A プログラム ウィンドウが最小化 (応答しない) ハング可能性がありますが復元されません正しくとは、2 つ目の最小化されたウィンドウが表示されます

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文書番号: 817611
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目次

現象

(状態で停止して、プログラムの最小化ウィンドウ「応答なし」Windows タスク マネージャーで) の正しくとリストアできません。クリックして、 復元 ボタン クリックします。また、ときに、プログラムではありません応答、2 つ目の最小化されたウィンドウを元のウィンドウの横に表示されます。2 番目のウィンドウで、移動することができますが、最初のウィンドウを維持、画面上書きされません。

原因

ゴースト ウィンドウの Windows XP のゴースト ウィンドウ機能を作成します。ウィンドウに、プログラムが正常に応答しない場合は、プログラムのメッセージ内のいくつか秒し、ハングアップするいると見なされます。この機能可能性があります。正しくない、最小化されたウィンドウのプロパティを復元しを作成可能性があります、最小化されたタイトル バー ウィンドウが元のウィンドウの横にある 2 番目しますが、上書きしません。そのためには。

解決方法

サービス パックの情報

解決するのにはこの問題は、Microsoft Windows XP 用の最新の service pack を入手します。の詳細については、「を表示するには、次の資料番号をクリックします。マイクロソフト サポート技術。
322389 Windows XP の最新の service pack を入手する方法

修正プログラムの情報

サポートされている修正プログラムがマイクロソフトから入手可能です。ただし、この修正プログラムはこの資料に記載されている問題のみを修正するものです。この修正プログラムはこの問題が発生しているシステムにのみ適用されます。この修正プログラムは、今後さらにテストを受け取ることがあります。したがって、この問題で深刻な影響をされていない場合は、この修正プログラムを含む次のソフトウェア更新プログラムのリリースを待つことをお勧めします。

この修正プログラムがダウンロードできないか場合は、この記事の上部に「修正プログラムのダウンロード」セクションです。このセクションが表示されない場合は、マイクロソフト カスタマー サービス & サポート修正プログラムを入手するに問い合わせてください。

メモ その他の問題が発生した場合、またはトラブルシューティングが必要な場合は、別のサービス リクエストを作成する必要があります。追加の質問およびこの特定の修正プログラムの対象とならない問題については、通常のサポート料金が適用されます。一覧マイクロソフト カスタマー サービス & サポートの電話番号のまたは別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
メモ 「修正プログラムのダウンロード」フォームに修正プログラムが提供されている言語を表示します。お使いの言語が表示されない場合は、修正プログラムがその言語の利用できないためにです。 英語版この修正プログラムはファイル属性があります (またはそれ以降) 次のいます。テーブルです。協定では、日付および時刻これらのファイルに記載されています。時刻 (UTC)。ファイル情報を表示すると、ローカル時刻に変換します。UTC とローカル時刻との時差を確認するを使用して、 時間ゾーン タブ コントロール パネルの日付と時刻ツールでします。
   Date         Time   Version         Size       File name    Platform
   --------------------------------------------------------------------
   15-Jul-2003  21:01  5.1.2600.1247   1,677,056  Win32k.sys   x86
   15-Jul-2003  21:01  5.1.2600.1247   5,619,840  Win32k.sys   IA-64

回避策

アプリケーションの互換性 Toolkit を出すことができます。幽霊を無効にするカスタム アプリケーションの互換性データベースをインストールします。プログラムのウィンドウの機能します。アプリケーションの互換性をダウンロードするのにはToolkit は、次のマイクロソフト Web サイトを参照してください。
http://msdn2.microsoft.com/en-us/library/aa286552.aspx
カスタム アプリケーションの互換性データベースを作成するのには
  1. インストールし、(追加、互換性アドミニストレーターを実行します。は、 /x コマンド ・ ラインの高度な機能を切り替えます)。
  2. 右クリックします。 カスタム データベース、し、クリックしてください。 新しい.
  3. 新しいデータベースを右クリックしをクリックしてください名前を変更します。.
  4. 種類 noghost 名前、データベースです。
  5. 右クリックします。 新しいデータベースをクリックして新規作成します。、し アプリケーションの修正プログラムを適用します。.修正するプログラムの名前を入力します。
  6. プログラムの製造元の名前を入力します。
  7. 選択し、[適切なプログラム (.exe)] をクリックしてくださいファイルです。
  8. クリックしてください。 次へします。
  9. で、 互換性モード [ウィンドウ] をクリックして[なし]、し 次へ.
  10. で、 互換性修正プログラム ボックスの一覧でクリックしてくださいNoGhost.
  11. いずれかをクリックします。 テストの実行 または終了日.クリックすると テストの実行 プログラムを起動します。アプリケーション互換性の設定を使用します。クリックすると 終了日互換性修正プログラムを追加します。
  12. で、 ファイル メニューをクリックして保存 データベースを保存します。または、コピーするデータベースには、C:\Windows\AppPatch フォルダー。
  13. データベースを右クリックしをクリックしてくださいインストール.また、実行、 sdbinstc:\windows\apppatch\noghost.sdb q データベースをインストールするには、[コマンド] をクリックします。

詳細


次の情報については、 GetMessage 関数は、Windows のゴースト ウィンドウ機能に記載されています。XP。詳細については、次のマイクロソフト Web サイトを参照してください。
GetMessage 関数
トップレベル ウィンドウの詳細についてはメッセージへの応答を停止するかどうか数秒よりもシステムが停止して、ウィンドウを考慮され、置き換えられますこれは、同じ z オーダー、場所、サイズ、および視覚を持つゴースト ウィンドウで属性。これはそうの移動や、サイズを変更すると、ユーザーできます、アプリケーションです。ただし、これら以外の処理に利用可能ですので、アプリケーションは実際にハングしています。デバッガー モードで、システムはありません。ゴースト ウィンドウは作成します。

状況

マイクロソフトこれに記載されているマイクロソフト製品の問題であることを確認しています「対象」のセクションで。 Microsoft ではこの問題は修正されましたWindows XP Service Pack 2。

プロパティ

文書番号: 817611 - 最終更新日: 2011年7月28日 - リビジョン: 2.0
キーワード:?
kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver kbautohotfix kbmt KB817611 KbMtja
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英語版 KB:817611
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