Een geminimaliseerd programmavenster dat niet meer reageert (is vastgelopen) kan niet worden geactiveerd en er wordt een tweede geminimaliseerd venster geopend

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 817611 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Het formaat van een geminimaliseerd venster van een vastgelopen programma (met de status 'Reageert niet' in Windows Taakbeheer) wordt niet juist hersteld wanneer u klikt op de knop Vorig formaat. Tevens wordt, terwijl het programma niet reageert, een tweede geminimaliseerd venster weergegeven naast het oorspronkelijke venster. Het tweede venster kan worden verplaatst, maar het eerste venster blijft op de plaats waar het schermgebied nog niet is overschreven.

Oorzaak

De Ghost Window-functie van Windows XP maakt substitutievensters namens een programma wanneer het desbetreffende programma binnen enkele seconden niet juist reageert op vensterberichten (waardoor ervan wordt uitgegaan dat het programma is vastgelopen). Deze functie herstelt de eigenschappen van een geminimaliseerd venster niet op de juiste manier en kan een tweede geminimaliseerd venster in de titelbalk maken dat wordt weergegeven naast het eerste venster, maar dit niet overschrijft.

Oplossing

Informatie over het servicepack

U kunt dit probleem oplossen met het laatste servicepack voor Microsoft Windows XP. Klik voor meer informatie op het volgende artikelnummer in de Microsoft Knowledge Base:
322389 Het meest recente service pack voor Windows XP ophalen

Informatie over hotfixes

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld als oplossing van het probleem dat in dit artikel wordt beschreven. Voer deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet mogelijk extra worden getest. Als u geen ernstige problemen ondervindt, raadt Microsoft u daarom aan te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix kan worden gedownload, is aan het begin van dit Knowledge Base-artikel een sectie 'Hotfix kan worden gedownload' opgenomen. Als een dergelijke sectie niet aanwezig is, kunt u de hotfix aanvragen bij de klantondersteuning van Microsoft.

Opmerking Als er nog andere problemen optreden of als er oplossingen vereist zijn, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking komen voor deze specifieke hotfix. Bezoek de volgende website van Microsoft voor een volledige lijst met telefoonnummers van de klantondersteuning van Microsoft of om een afzonderlijk serviceverzoek te maken:
http://support.microsoft.com/contactus/?ws=support
Opmerking Op het formulier 'Hotfix kan worden gedownload' zijn de talen vermeld waarvoor de hotfix beschikbaar is. Als uw taal daar niet bij staat, is de hotfix niet voor die taal beschikbaar. De Engelse versie van deze correctie heeft de bestandskenmerken die in de volgende tabel worden weergegeven (of recentere kenmerken). De datums en tijden voor deze bestanden worden weergegeven in UTC-notatie (Coordinated Universal Time). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Als u het verschil tussen UTC en lokale tijd wilt bepalen, gebruikt u het tabblad Tijdzone van de optie Datum en tijd in het Configuratiescherm.
   Datum         Tijd   Versie      Grootte     Bestandsnaam    Platform
   --------------------------------------------------------------------
   15-jul-2003  21:01  5.1.2600.1247   1.677.056  Win32k.sys   x86
   15-jul-2003  21:01  5.1.2600.1247   5.619.840  Win32k.sys   IA-64

Workaround

Met de Application Compatibility Toolkit kunt u een aangepaste Application Compatibility-database maken en installeren om de Ghost Window-functie voor uw programma uit te schakelen. Ga naar de volgende Microsoft-website om de Application Compatibility Toolkit te downloaden:
http://msdn.microsoft.com/nl-nl/library/aa286552(en-us).aspx
U maakt als volgt een aangepaste Application Compatibility-database:
  1. Installeer het hulpprogramma Compatibility Administrator en voer dit uit (gebruik de schakeloptie /x op de opdrachtregel voor geavanceerde functies).
  2. Klik met de rechtermuisknop op Custom Database en klik op Nieuw.
  3. Klik met de rechtermuisknop op de nieuwe database en klik op Rename.
  4. Typ noghost als de naam van de database.
  5. Klik met de rechtermuisknop op New Database en klik achtereenvolgens op Create New en Application Fix. Typ de naam van het bestand dat moet worden gecorrigeerd.
  6. Typ de naam van de fabrikant van het programma.
  7. Ga naar het desbetreffende programmabestand (EXE-bestand) en klik hierop.
  8. Klik op Next.
  9. Klik op None in het venster Compatibility Modes en klik op Next.
  10. Klik op NoGhost in de lijst Compatibility Fixes.
  11. Klik op Test Run of Finish. Wanneer u op Test Run klikt, wordt het programma gestart met de Application Compatibility-instelling. Wanneer u op Finish klikt, wordt de compatibiliteitscorrectie toegevoegd aan uw database.
  12. Open het menu File en klik op Save om de database op te slaan. U kunt de database ook kopiëren naar de map C:\Windows\AppPatch.
  13. Klik met de rechtermuisknop op de database en klik op Install. U kunt ook de opdracht sdbinst c:\windows\apppatch\noghost.sdb -q uitvoeren om de database te installeren.

Meer informatie


Over de functie GetMessage is de volgende informatie gedocumenteerd voor de Ghost Window-functie in Windows XP. Ga voor meer informatie naar de volgende Microsoft-website:
Functie GetMessage
Als een venster op het hoogste niveau langer dan enkele seconden niet meer reageert op berichten, gaat het systeem ervan uit dat het venster hangt (is vastgelopen) en wordt het vervangen door een substitutievenster met dezelfde z-volgorde, locatie, grootte en visuele kenmerken. Zo kan de gebruiker het venster verplaatsen, het formaat van het venster wijzigen of zelfs de toepassing afsluiten. Omdat de toepassing is vastgelopen, zijn dit echter de enige beschikbare acties. In de foutopsporingsmodus genereert het systeem geen substitutievenster.

Status

Microsoft heeft bevestigd dat dit probleem zich kan voordoen in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'. In Microsoft Windows XP Service Pack 2 is voor het eerst een correctie opgenomen voor dit probleem.

Eigenschappen

Artikel ID: 817611 - Laatste beoordeling: woensdag 31 december 2008 - Wijziging: 6.3
De informatie in dit artikel is van toepassing op:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Media Center Edition
Trefwoorden: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB817611

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com