Свернутое окно зависшего приложения не разворачивается, и появляется второе свернутое окно

Переводы статьи Переводы статьи
Код статьи: 817611 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

Свернутое окно зависшей программы (которая в диспетчере задач Windows находится в состоянии «Не отвечает») неправильно разворачивается при нажатии кнопки Восстановить. Когда программа зависла (не отвечает), рядом с исходным окном может появиться второе свернутое окно. Второе окно можно переместить, но первое окно остается там, где экран еще не был обновлен.

Причина

Если программа несколько секунд не отвечает на сообщения окна и считается зависшей, функция Ghost Window операционной системы Windows XP создает второе окно программы. Эта функция может неправильно восстановить свойства свернутого окна и создать второе свернутое окно со строкой заголовка за исходным окном, не перезаписывая его.

Решение

Сведения о пакете обновления

Чтобы решить эту проблему, установите последний пакет обновления для Windows XP. Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
322389 Как получить последний пакет обновления для Windows XP

Сведения об исправлении

Корпорация Майкрософт выпустила исправление, однако оно предназначено исключительно для устранения проблемы, описанной в этой статье. Это исправление необходимо применять только в тех системах, в которых наблюдается данная проблема. Исправление может проходить дополнительное тестирование. По этой причине корпорация Майкрософт рекомендует во всех случаях, когда проблема не представляет особой важности, отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, в верхней части статьи базы знаний отображается раздел «Исправление доступно для загрузки». Если этот раздел не отображается, обратитесь в службу поддержки пользователей Майкрософт, чтобы получить данное исправление.

Примечание. Если возникли другие проблемы или необходимо устранить неполадки, возможно, потребуется создать отдельный запрос. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются на стандартных условиях. Чтобы получить полный список телефонных номеров службы поддержки пользователей корпорации Майкрософт или создать отдельный запрос, посетите веб-узел корпорации Майкрософт по следующему адресу:
http://support.microsoft.com/contactus/?ws=support
Примечание. В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если нужный язык не отображается, это означает, что исправление для данного языка отсутствует. Английская версия исправления содержит версии файлов, приведенные в следующей таблице, или более поздние. Дата и время указаны в формате UTC. При просмотре сведений о файле в системе происходит перевод соответствующих значений в местное время. Чтобы узнать разницу между временем в формате UTC и местным временем, откройте вкладку Часовой пояс элемента «Дата и время» на панели управления.
   Дата         Время Версия     Размер Имя файла Платформа
   --------------------------------------------------------------------
   15-июл-2003  21:01  5.1.2600.1247   1,677,056  Win32k.sys   x86
   15-июл-2003  21:01  5.1.2600.1247   5,619,840  Win32k.sys   IA-64

Временное решение

Используйте набор средств для совместимости приложений Application Compatibility Toolkit, чтобы создать и установить пользовательскую базу данных совместимости приложений и отключить функцию Ghost Window для той или иной программы. Загрузить набор средств для совместимости приложений Application Compatibility Toolkit можно со следующего веб-узла корпорации Майкрософт:
http://msdn2.microsoft.com/en-us/library/aa286552.aspx
Чтобы создать пользовательскую базу данных совместимости приложений, выполните следующие действия.
  1. Установите и запустите средство администрирования совместимости (добавьте параметр /x в командной строке, чтобы просмотреть расширенные возможности).
  2. Щелкните правой кнопкой мыши параметр Custom Database и выберите команду New.
  3. Щелкните новую базу данных правой кнопкой мыши и выберите пункт Rename.
  4. В качестве имени базы данных введите noghost.
  5. Щелкните правой кнопкой мыши вариант New Database, выберите пункт Create New, а затем — команду Application Fix. Введите имя программы, которую нужно исправить.
  6. Введите имя разработчика программы.
  7. Найдите и выберите соответствующий EXE-файл программы.
  8. Нажмите кнопку Next.
  9. В окне Compatibility Modes выберите вариант None, а затем нажмите кнопку Next.
  10. В списке Compatibility Fixes выберите вариант NoGhost.
  11. Нажмите кнопку Test Run или кнопку Finish. Нажатие кнопки Test Run приведет к запуску программы с параметром Application Compatibility. Нажатие кнопки Finish приведет к добавлению исправления совместимости в базу данных.
  12. В меню File выберите команду Save, чтобы сохранить базу данных. Можно также скопировать базу данных в папку C:\Windows\AppPatch.
  13. Щелкните файл базы данных правой кнопкой мыши и выберите команду Install, либо для установки базы данных выполните команду sdbinst c:\windows\apppatch\noghost.sdb -q.

Дополнительная информация


О функции GetMessage служебной программы Ghost Window в Windows XP существуют следующие сведения. Дополнительные сведения см. на следующем веб-узле корпорации Майкрософт:
GetMessage Function
Если окно верхнего уровня не отвечает на сообщения несколько секунд, система считает, что окно зависло и замещает его вторым окном, которое имеет такой же порядок элементов, расположение, размер и визуальные атрибуты, как и исходное окно. Пользователь получает возможность перемещать окно, масштабировать его и даже закрывать приложение. Тем не менее, доступны только эти действия, потому что приложение на самом деле зависло. Находясь в режиме отладки, система не создает второе окно.

Статус

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в разделе «Информация в данной статье применима к». Первое исправление этой проблемы появилось в пакете обновления 2 (SP2) для Windows XP.

Свойства

Код статьи: 817611 - Последний отзыв: 11 сентября 2008 г. - Revision: 6.1
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Media Center Edition
Ключевые слова: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB817611

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com