Article ID: 817686 - Last Review: December 3, 2007 - Revision: 4.10

Computer Stops Responding When Running BPStress.exe, Error in UsbhFdoCleanup Process

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SYMPTOMS

BPStress.exe is part of the Hardware Compatibility Test (HCT) Fault Tolerant test kit. When you run BPStress.exe, the computer may stop responding and you may receive a "bugcheck" error message on the UsbhFdoCleanup process.

CAUSE

This behavior may occur when BPStress.exe causes a failure on a node during the stress test, and then moves to a backup node. During this failover mode, the USB host controllers and root hubs are removed, and this causes the error.

No USB devices must be attached to the computer for this error to occur.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------------
   31-Mar-2003  18:08  5.2.3790.2         54,784  Usbhub.sys
   29-Mar-2003  02:41                        211  Branches.inf
   31-Mar-2003  19:32                     10,091  Kb817686.cat
   31-Mar-2003  19:17                        354  Updatebr.inf
   31-Mar-2003  19:18                      5,136  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwinserv2003presp1fix KB817686