Mensaje de error "Was Unable formatear la unidad de instalación" aparece durante la restauración

Seleccione idioma Seleccione idioma
Id. de artículo: 817708 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Mientras lleva a cabo una restauración de recuperación automática del sistema (ASR) en un equipo Itanium (IA64), puede recibir el siguiente mensaje de error:
El programa de instalación no pudo formatear la unidad
El proceso de ASR da formato a una partición completamente. ASR parece dar formato correctamente a la segunda partición, pero a continuación, recibirá el mensaje de error. En este momento, debe reiniciar el equipo. Pero, porque ya se ha formateado la partición de sistema operativo (la partición de inicio), no puede reiniciar correctamente el equipo.

Causa

La primera partición que tiene el formato es la partición que está el sistema operativo. La partición de segunda que se ha dado formato es la partición de sistema de interfaz de firmware extensible (EFI), pero el proceso de formato falla porque el archivo ASR.sif que está en el disquete de ASR tiene el valor incorrecto para "sectores por cluster"

Solución

La resolución que se describe en este artículo es una medida preventiva. Si están en una situación donde debe restaurar para acceder al sistema operativo nuevo, consulte la sección "Solución" de este artículo.

Windows Server 2003

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Syssetup.dll5.2.3790.501,833,98406-Jun-200316: 10IA-64

Windows XP

Información de Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Windows XP. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Información de revisiones

Requisitos previos

Para aplicar este hotfix, debe tener instalado en el equipo Windows XP Service Pack 1 (SP1).

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Syssetup.dll5.1.2600.12321,807,87206-Jun-200316: 17IA-64

Solución

Para evitar este problema, corrija el archivo ASR.sif para que pueda iniciar el proceso de restauración de ASR en el equipo.

Este procedimiento utiliza un archivo de ejemplo ASR.sif. El archivo ASR.sif que utiliza tendrá un aspecto similar, pero los números será diferentes. Coloque el disquete de ASR creado durante el proceso de copia de seguridad de ASR en otro equipo. Abra el archivo ASR.sif en un editor de texto, como el Bloc de notas. La sección correspondiente de ASR.sif será similar al siguiente:
[PARTITIONS.GPT]
1=1,0,2,,"C12A7328-F81F-11D2-BA4B-00A0C93EC93B","0a575940-189b-01c3-92e0-3c772e43ac40",0x1,"EFI partición del sistema", 0 x 06, 63, 706797, 0 x 1000
2=1,1,0,,"E3C9E316-0B5C-4DB8-817D-F92DF00215AE","a142f920-1af0-01c3-a1f4-04622fd5ec6d",0x0,"Microsoft reservado partición", 0 x 00, 706860, 257040, 0 x 0
3=1,2,1,,"ebd0a0a2-b9e5-4433-87c0-68b6b72699c7","b126f760-1af0-01c3-92e0-3c772e43ac40",0x0,"Basic partición de datos", 0 x 07, 963900, 20482875, 0 x 1000
Nota Las líneas en este ejemplo se ajustan para mejorar la legibilidad.

La línea sólo importante es la línea de partición de sistema EFI:
1=1,0,2,,"C12A7328-F81F-11D2-BA4B-00A0C93EC93B","0a575940-189b-01c3-92e0-3c772e43ac40",0x1,"EFI partición del sistema", 0 x 06, 63, 706797, 0 x 1000
La partición de sistema EFI es la partición que está produciendo el error para dar formato. Debe conocer el tamaño de esta partición. Tomar el valor 706797 (el último segundo número en esa línea) y multiplíquelo por 512. Esto es igual a 361,880,064. Esto significa que el sistema de ejemplo tiene una partición de sistema EFI de unos 361 MB. Compare este valor para la tabla siguiente:

	   Drive size            
(logical volume)      FAT type   Sectors     Cluster size (decimal)     Cluster size (hexadecimal)
------------------------------------------------------------------------------------------
15 MB or less         12-bit       8           4096                      0x1000
16 MB - 127 MB        16-bit       4           2048                      0x800
128 MB - 255 MB       16-bit       8           4096                      0x1000
256 MB - 511 MB       16-bit      16           8192                      0x2000
512 MB - 1,023 MB     16-bit      32          16384                      0x4000
1,024 MB - 2,048 MB   16-bit      64          32768                      0x8000

Esto significa que debe formatear esta partición de ejemplo con clústeres de 8 KB (8.192 bytes). Sin embargo, el archivo se indica a formato de clústeres de 4 KB (4096 bytes) (el último número de la misma línea, 0 x 1000, es igual a 4096 en formato decimal). Por lo tanto, debe cambiar 0 x el 0 x 1000 a 2000 (el equivalente decimal de 0 x 2000 es 8.192).

La nueva versión de la línea es:
1=1,0,2,,"C12A7328-F81F-11D2-BA4B-00A0C93EC93B","0a575940-189b-01c3-92e0-3c772e43ac40",0x1,"EFI partición del sistema", 0 x 06, 63, 706797, 0 x 2000

Guarde el archivo e inicie el proceso de restauración de ASR con el disquete ASR modificado. Ahora debe completar el proceso.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo.

Referencias

Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
820364 El archivo Setupldr.efi no puede leer el disco de recuperación automática del sistema o el archivo Winnt.sif de una unidad disquete USB en Windows Server 2003

Propiedades

Id. de artículo: 817708 - Última revisión: sábado, 01 de diciembre de 2007 - Versión: 2.10
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002 SP1
Palabras clave: 
kbmt kbautohotfix kbwinxppresp2fix kbhotfixserver kbbug kbfix kbqfe kbwinserv2003presp1fix KB817708 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 817708

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com