Network Monitor protocol causes "Stop error code 0x000000D1 (DRIVER_IRQL_NOT_LESS_OR_EQUAL)" when closing adapter

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Article ID: 817864
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SYMPTOMS

After you exit from the Network Monitor program, your computer may stop responding (hang), and you may receive the following error message on a blue screen:
STOP 0x000000d1 (0x00000000,0x00000002,0x00000000,0xF9C8D886)
Note The last parameter of the stop code may differ.

CAUSE

This problem may occur if Network Monitor's protocol driver, Nmnt.sys, is unloaded under certain circumstances.
Some network adapter miniports or Network Driver Interface Specification (NDIS) intermediate drivers send the status message of "NDIS_STATUS_CLOSING" to bound protocols when shutting down. This NDIS status causes Network Monitor's protocol driver to fail with the bugcheck error: DRIVER_IRQL_NOT_LESS_OR_EQUAL (0xd1)

Network adapter miniports or NDIS drivers do not have to indicate NDIS_STATUS_CLOSING, and when possible, drivers that do so must be corrected. However, in those scenarios where this cannot be done, this hotfix contains a replacement Network Monitor protocol driver that can correctly handle this status.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   01-Apr-2003  20:32  5.0.2195.6699      37,552  Nmnt.sys


				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product

Properties

Article ID: 817864 - Last Review: January 31, 2012 - Revision: 3.0
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwin2ksp4fix kberrmsg kbprb kbddk kbwin2000presp4fix kbfix kbbug KB817864

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