Help and Support
 

powered byLive Search

Error Event 1109 Appears in the Event Log When Terminal Services Clients Disconnect

Article ID:817870
Last Review:December 3, 2007
Revision:5.4

SYMPTOMS

When you disconnect a Terminal Services session from a Windows Server 2003 server, an event similar to the following appears in the System log of the Event Viewer on the server:
Date:     <date>        Source:   TermServDevices
Time:     <time>        Category: None
Type:     Error         Event ID: 1109
User:     N/A
Computer: <Servername>

Description:
The printer <printername> on <share> (of <client-computer>) in meeting 1
could not be specified as standard printers. 

For more information, see Help and Support Center at
http://support.microsoft.com

Data:
0000: 09 07 00 00 58 15 00 00 ....X...
This event indicates that the system cannot set the default printer. This issue occurs even though the default printer was correctly set.

Back to the top

CAUSE

This error event is incorrectly logged, and it occurs when both of the following conditions are true:
The Terminal Services client has more than one redirected print queue.

-and-
The Terminal Services client disconnects from the terminal server.
This issue occurs because the terminal server does not remove the redirected printer queues in the same order that it created them in. When a client with multiple redirected printer queues disconnects from the terminal server, the server may try to restore redirected printer queues that have already been removed. This process is unsuccessful because the client is in the process of disconnecting from the terminal server, and therefore the event is logged.

Back to the top

WORKAROUND

To work around this issue, ignore this error event.

Back to the top

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

Back to the top


APPLIES TO
Microsoft Windows Server 2003, Enterprise x64 Edition
Microsoft Windows Server 2003, 64-Bit Datacenter Edition
Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Microsoft Windows Small Business Server 2003 Premium Edition
Microsoft Windows Small Business Server 2003 Standard Edition

Back to the top

Keywords: 
kbpending kbbug KB817870

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.