FIX: Undesirable User Experience During Certain Windows Media Services 9 Series Broadcast and On-Demand Scenarios

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Article ID: 818127 - View products that this article applies to.
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SYMPTOMS

Users may experience excessive rebuffering or stream thinning during playback in either of the following scenarios:
  • When doing live streaming of higher bitrate content

    - or -
  • When doing on-demand streaming where the files are located on a remote storage server by means of an SMB connection.

CAUSE

Each scenario has a different cause for the problem.

Live Streaming

This optimization is recommended if the following two conditions are true:
  • Live broadcasts that exceeds one minute in length
  • Using TCP-based protocols
If both conditions are true, Microsoft recommends that you apply this fix to resolve a misalignment within two internal server configuration parameters.

On-Demand Streaming

This optimization is recommended if the following condition is true:
  • SMB Connections -- The SMB protocol has a limitation on the maximum number of commands that it can be executing with a remote connection. By default, the SMB protocol has a limit of 50 commands per connection. The Server uses one of these commands for every unique directory from which it could be reading data. This is to get any change notification that may occur for that directory. Because of how SMB manages these calls, under heavy load, end users may experience poor playback.

    In addition to applying the fix, you must set the Only File Read Share namespace value to 0x1. For additional information about setting this namespace value, click the following article number to view the article in the Microsoft Knowledge Base:
    812633 HOWTO: Improve Server Performance when Streaming On-Demand Content from a Remote Share

RESOLUTION

The following file is available for download from the Microsoft Download Center:
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Download
Download the 818127 package now.

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Apr-2003  21:04  9.0.0.3374      2,533,888  Wmsserver.dll     

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

Properties

Article ID: 818127 - Last Review: February 27, 2014 - Revision: 3.0
APPLIES TO
  • Microsoft Windows Media Services 9 Series
Keywords: 
kbnosurvey kbarchive kbdownload kbfile kbfix KB818127

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