Artigo: 818143 - Última revisão: quinta-feira, 6 de Outubro de 2005 - Revisão: 2.2

Direct Mailer tarefa é efectuada sem êxito quando Direct Mailer recurso não está com alias para DBO

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Sintomas

Quando executa uma tarefa Direct Mailer a partir da linha de comandos, não tem êxito e receberá a seguinte mensagem de erro:
[Data de trabalho]
JobDesc = TemplateURL=http://hostname/email_template.asp Direct Mailer de teste do CONCEITO
MailFrom=user@company.com
DefaultFmt = 3
MailingListType = 3
MailPersonalize = 1
MailingListLocation = driver = {SQL Server}; SERVER = nomeservidor; DATABASE = site_profile; UID = ID do utilizador; PWD = palavra-passe;
MailingListSQL = EXECUTE UspGetMailingList

[Resultados]
Código de erro =-2147024891
Idtrab = ErrorString = Não foi possível [Commerce Server Direct Mailer] para criar nova lista de correio para a tarefa '{4933080A-7540-4A79-9FD3-B9C051C2D22C}': não foi possível criar instâncias do objecto de ListManager
Isto só ocorre se o recurso Direct Mailer estiver configurado para utilizar SQL autenticação e a conta é um proprietário de base de dados que não seja alternativo para DBO.

Causa

Este problema ocorre se a cadeia de ligação do recurso global Direct Mailer está configurada para utilizar a autenticação de SQL ("utilizar um nome de utilizador específico e a palavra-passe") e se a conta do utilizador especificada não é alternativo para DBO. Até o proprietário da base de dados irá falhar a menos que o utilizador com alias para DBO.

Resolução

Agora é disponibilizada pela Microsoft uma correcção suportada, mas destina-se apenas a corrigir o problema descrito neste artigo. Aplique-a apenas em sistemas que tenham este problema específico. Esta correcção poderá ser submetida a testes adicionais para garantir a qualidade do produto. Por conseguinte, se não estiver a ser gravemente afectado por este problema, a Microsoft recomenda que aguarde pelo próximo service pack do Commerce Server 2002 que contenha esta correcção.

Para resolver este problema imediatamente, contacte o suporte técnico da Microsoft para obter a correcção. Para obter uma lista completa de números de telefone do suporte técnico da Microsoft e informações sobre os custos de suporte, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms)
Nota Em casos especiais, os custos normalmente inerentes às chamadas de suporte poderão ser anulados, se um técnico de suporte da Microsoft determinar que uma actualização específica resolverá o problema. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem na atualização específica em questão.

A versão inglesa desta correcção tem os atributos de ficheiro (ou posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time   Version      Size     File name
   ---------------------------------------------------------
   23-Apr-2003  01:08  4.5.3051.0   297,076  Listmanager.exe  
				

Como contornar

Para contornar este problema, execute o seguinte comando no SQL Query Analyzer:
Run sp_addalias 'account', 'dbo'

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a" deste artigo.

A informação contida neste artigo aplica-se a:
  • Microsoft Commerce Server 2002 Service Pack 1
Palavras-chave: 
kbmt kbbug kbfix KB818143 KbMtpt
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