ID do artigo: 818143 - Última revisão: quinta-feira, 6 de outubro de 2005 - Revisão: 2.2

Trabalho Direct Mailer É sem êxito quando o recurso Direct Mailer não está com alias para DBO

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Quando você executa um trabalho de Direct Mailer de uma linha de comando, é malsucedida e você receber a seguinte mensagem de erro:
[Data de trabalho]
JobDesc = VDC Direct Mailer TemplateURL=http://hostname/email_template.asp
MailFrom=user@company.com
DefaultFmt = 3
MailingListType = 3
MailPersonalize = 1
MailingListLocation = driver = {SQL Server}; SERVER = nome_do_servidor; DATABASE = site_profile; UID = userid; PWD = senha;
MailingListSQL = EXECUTE UspGetMailingList

[Resultados]
ErrorCode =-2147024891
JobID = ErrorString = [Commerce Server Direct Mailer] Falha ao criar nova lista de endereçamento para o trabalho '{4933080A-7540-4A79-9FD3-B9C051C2D22C}': Falha ao criar uma instância de objeto ListManager
Isso ocorre apenas se o recurso Direct Mailer é configurado para usar SQL autenticação e a conta é um proprietário de banco de dados que não é um alias para DBO.

Causa

Esse problema ocorre se a seqüência de conexão do recurso global Direct Mailer é configurada para usar autenticação SQL ("usar um nome de usuário específico e senha") e se a conta do usuário especificada não é alias para DBO. Até mesmo o proprietário do banco de dados falhará a menos que o usuário é alias para DBO.

Resolução

Uma correção suportada está agora disponível da Microsoft, mas destina-se somente a corrigir o problema descrito neste artigo. Aplique-o somente nos sistemas que apresentarem esse problema específico. Pode ser nessa correção testes adicionais para garantir ainda mais a qualidade do produto. Portanto, se você não tiver sido gravemente afetado por esse problema, a Microsoft recomenda que você aguarde o próximo service pack do Commerce Server 2002 que contém esse hotfix.

Para resolver esse problema imediatamente, contate o Atendimento Microsoft para obter a correção. Para obter uma lista completa dos números de telefone do Atendimento Microsoft do e informações sobre os custos de suporte, visite o seguinte site:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms)
Observação Em alguns casos, as taxas cobradas pelas ligações para chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas que não se qualificam à atualização específica em questão de suporte adicionais.

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version      Size     File name
   ---------------------------------------------------------
   23-Apr-2003  01:08  4.5.3051.0   297,076  Listmanager.exe  
				

Como Contornar

Para contornar esse problema, execute o seguinte comando no SQL Query Analyzer:
Run sp_addalias 'account', 'dbo'

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft que estão listados na seção "Aplica-se a" deste artigo.

A informação contida neste artigo aplica-se a:
  • Microsoft Commerce Server 2002 Service Pack 1
Palavras-chave: 
kbmt kbbug kbfix KB818143 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 818143  (http://support.microsoft.com/kb/818143/en-us/ )