Autenticación puede fallar intermitentemente

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Síntomas

Cuando configura un entorno de aplicación de Web de tres niveles que utiliza la autenticación Kerberos, puede intermitentemente encontrar a ese cliente produce un error de autenticación. Por ejemplo, en el siguiente escenario, el vale que concede vales (TGT) pueden caducar antes de que el cliente se autentica al equipo de destino que está ejecutando Microsoft SQL Server:
  1. El cliente se conecta a un Microsoft Internet Information servidor Web Services (IIS).
  2. El cliente reenvía el TGT al servidor IIS.
  3. El servidor IIS se conecta con un equipo que ejecuta SQL Server utilizando el vale se reenvió por el cliente (Kerberos delegación).
La función de InitializeSecurityContext devuelve un código de error SEC_E_NO_CREDENTIALS en el SQL aplicación en el servidor Web. Además, el cliente recibe la mensaje de error siguientes:
No se puede generar SSPI Context

Causa

Este problema puede producirse si la función AcquireCredentialsHandle devuelve una hora de caducidad incorrecto para el TGT. Parámetro de la función AcquireCredentialsHandle ptsExpiry no refleja la duración correcta de en el TGT reenviado.

Solución

Información de revisiones

Microsoft Windows 2000

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Esta revisión requiere Windows 2000 Service Pack 4 (SP4).
Requisito de reinicio
Una vez aplicado este hotfix, debe reiniciar el equipo.
Información acerca de la sustitución de la revisión
Este hotfix no sustituye a otros hotfix.
Información de archivo
La versión en inglés de esta dispone de los atributos de archivo (o atributos de archivo más reciente) mostrados en la tabla siguiente. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Adsldp.dll5.0.2195.6748124,68819-Jun-200305: 28x 86
Adsldpc.dll5.0.2195.6748132,36819-Jun-200305: 28x 86
Adsmsext.dll5.0.2195.674863,76019-Jun-200305: 28x 86
Advapi32.dll5.0.2195.6743381,20019-Jun-200305: 28x 86
Browser.dll5.0.2195.675369,39206-Jun-200304: 53x 86
Dnsapi.dll5.0.2195.6680134,92819-Jun-200305: 28x 86
Dnsrslvr.dll5.0.2195.666392.43219-Jun-200305: 28x 86
EventLog.dll5.0.2195.675347,37619-Jun-200305: 28x 86
Kdcsvc.dll5.0.2195.6747148,24019-Jun-200305: 28x 86
Kerberos.dll5.0.2195.6758205,07218-Jun-200302: 43x 86
Ksecdd.sys5.0.2195.669571,88826-Mar-200306: 37x 86
Lsasrv.dll5.0.2195.6749509,71228-May-200305: 39x 86
Lsass.exe5.0.2195.674933.55228-May-200305: 39x 86
Msv1_0.dll5.0.2195.6680117,52004-Abr-200309: 12x 86
Netapi32.dll5.0.2195.6601311,56819-Jun-200305: 28x 86
Netlogon.dll5.0.2195.6695371,98419-Jun-200305: 28x 86
Ntdsa.dll5.0.2195.66971,040,14419-Jun-200305: 28x 86
Samsrv.dll5.0.2195.6742392,46419-Jun-200305: 28x 86
Scecli.dll5.0.2195.6737131,34419-Jun-200305: 28x 86
Scesrv.dll5.0.2195.6737306,44819-Jun-200305: 28x 86
Sp3res.dll5.0.2195.67564,576,76817-Jun-200302: 54x 86
W32Time.dll5.0.2195.660151,47219-Jun-200305: 28x 86
W32tm.exe5.0.2195.660157,10415-Ago-200222: 32x 86
Wldap32.dll5.0.2195.6741126,22419-Jun-200305: 28x 86
Nota En el servidor IIS y en el cliente se debe aplicar este hotfix.

Microsoft Windows XP

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Esta revisión requiere Windows XP Service Pack 1 (SP1).
Requisito de reinicio
Una vez aplicado este hotfix, debe reiniciar el equipo.
Información acerca de la sustitución de la revisión
Este hotfix no sustituye a otros hotfix.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control. Microsoft Windows XP Service Pack 1 (SP1), las versiones de 32 bits
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Kerberos.dll5.1.2600.1228273,92030-May-200305: 38x 86
Microsoft Windows XP Service Pack 1 (SP1), versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Kerberos.dll5.1.2600.1228929,79230-May-200305: 39IA-64
Wkerberos.dll5.1.2600.1228273,92030-May-200311: 05x 86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura de archivos para los paquetes de actualización de software de Microsoft Windows

Propiedades

Id. de artículo: 818173 - Última revisión: jueves, 26 de octubre de 2006 - Versión: 5.4
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows XP Service Pack 1
Palabras clave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbpubtypekc kbbug kbfix kbwin2000presp5fix KB818173 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 818173

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