Exchange Server 2003 Setup returns error code 0x80072030 when you run setup.exe /domainprep

Article translations Article translations
Article ID: 818470 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

In Exchange Server 2003, when you run the command setup.exe /domainprep to prepare your domain, you may experience one of the following symptoms:
  • During the Microsoft Exchange Domain Preparation portion of Setup, you receive the following error message:
    Setup failed while installing sub-component Domain-level permissions with error code 0x80072030 (please consult the installation logs for a detailed description). You may cancel the installation or try the failed step again.
    When you click Cancel, and then click Microsoft Exchange Domain Preparation in the Component list that appears, the following information is displayed:
    An unspecified error has occurred.
    Additionally, when you view the Exchange Server Setup Progress.log file, you notice information similar to the following information:
    [14:52:11] Entering SCISDomainPrepped
    [14:52:11] Checking whether the domain "/dc=com/dc=example" is DomainPrepped
    [14:52:11] Looking for server groups
    [14:52:11] Entering ScGetExchangeServerGroups
    [14:52:11] Getting DOB for group 0
    [14:52:11] Getting string GUID for group 0
    [14:52:11] Getting string SID for group 0
    [14:52:11] Getting DOB for group 1
    [14:52:11] ScGetExchangeServerGroups (f:\df6903\admin\src\libs\exsetup\dsmisc.cxx:351)
              Error code 0x80072030 (8240): There is no such object on the server.
    [14:52:11] Leaving ScGetExchangeServerGroups
    [14:52:11] Server groups not found
    Note You do not experience this error message during Typical setup or reinstall modes because in those setup modes, a prerequisite check blocks the installation in the early stages of setup. The DomainPrep setup mode does not look for this prerequisite, and therefore Setup is not successful.
  • Setup completes the domain preparation successfully, but an additional Exchange Domain Servers security group is created in the Users container in Active Directory.
Note Setup may take a very long time to start in situations where you experience these symptoms.

CAUSE

This behavior may occur if the Exchange Domain Servers security group has been moved or renamed.

WORKAROUND

To work around this problem, make sure that the following security groups have not been renamed and are located in the Users container of your domain:
  • Exchange Enterprise Servers
  • Exchange Domain Servers
If the groups have been renamed or moved or both, rename the groups to their original names, move them to the Users container, and then run the setup.exe /domainprep command to prepare your domain.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server 2003.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
324949 Redirecting the Users and Computers containers in Windows Server 2003 domains
Note If you follow the steps in Knowledge Base article 324949, you will have to manually move the two groups back to the Default Users Container. The two groups that you have to move are Exchange Domain Servers Group and Exchange Enterprise Servers Group.

Properties

Article ID: 818470 - Last Review: October 25, 2007 - Revision: 2.5
APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Keywords: 
kberrmsg kbnofix kbbug KB818470

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com