Internet Explorer reagiert bei der Anforderung einer Vielzahl von Objekten scheinbar nicht mehr

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Artikel-ID: 818506 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
818506 Internet Explorer may appear to stop responding when requesting many objects
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Microsoft Internet Explorer reagiert bei der Anforderung einer Vielzahl von Objekten scheinbar nicht mehr (hängt). Anforderungen an den aktuellen Webserver werden nicht vollständig verarbeitet und im Internet Explorer-Fenster wird ein Stundenglas-Symbol angezeigt.

Wenn dieses Problem auftritt, werden Bilder eventuell nicht wie erwartet angezeigt und es kann eine Meldung in der Statusleiste am unteren Rand des Fensters angezeigt werden, die auf eine bestimmte Anzahl verbleibender Objekte verweist oder "Fertig" lautet.

Ursache

Dieses Problem kann auftreten, wenn Internet Explorer zunächst eine Vielzahl von HTTP-Anforderungen versendet und dann die Verarbeitung vieler dieser Anforderungen wieder abbricht. Bei diesem Problem schlagen weitere HTTP-Anforderungen an denselben Webserver fehl.

Hinweis: Wenn Sie einen anderen Webserver verwenden, werden die HTTP-Anforderungen erfolgreich verarbeitet.

Lösung

Download-Informationen

Internet Explorer 6 SP1 für Windows XP, Windows 2000, Windows NT und Windows Millennium Edition

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:
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Paket "q818506.exe" jetzt downloaden. Weitere Informationen zum Download von Microsoft Support-Dateien finden Sie im folgenden Artikel der Microsoft Knowledge Base:
119591 So erhalten Sie Microsoft Support-Dateien im Internet
Microsoft scanned this file for viruses. Microsoft hat dazu die neueste Software zur Virenerkennung verwendet, die zum Zeitpunkt der Bereitstellung verfügbar war. Die Datei befindet sich auf Servern mit verstärkter Sicherheit, wodurch nicht autorisierte Änderungen an der Datei weitestgehend verhindert werden.

Internet Explorer 6 für Windows Server 2003

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:
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Paket "WindowsServer2003-KB818506-x86-deu.EXE" jetzt downloaden. Weitere Informationen zum Download von Microsoft Support-Dateien finden Sie im folgenden Artikel der Microsoft Knowledge Base:
119591 So erhalten Sie Microsoft Support-Dateien im Internet
Microsoft scanned this file for viruses. Microsoft hat dazu die neueste Software zur Virenerkennung verwendet, die zum Zeitpunkt der Bereitstellung verfügbar war. Die Datei befindet sich auf Servern mit verstärkter Sicherheit, wodurch nicht autorisierte Änderungen an der Datei weitestgehend verhindert werden.

Dateiinformationen

Windows Server 2003 Version
   Datum        Zeit    Version     Größe    Dateiname
   -------------------------------------------------------
   15-Jul-2003  00:39  6.0.3790.68  623,616  Wininet.dll
Andere Versionen als Windows Server 2003
   Datum        Zeit   Version        Größe    Dateiname
   -------------------------------------------------------
   09-Jun-2003  15:14  6.0.2800.1207  586,752  Wininet.dll

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den Microsoft-Produkten handelt, die zu Beginn dieses Artikels aufgeführt sind.

Weitere Informationen

Wenn Internet Explorer eine HTTP-Anforderung abbricht, benötigt die Seite in der Regel keine Referenz für die Ressource mehr (wie zum Beispiel ein Bild, eine JScript-Datei (.js), eine HTML-Komponentendatei (.htc) oder eine Cascading Style Sheet-Datei (.css)). Das beschriebene Problem tritt dann auf, wenn Sie in schneller Folge viele Knoten eines DHTML-Strukturansicht-Steuerelements öffnen und wieder schließen. Noch häufiger ist dieses Problem zu beobachten, wenn Internet Explorer darauf konfiguriert ist, bei jedem Besuch einer Webseite nach neueren Versionen zu suchen, weil dabei noch mehr HTTP-Anforderungen erzeugt werden. (In der Regel handelt es sich dabei um Get-Anforderungen).

Andere Faktoren, die zum Volumen des HTTP-Verkehrs beitragen, können auch zusätzliche HTTP-Anforderungen generieren. Zu diesen Faktoren zählen beispielsweise die Netzwerklatenz und das Setzen des Zwischenspeicherungsattributs. Die Netzwerklatenz trägt zu dem geschilderten Problem bei, weil sie die Wahrscheinlichkeit erhöht, dass die Verarbeitung von HTTP-Anforderungen abgebrochen wird.

Wenn Sie die Anzahl der maximal zulässigen Verbindungen pro Server erhöhen, können Sie das Problem abmildern oder dessen Auftreten verzögern. Das Problem hat seine Ursache darin, dass Internet Explorer von Zeit zu Zeit intern HTTP-Verbindungen verliert. Standardmäßig sind für HTTP 1.1 zwei Verbindungen gleichzeitig zulässig; das Problem tritt dann später auf, wenn Sie die Anzahl der maximal zulässigen Verbindungen erhöhen.

Eigenschaften

Artikel-ID: 818506 - Geändert am: Freitag, 7. April 2006 - Version: 4.8
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Internet Explorer 6.0 Service Pack 1, wenn verwendet mit:
    • Microsoft Windows XP Professional
    • Microsoft Windows 2000 Standard Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows NT 4.0
  • Microsoft Internet Explorer 6.0, wenn verwendet mit:
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbbug kbfix kbie600presp2fix kbqfe kbie600sp2fix kbhotfixserver KB818506
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