Internet Explorer peut sembler cesser de répondre lorsque de nombreux objets sont demandés

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Symptômes

Lorsque Microsoft Internet Explorer effectue de nombreuses requêtes d'objets, il peut cesser de répondre (se bloquer). Les requêtes au serveur Web en cours peuvent ne pas se terminer et la fenêtre Internet Explorer affiche un pointeur en forme de sablier et de flèche.

Lorsque ce problème se produit, les images peuvent ne pas apparaître comme prévu et un message peut s'afficher dans la barre d'état au bas de la fenêtre indiquant qu'il existe un certain nombre d'« éléments restants » ou indiquant « Terminé ».

Cause

Ce problème peut se produire si Internet Explorer envoie de nombreuses requêtes HTTP, puis en abandonne un grand nombre. Lorsque ce problème se produit, les requêtes HTTP vers le même serveur Web n'aboutissent pas.

Remarque Lorsque vous utilisez d'autres serveurs Web, les requêtes HTTP fonctionnent correctement.

Résolution

Informations sur le téléchargement

Internet Explorer 6 SP1 pour Windows XP, Windows 2000, Windows NT et Windows Millennium Edition

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119591 Comment obtenir des fichiers de support technique Microsoft auprès des services en ligne
Microsoft a analysé ce fichier en vue de détecter la présence de virus. Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date de publication de ce fichier. Le fichier est conservé sur des serveurs sécurisés, empêchant toute modification non autorisée du fichier.

Internet Explorer 6 pour Windows Server 2003

Vous pouvez télécharger le fichier suivant à partir du Centre de téléchargement Microsoft (en anglais):
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Microsoft a analysé ce fichier en vue de détecter la présence de virus. Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date de publication de ce fichier. Le fichier est conservé sur des serveurs sécurisés, empêchant toute modification non autorisée du fichier.

Informations sur les fichiers

Version Windows Server 2003
   
Date         Heure   Version        Taille       Nom de fichier
---------------------------------------------------------------
15/07/2003   00:39   6.0.3790.68    623 616      Wininet.dll
Version non-Windows Server 2003
Date         Heure   Version        Taille       Nom de fichier
---------------------------------------------------------------
09/06/2003   15:14   6.0.2800.1207  586 752      Wininet.dll

Statut

Microsoft a confirmé l'existence de ce problème dans Microsoft Internet Explorer 6 Service Pack 1.

Plus d'informations

En général, lorsque Internet Explorer abandonne une requête HTTP, la page ne requiert plus de référence pour cette ressource (telle qu'une image, un fichier JScript (.js), un fichier de composant HTML (.htc) ou un fichier de feuille de style en cascade (.css)). Ce problème peut se produire lorsque vous ouvrez et fermez rapidement de nombreux noeuds d'un contrôle de type arborescence DHTML. Le problème se produit plus fréquemment lorsque Internet Explorer est configuré pour rechercher des versions plus récentes à chaque visite sur la page Web car cela génère plus de requêtes HTTP. (En général, ces demandes sont des demandes « get »).

D'autres facteurs qui contribuent au trafic HTTP peuvent également générer davantage de requêtes HTTP. Ces facteurs incluent le paramétrage de l'attribut de mise en cache et le temps de réponse du réseau. Le temps de réponse du réseau contribue au problème parce le risque d'abandon d'une requête HTTP est plus grand.

Si vous augmentez la limite de connexion par serveur, vous pouvez différer le problème. Le problème se produit parce qu'Internet Explorer peut parfois perdre des connexions HTTP en interne. La limite de connexion standard étant fixée à 2 pour HTTP 1.1, vous pouvez retarder le problème en augmentant la limite de connexion.

Propriétés

Numéro d'article: 818506 - Dernière mise à jour: mercredi 29 mars 2006 - Version: 4.6
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Internet Explorer 6.0 Service Pack 1 sur le système suivant
    • Microsoft Windows XP Professional
    • Microsoft Windows 2000 Standard Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows NT 4.0
  • Microsoft Internet Explorer 6.0 sur le système suivant
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Mots-clés : 
kbbug kbfix kbie600presp2fix kbqfe kbie600sp2fix kbhotfixserver KB818506
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