Può sembrare che si verifichi il blocco di Internet Explorer quando vengono richiesti molti oggetti

Traduzione articoli Traduzione articoli
Identificativo articolo: 818506 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando Microsoft Internet Explorer invia molte richieste di oggetti, il programma potrebbe bloccarsi. È possibile che le richieste inviate al server Web corrente non vengano portate a termine, nel qual caso viene visualizzato un puntatore a forma di clessidra con una freccia nella finestra di Internet Explorer.

Quando questo problema si verifica, è possibile che le immagini non vengano visualizzate come previsto e che sulla barra di stato nella parte inferiore della finestra venga visualizzato un messaggio che informa del numero di elementi ancora da visualizzare oppure che sono stati visualizzati tutti gli elementi della pagina.

Cause

Questo problema può verificarsi se Internet Explorer invia molte richieste HTTP, molte delle quali vengono successivamente interrotte. Quando ciò si verifica, le richieste HTTP inviate allo stesso server Web non hanno esito favorevole.

Nota Quando si utilizzano altri server Web, le richieste HTTP funzionano correttamente.

Risoluzione

Informazioni sul download

Internet Explorer 6 SP1 per Windows XP, Windows 2000, Windows NT e Windows Millennium Edition

Il seguente file è disponibile per il download dall'Area download Microsoft:
Download del pacchetto q818506.exe. Per ulteriori informazioni sul download di file di supporto Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
119591 Come ottenere file di supporto Microsoft dai servizi online
Il file è stato controllato e non contiene virus. Microsoft ha utilizzato il software antivirus più recente disponibile al momento della data di pubblicazione del file. Il file viene salvato su server con un livello di protezione avanzata che impedisce modifiche non autorizzate.

Internet Explorer 6 per Windows Server 2003

Il seguente file è disponibile per il download dall'Area download Microsoft:
Download del pacchetto WindowsServer2003-KB818506-x86-ENU.exe. Per ulteriori informazioni sul download di file di supporto Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
119591 Come ottenere file di supporto Microsoft dai servizi online
Il file è stato controllato e non contiene virus. Microsoft ha utilizzato il software antivirus più recente disponibile al momento della data di pubblicazione del file. Il file viene salvato su server con un livello di protezione avanzata che impedisce modifiche non autorizzate.

Informazioni sui file

Versione di Windows Server 2003
   Data        Ora    Versione     Dimensione    Nome file
   ---------------------------------------------------------
   15/07/2003  00.39  6.0.3790.68  623.616       Wininet.dll
Versione non di Windows Server 2003
   Data        Ora    Versione        Dimensione   Nome file
   -----------------------------------------------------------
   09/06/2003  15.14  6.0.2800.1207   586.752      Wininet.dll

Status

Microsoft ha confermato che questo è un problema di Microsoft Internet Explorer 6.0 Service Pack 1.

Informazioni

In genere, quando Internet Explorer interrompe una richiesta HTTP, non è più necessario che la pagina disponga di un riferimento per tale risorsa, ad esempio un'immagine, un file JScript (js), un file di componenti HTML (htc) o un file di foglio di stile (css). Questo problema si verifica quando si aprono e si chiudono molti nodi di un controllo DHTML simile al controllo Treeview. Il problema si verifica con maggiore frequenza quando Internet Explorer è impostato per cercare versioni più recenti ogni volta che si visita una stessa pagina Web. Questa operazione genera infatti molte richieste HTTP. Si tratta in genere di richieste "get".

Altri fattori relativi al traffico HTTP possono generare molte richieste HTTP, tra questi l'impostazione degli attributi della cache e della latenza della rete. La latenza di rete acuisce il problema in quanto aumenta le probabilità di interruzione di una richiesta HTTP.

Aumentando il limite delle connessioni per server, è possibile ritardare il problema. Il problema si verifica perché Internet Explorer può occasionalmente perdere connessioni HTTP al proprio interno. Poiché il limite di connessioni standard è 2 per HTTP 1.1, aumentando tale limite si ritarda il problema.

Proprietà

Identificativo articolo: 818506 - Ultima modifica: mercoledì 31 maggio 2006 - Revisione: 4.9
Le informazioni in questo articolo si applicano a
  • Microsoft Internet Explorer 6.0 Service Pack 1 alle seguenti piattaforme
    • Microsoft Windows XP Professional
    • Microsoft Windows 2000 Standard Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows NT 4.0
  • Microsoft Internet Explorer 6.0 alle seguenti piattaforme
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Chiavi: 
kbbug kbfix kbie600presp2fix kbqfe kbie600sp2fix kbhotfixserver KB818506
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com