Problemy spowodowane uzyskaniem dostępu do tego samego pliku przez więcej niż jednego użytkownika usług terminalowych

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 818528 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Jeśli w środowisku usług terminalowych systemu Windows 2000 użytkownicy uzyskują dostęp do tego samego pliku przy użyciu sieci lub zamapowanych dysków sieciowych, mogą wystąpić problemy po zamknięciu pliku przez użytkownika, który otworzył go jako pierwszy. Problemy są udokumentowane w następujących artykułach z bazy wiedzy Microsoft Knowledge Base:
294816 Programy uruchamiane z udziału sieciowego w usługach terminalowych są zamykane lub generują błędy (j. ang.)
299603 W usługach terminalowych systemu Windows 2000 jest wyświetlany komunikat o błędzie „Błąd podczas czytania pliku” (j. ang.)

Przyczyna

Readresator sieci systemu Windows 2000 przechowuje struktury danych po jednej na komputer, dlatego jeśli dwóch użytkowników tego samego serwera terminali ma dostęp do tego samego pliku w sieci, to współużytkują oni wewnętrznie te same struktury danych. Po zamknięciu pliku przez pierwszego użytkownika readresator zamknie ten plik również w przypadku innych użytkowników.

Rozwiązanie

Firma Microsoft udostępniła obsługiwaną poprawkę. Jednak jest ona przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tę poprawkę należy stosować tylko w tych systemach, w których występuje opisany problem.

Jeśli poprawka jest dostępna do pobrania, na początku tego artykułu z bazy wiedzy Knowledge Base jest umieszczona sekcja „Poprawka dostępna do pobrania”. Jeśli nie ma tej sekcji, skontaktuj się z działem obsługi klienta i pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga W przypadku wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu może być wymagane utworzenie osobnego zlecenia usługi. Typowe opłaty za korzystanie z pomocy technicznej będą pobierane tylko w przypadku dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu tej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta i pomocy technicznej firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/?ws=support
Uwaga Sekcja „Poprawka dostępna do pobrania” zawiera listę języków, dla których ta poprawka jest dostępna. Jeśli odpowiedni język nie jest widoczny, oznacza to, że ta poprawka nie jest dostępna dla tego języka.

Wersja anglojęzyczna tej poprawki ma atrybuty plików pokazane w poniższej tabeli (lub nowsze). Daty i godziny ostatniej modyfikacji plików podano zgodnie z czasem UTC (Coordinated Universal Time). Są one zamieniane na czas lokalny po wyświetleniu informacji o pliku. Aby zobaczyć różnicę między czasem UTC i czasem lokalnym, skorzystaj z karty Strefa czasowa narzędzia Data i godzina w Panelu sterowania.
   Data         Godzina   Wersja       Rozmiar     Nazwa pliku
   ------------------------------------------------------
   04-cze-2003  17:18   5.0.2195.6752  407 792  Mrxsmb.sys
   04-cze-2003  17:18  5.0.2195.6752  168 496  Rdbss.sys

Stan

Firma Microsoft potwierdziła, że jest to usterka występująca w produktach firmy Microsoft wymienionych w sekcji „Informacje zawarte w tym artykule dotyczą”.

Więcej informacji

Ważne W tej sekcji, metodzie lub w tym zadaniu podano informacje dotyczące modyfikowania rejestru. Niepoprawne zmodyfikowanie rejestru może jednak być przyczyną poważnych problemów. Dlatego należy uważnie wykonywać podane kroki. Aby zapewnić dodatkową ochronę, przed zmodyfikowaniem rejestru należy wykonać jego kopię zapasową. Dzięki temu będzie można przywrócić rejestr w wypadku wystąpienia problemu. Aby uzyskać więcej informacji dotyczących wykonywania kopii zapasowej i przywracania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322756 Jak wykonywać kopię zapasową rejestru, edytować go i przywracać w systemach Windows XP i Windows Server 2003
Aby uzyskać więcej informacji dotyczących uzyskiwania poprawki dla systemu Windows 2000 Datacenter Server, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
265173 Program Datacenter i produkt Windows 2000 Datacenter Server (j. ang.)
W celu używania nowych funkcji zawartych w tej poprawce i korzystania ze struktur danych obsługiwanych według użytkowników należy dodać następujący wpis do rejestru na serwerze terminali.
Podklucz:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MRxSmb\Parameters

Typ: REG_DWORD
Wpis: MultiUserEnabled
Wartość: 1
Ten wpis włącza struktury danych obsługiwane według użytkowników w readresatorze sieciowym.

Nowy wpis rejestru dla serwerów terminali systemu Windows 2000 jest odpowiednikiem wpisu
MultipleUsersOnConnection
dla serwerów terminali systemu Windows NT 4.0.

Właściwości

Numer ID artykułu: 818528 - Ostatnia weryfikacja: 31 grudnia 2008 - Weryfikacja: 7.4
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
Słowa kluczowe: 
kbautohotfix kbhotfixserver kbqfe kbqfe kbhotfixserver kbwin2000sp5fix kbwin2000presp5fix kbfix kbbug KB818528

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com