Equipo portátil no puede renovar su dirección IP de un servidor DHCP después de quitar el equipo de una estación de acoplamiento

Seleccione idioma Seleccione idioma
Id. de artículo: 818635 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Compruebe que ha hecho una copia de seguridad del Registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
En este artículo sólo se aplica a Microsoft Windows 2000 SP4 y no se aplica a otras versiones de Windows 2000.
Expandir todo | Contraer todo

En esta página

Síntomas

Un equipo portátil no puede renovar su dirección de protocolo Internet (IP) desde un servidor de protocolo de configuración dinámica de host (DHCP) después de quitar el equipo desde una estación de acoplamiento o desde un replicador de puerto. Además, errores no se registran en el registro del sistema, y este problema aún se produce después de deshabilitar y, a continuación, volver a habilitar al adaptador de red.

Causa

Este problema se produce porque el equipo no puede alcanzar el servidor DHCP. Windows 2000 utiliza la característica Media Sense para quitar los protocolos que están enlazados a un adaptador de red que detecta como "abajo"o "desconectado". En el escenario que se describe en la sección "Síntomas", Internet Control Message Protocol (ICMP) Enviar solicitud devuelve un estado pendiente , quita de la detección de medios no se detecta el protocolo TCP/IP y el adaptador de red porque no hay ningún protocolo enlazado al adaptador de red.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Afd.sys5.0.2195.6687120,24019-Jun-200320: 05x 86
Msafd.dll5.0.2195.6602108.81619-Jun-200320: 05x 86
Tcpip.sys5.0.2195.6921315,12026-Abr-200421: 38x 86
TDI.sys5.0.2195.665516,24019-Jun-200320: 05x 86
Wshtcpip.dll5.0.2195.660117,68019-Jun-200320: 05x 86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Solución

Impedir para evitar este problema, que su adaptador de red detecte el estado de vinculación modificando el registro para deshabilitar la característica Media Sense para TCP/IP. Para ello, siga estos pasos.

Nota Interfaz de usuario extendida de NetBIOS (NetBEUI) y de intercambio de paquetes entre redes (IPX) no reconocen la característica Media Sense.

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar .
  2. En el cuadro Abrir , escriba regedit y, a continuación, haga clic en Aceptar .
  3. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters
  4. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD
  5. Escriba DisableDHCPMediaSense como el nombre de la nueva entrada y, a continuación, presione ENTRAR.
  6. Haga doble clic en la nueva entrada DisableDHCPMediaSense , escriba 1 en el cuadro de datos de valor y, a continuación, haga clic en Aceptar .
  7. Cierre el Editor del Registro y reinicie el equipo.
Nota El valor de DisableDHCPMediaSense controla el comportamiento de detección de medios de DHCP. Si establece este valor en 1, los clientes y los clientes DHCP no pasar por alto los eventos de detección de medios desde el adaptador de red. De forma predeterminada, los eventos de detección de medios provocan el cliente para realizar una acción, como para intentar obtener una concesión cuando se produce un suceso de conexión o para invalidar el adaptador de red y las rutas de cuando un suceso de desconexión se produce.Para obtener más información acerca de cómo deshabilitar Media Sense para TCP/IP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
239924Cómo deshabilitar la característica de "Detección de medios" para TCP/IP en Windows

Más información

Para obtener más información acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura para los paquetes de revisión de Microsoft Windows
Para obtener más información acerca de la terminología utilizada en este artículo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 818635 - Última revisión: jueves, 26 de octubre de 2006 - Versión: 3.2
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server SP4
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbbug kbfix kbqfe kbwin2000presp5fix KB818635 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 818635

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com