Il computer portatile Impossibile rinnovare l'indirizzo IP da un server DHCP dopo la rimozione del computer da un alloggiamento di espansione

Traduzione articoli Traduzione articoli
Identificativo articolo: 818635 - Visualizza i prodotti a cui si riferisce l?articolo.
importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
256986Descrizione del Registro di sistema di Microsoft Windows
In questo articolo si applica solo a Microsoft Windows 2000 SP4 e non è valida per le altre versioni di Windows 2000.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Un computer portatile potrebbe risultare impossibile rinnovare l'indirizzo IP (Internet Protocol) da un server DHCP (Dynamic Host Configuration Protocol) dopo la rimozione del computer dall'alloggiamento di espansione o da un replicatore di porte. Inoltre, non gli errori vengono registrati nel Registro di sistema, e questo problema si verifica ancora dopo disattivare e riattivare la scheda di rete.

Cause

Questo problema si verifica perché il computer non è in grado di raggiungere il server DHCP. Windows 2000 utilizza la funzionalità di rilevamento del supporto per la rimozione di protocolli che sono associati a una scheda di rete è sensed "GIÙ"o"disconnesso." Nello scenario è descritto nella sezione "Sintomi", ICMP (Internet Control Message Protocol) invia la richiesta restituisce uno stato in sospeso , il protocollo TCP/IP e la scheda di rete non viene rilevato perché non esistono Nessun protocollo di rilevamento del supporto rimuove associato alla scheda rete.

Risoluzione

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

Non è richiesto alcun prerequisito.

Necessità di riavvio

È necessario riavviare il computer dopo aver applicato questo hotfix.

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello data e ora nel Pannello di controllo.
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Afd.sys5.0.2195.6687120,24019 / 06 / 200320: 05x 86
Msafd.dll5.0.2195.6602108.81619 / 06 / 200320: 05x 86
Tcpip.sys5.0.2195.6921315,12026/04 / 200421: 38x 86
TDI.sys5.0.2195.665516.24019 / 06 / 200320: 05x 86
Wshtcpip.dll5.0.2195.660117.68019 / 06 / 200320: 05x 86

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Workaround

Per risolvere questo problema, impedire che la scheda di rete rilevare lo stato dei collegamenti modificando il Registro di sistema per disattivare la funzionalità di rilevamento del supporto per TCP/IP. Per effettuare questa operazione, attenersi alla seguente procedura.

Nota NetBIOS Extended User Interface (NetBEUI) e IPX (Internetwork Packet Exchange) non riconoscono la funzionalità Media Sense.

avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.
  1. Fare clic su Start e quindi fare clic su Esegui .
  2. Nella casella Apri digitare regedit e quindi fare clic su OK .
  3. Individuare e selezionare la seguente sottochiave:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters
  4. Scegliere Nuovo dal menu Modifica , quindi Valore DWORD
  5. Digitare DisableDHCPMediaSense come nome della nuova voce e premere INVIO.
  6. Fare doppio clic sulla nuova voce DisableDHCPMediaSense digitare 1 nella casella dati valore e quindi fare clic su OK .
  7. Chiudere l'editor del Registro di sistema e riavviare il computer.
Nota Il valore di DisableDHCPMediaSense controlla il comportamento di rilevamento del supporto DHCP. Se si imposta questo valore su 1, client e il client non DHCP ignorano gli eventi di rilevamento del supporto dalla scheda di rete. Per impostazione predefinita, gli eventi di rilevamento del supporto attivano il client da intraprendere un'azione, ad esempio per tentare di ottenere un lease quando si verifica un evento di connessione, o per invalidare la scheda di rete e la route quando un evento di disconnessione si verifica.Per ulteriori informazioni su come disattivare rilevamento del supporto per TCP/IP, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
239924Come disattivare la funzionalità di "Rilevamento del supporto" per TCP/IP in Windows

Informazioni

Per ulteriori informazioni sulla denominazione dei pacchetti di aggiornamento rapido (hotfix), fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
816915Nuovo schema di denominazione per i pacchetti di aggiornamento software Microsoft Windows
Per ulteriori informazioni sulla terminologia utilizzata nel presente articolo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

Identificativo articolo: 818635 - Ultima modifica: giovedì 26 ottobre 2006 - Revisione: 3.2
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server SP4
Chiavi: 
kbmt kbautohotfix kbhotfixserver kbbug kbfix kbqfe kbwin2000presp5fix KB818635 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 818635
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com