Identificativo articolo: 818792 - Ultima modifica: mercoledì 21 febbraio 2007 - Revisione: 8.0

Lungo ritardo nella visualizzazione dei nomi di file nella finestra di dialogo "Apri" in Office XP

Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di eseguirne una copia di backup e di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986  (http://support.microsoft.com/kb/256986/ ) Descrizione del Registro di sistema di Microsoft Windows

In questa pagina

Espandi tutto | Chiudi tutto

Sintomi

Quando si sceglie Apri dal menu File o dalla barra degli strumenti Standard in un'applicazione di Microsoft Office XP, la visualizzazione dei file nella finestra di dialogo Apri può richiedere da 2 a 5 minuti.

Inoltre, l'attività del processore (CPU) potrebbe indicare un utilizzo del 100 percento.

Cause

Questo problema può verificarsi quando si tenta di individuare un'unità o una condivisione di rete contenente molte cartelle e file.

Risoluzione

Informazioni sul service pack

Per risolvere il problema, procurarsi l'ultimo service pack per Office XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
307841  (http://support.microsoft.com/kb/307841/ ) OFFXP: Come procurarsi il Service Pack di Office XP più recente

Informazioni sull'hotfix

Parte 1: Download e installazione dell'hotfix

È disponibile un hotfix supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che su questo hotfix vengano eseguite ulteriori verifiche. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Microsoft Office XP contenente tale hotfix.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione globale di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC (Universal Time Coordinate). Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data        Ora     Dimensione  Nome file 
   --------------------------------------------
   29/04/2003  10.27    3.945.132  Sharedop.msp 
   29/04/2003  15.04   10.140.948  Sharedff.msp
I file elencati di seguito avranno gli attributi di file elencati nella tabella seguente (o successivi).
   Data        Ora    Versione     Dimensione  Nome file 
   -----------------------------------------------------
   28/04/2003  23.27  10.0.5222.0   9.939.528  Mso.dll

Parte 2: Attivazione dell'hotfix

Avviso L'errata modifica del Registro di sistema tramite l'editor o un altro metodo può causare seri problemi, che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. La modifica del Registro di sistema è a rischio e pericolo dell'utente.Per attivare questo hotfix, attenersi alla procedura descritta di seguito.
  1. Chiudere tutte le applicazioni di Microsoft Office.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit, quindi scegliere OK.
  3. Individuare e selezionare la chiave del Registro di sistema seguente:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common\Open Find
  4. Dopo avere selezionato la chiave specificata al passaggio 3, scegliere Nuovo dal menu Modifica, quindi scegliere DWORD.
  5. Digitare DisableAutoSelect, quindi premere INVIO.
  6. Fare clic con il pulsante destro del mouse su DisableAutoSelect e scegliere Modifica.
  7. Nella casella Dati valore digitare 1, quindi scegliere OK.
  8. Scegliere Esci dal menu File per chiudere l'editor del Registro di sistema.

Nota Quando questo hotfix è attivato, il codice Microsoft Visual Basic Applications Edition che utilizza una proprietà SelectedItems non funzionerà come previsto in quanto l'hotfix non consente più di selezionare il primo file.

Nota Le visualizzazioni di più directory, FTP e Cronologia della finestra di dialogo Apri file non sono interessate dall'attivazione della chiave DisableAutoSelect del Registro di sistema.

Questo hotfix è successivo a Office XP Service Pack 2 (SP2). Per installare l'hotfix, è necessario che sia installato Office XP SP2. Per ulteriori informazioni su Office XP SP2, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
325671  (http://support.microsoft.com/kb/325671/ ) Descrizione di Office XP Service Pack 2 (SP2)
Per installare questo hotfix, potrebbe essere necessario installare anche Windows Installer 2.0. Per ulteriori informazioni sui requisiti di Windows Installer per gli hotfix successivi a Office XP SP2, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
330537  (http://support.microsoft.com/kb/330537/ ) Gli aggiornamenti e le patch di Office XP rilasciati successivamente al mese di settembre 2002 possono richiedere Windows Installer 2.0

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Le informazioni in questo articolo si applicano a" del presente articolo. Questo problema è stato corretto per la prima volta in Microsoft Office XP Service Pack 3.

Le informazioni in questo articolo si applicano a
  • Microsoft Office XP Standard Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Chiavi: 
kbqfe kbhotfixserver kbperformance kbbug kbfix kbofficexppresp3fix KB818792
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
 

Traduzione articoli