Article ID: 818842 - Last Review: February 5, 2007 - Revision: 2.7

You receive the "Could not create subweb" or "Invalid procedure call or argument" error message when you try to install SharePoint Team Services

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SYMPTOMS

When you try to install SharePoint Team Services from Microsoft to use with Microsoft Project Server 2002, you may receive the following error messages:
Could not create subweb
Run-time error '5':
Invalid procedure call or argument

CAUSE

This issue frequently occurs in environments where you use a custom script to increase the security of the server computers. The %temp% folder becomes inaccessible because the path of the folder has been truncated or the permissions to the folder have changed.

This issue may also occur when the CD-ROM that you used to install SharePoint Team Services contains scratches or is defective. You can verify the CD-ROM by copying the contents of the Microsoft Project Server 2002 CD-ROM to a folder on the computer. If a problem exists with the CD-ROM, you may receive the following error message:
Error Copying File or folder

Cannot copy ONET: Error performing inpage operation

RESOLUTION

To resolve this issue, if this issue has occurred because of increased security, you can change the user environmental variable %temp% from the current temporary folder to a temporary folder where you have full administrator permissions.

To change the user variable for the %temp% user environmental variable, follow these steps:
  1. Log on as an administrator.
  2. Create a folder on the root of drive C, for example, C:\temp1.
  3. Right-click the My Computer icon on the desktop, and then click Properties.
  4. Click the Advanced tab, and then click the Environment Variables button.
  5. In the System variables section, click the variable that has the name TEMP, and then click the Edit button.
  6. Change the default value of %SystemRoot%\TEMP to the folder that you created in step two, for example, C:\temp1.
  7. Remove the current installation of SharePoint Team Services.
  8. Use the SharePoint Team Services installation wizard to reinstall SharePoint Team Services.
If this issue has occurred because of damaged media, obtain a new original Microsoft Project Server 2002 CD-ROM.

If you are calling from the United States, contact the Microsoft Order Desk at the following phone number:
(800) 360-7561, Monday through Friday, 5:00 A.M. to 7:00 P.M. Pacific time
If you are calling from Canada, contact the Canadian Order Desk at the following number:
(800) 933-4750, Monday through Friday, 5:00 A.M. to 7:00 P.M. Pacific Time.
You can also verify the status of your order by calling one of these phone numbers. If you order replacement media, you can view the status of your order online. To do this, visit the following Microsoft Web site:
https://admin.innotrac.com/Microsoft/ics/ (https://admin.innotrac.com/Microsoft/ics/)

To obtain your order status, type the Order Status ID Code and Postal Code or E-mail.

MORE INFORMATION

For more information how to configure SharePoint Team Services in Microsoft Project Web Access, click the following article number to view the article in the Microsoft Knowledge Base:
322235  (http://support.microsoft.com/kb/322235/ ) How to install and configure SharePoint Team Services for Microsoft Project Server on Windows 2000

APPLIES TO
  • Microsoft Project Server 2002
  • Microsoft Office Project Web Access
  • Microsoft SharePoint Team Services
Keywords: 
kberrmsg KB818842
 

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