"Errore 1919. Errore durante la configurazione dell'origine dati ODBC" durante l'installazione di Office

Traduzione articoli Traduzione articoli
Identificativo articolo: 818954 - Visualizza i prodotti a cui si riferisce l?articolo.
Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di eseguirne una copia di backup e di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986 Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si esegue il programma di installazione di una delle applicazioni elencate nella sezione "Le informazioni in questo articolo si applicano a" di questo articolo, è possibile che venga visualizzato un messaggio di errore analogo al seguente:
Errore 1919. Errore durante la configurazione dell'origine dati ODBC: Database di Microsoft Access. Errore ODBC 6: Impossibile trovare il componente nel Registro di sistema. Assicurarsi che il file Database di Microsoft Access esista e di disporre dei relativi diritti di accesso.
Se si sceglie Ignora, è possibile che venga visualizzato il seguente messaggio di errore:
Errore 1919. Errore durante la configurazione dell'origine dati ODBC: File di Excel. Errore ODBC 0: Assicurarsi che il file File di Excel esista e di disporre dei relativi diritti di accesso.
È inoltre possibile che venga visualizzato un messaggio di errore analogo ai seguenti:
Errore 1919. Errore durante la configurazione dell'origine dati ODBC: Database di Microsoft Access. Errore ODBC 0: Assicurarsi che il file Database di Microsoft Access esista e di disporre dei relativi diritti di accesso.
Errore 1919. Errore durante la configurazione dell'origine dati ODBC: Database di Visual FoxPro. Errore ODBC 0: Assicurarsi che il file Database di Visual FoxPro esista e di disporre dei relativi diritti di accesso.
Errore 1919. Errore durante la configurazione dell'origine dati ODBC: Tabelle di Visual FoxPro. Errore ODBC 0: Assicurarsi che il file Tabelle di Visual FoxPro esista e di disporre dei relativi diritti di accesso.
Errore 1919. Errore durante la configurazione dell'origine dati ODBC: File di dBASE. Errore ODBC 6: Assicurarsi che il file File di dBASE esista e di disporre dei relativi diritti di accesso.

Cause

Questi problemi possono verificarsi se nel Registro di sistema mancano alcune chiavi.

Risoluzione

Per risolvere questo problema, sostituire le chiavi mancanti. Per eseguire questa operazione, utilizzare uno dei seguenti metodi.

Metodo 1: Installare MDAC 2.8

Per installare MDAC 2.8, visitare il seguente sito Web MSDN (informazioni in lingua inglese):
http://msdn2.microsoft.com/en-us/data/aa937712.aspx

Per ulteriori informazioni su MDAC 2.8, comprese istruzioni di installazione e rimozione, visitare il seguente sito Web MSDN (informazioni in lingua inglese):
http://msdn2.microsoft.com/en-us/library/ms810805.aspx
Dopo l'installazione di MDAC 2.8, è necessario riavviare il computer ed effettuare l'accesso con credenziali amministrative.

Nota: MDAC 2.8 viene installato anche quando si installa Microsoft Windows XP Service Pack 2 (SP2). Se si utilizza Windows XP, è possibile scegliere di installare Windows XP SP2 invece di attenersi alla procedura descritta in precedenza. Per installare Windows XP SP2, visitare il seguente sito Web Microsoft Web:
http://support.microsoft.com/xpsp2getinstall

Per ulteriori informazioni su Windows XP SP2, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/italy/windows/products/windowsxp/winxp/sp2/default.mspx

Metodo 2: Reimpostare le chiavi del Registro di sistema utilizzando il file Mdac.inf

Utilizzare il file Mdac.inf per reimpostare le chiavi del Registro di sistema.

Nota Per ottenere i nuovi file, è possibile che venga chiesto di inserire il CD di Windows.

Effettuare una delle operazioni descritte di seguito, a seconda del sistema operativo in uso. È necessario disporre del CD di Windows.

Per le edizioni disponibili al dettaglio di Microsoft Windows 2000, Microsoft Windows XP e Microsoft Windows Server 2003

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare percorso\inf nella casella Apri, quindi scegliere OK.

    In questo esempio, percorso è il percorso della cartella di Windows. Digitare ad esempio C:\Windows\Inf o C:\Winnt\Inf. Per impostazione predefinita, C:\Windows è la cartella di installazione di Windows XP. Per impostazione predefinita, C:\Winnt è la cartella di installazione di Windows 2000 e la cartella in cui viene installato Windows XP in caso di aggiornamento da Windows 2000 a Windows XP.
  2. Scegliere Opzioni cartella dal menu Strumenti.
  3. Nella casella Impostazioni avanzate della scheda Visualizzazione selezionare Visualizza cartelle e file nascosti, quindi scegliere OK.
  4. Fare clic con il pulsante destro del mouse su Mdac.inf, quindi scegliere Installa.
  5. Se viene richiesto il CD di Windows, inserirlo nell'unità CD-ROM o DVD-ROM.
  6. Fare clic sulla cartella I386 sul disco rigido, solitamente la cartella C:\I386, quindi scegliere OK.

    Nota Se la cartella I386 è una sottocartella della cartella di Windows, in alcuni computer risulta impossibile selezionarla. In questo caso, digitare il percorso completo nella casella di testo Copia file da, ad esempio C:\Windows\I386 o C:\Winnt\I386, quindi scegliere OK.
  7. Riavviare il computer.

Per le versioni OEM (Original Equipment Manufacturer) di Windows 2000 o Windows XP

Avviso L'errata modifica del Registro di sistema tramite l'editor o un altro metodo può causare seri problemi, che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Passaggio 1: Modificare le chiavi del Registro di sistema

  1. Individuare la cartella I386 sul disco rigido e prendere nota del relativo percorso.
  2. Fare clic sul pulsante Start, quindi scegliere Esegui.
  3. Nella casella Apri digitare regedit, quindi scegliere OK.
  4. Nell'editor del Registro di sistema individuare e selezionare la seguente chiave:
    HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Setup
  5. Fare clic con il pulsante destro del mouse sulla voce Installation Sources, quindi scegliere Modifica.
  6. Nella casella Dati valore modificare il valore del percorso della cartella I386 sul disco rigido, quindi scegliere OK.
  7. Ripetere i passaggi 5 e 6 per ciascuna delle seguenti voci:
    • SourcePath
    • ServicePackSourcePath
  8. Chiudere l'editor del Registro di sistema.

Passaggio 2: Installare Mdac.Inf

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare C:\Winnt\Inf nella casella Apri, quindi scegliere OK.
  2. Scegliere Opzioni cartella dal menu Strumenti.
  3. Nella casella Impostazioni avanzate della scheda Visualizzazione selezionare Visualizza cartelle e file nascosti, quindi scegliere OK.
  4. Fare clic con il pulsante destro del mouse su Mdac.inf, quindi scegliere Installa.
  5. Se viene richiesto il CD di Windows, inserirlo nell'unità CD-ROM o DVD-ROM.
  6. Fare clic sulla cartella I386 sul disco rigido, solitamente la cartella C:\I386, quindi scegliere OK.

    Note
    • Se non si dispone del CD dell'installazione corrente di Windows, fare clic su Sfoglia, quindi individuare e selezionare la cartella I386.
    • Se la cartella I386 è una sottocartella della cartella di Windows in alcuni computer risulta impossibile selezionarla.

      In questo caso, digitare il percorso completo nella casella di testo Copia file da, ad esempio C:\Windows\I386 o C:\Winnt\I386, quindi scegliere OK.
  7. Riavviare il computer.

Metodo 3: Importare le chiavi del Registro di sistema da un altro computer in rete

Nota Quando si importano chiavi del Registro di sistema da un altro computer, assicurarsi che sul computer di origine e su quello di destinazione sia in esecuzione lo stesso sistema operativo. Se ad esempio si utilizza questo metodo in un computer con Windows XP, individuare un computer in cui sia installato Windows XP da utilizzare per l'esportazione delle chiavi del Registro di sistema.

Avviso L'errata modifica del Registro di sistema tramite l'editor o un altro metodo può causare seri problemi, che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Parte 1: Esportare le chiavi dal Registro di sistema del computer di origine

  1. In un computer nel quale siano presenti le chiavi (computer di origine) fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
  2. Individuare e fare clic sulla chiave del Registro di sistema seguente:
    HKEY_CURRENT_USER\Software\ODBC
  3. Scegliere Esporta dal menu File.
  4. Nella casella Salva in specificare un percorso in cui salvare temporaneamente il file di registrazione (reg).

    Nella casella Nome file digitare un nome di file, quindi scegliere Salva.
  5. Individuare e selezionare la seguente chiave:
    HKEY_LOCAL_MACHINE\Software\ODBC
  6. Ripetere i passaggi 4 e 5 per esportare questa chiave.

Parte 2: Importare le chiavi nel Registro di sistema del computer di destinazione

  1. Copiare i file reg esportati dal computer di origine in una cartella temporanea nel computer in cui mancano le chiavi, vale a dire il computer di destinazione.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
  3. Scegliere Importa file del Registro di sistema dal menu Registro.
  4. Individuare e selezionare uno dei file reg copiati nel passaggio 1, quindi scegliere Apri.
  5. Ripetere i passaggi 4 e 5 per l'altro file reg.

Workaround

Può essere possibile risolvere il problema scegliendo più volte Riprova quando vengono visualizzati i messaggi di errore. Si tratta tuttavia di una soluzione solo temporanea, in quanto potranno verificarsi problemi in seguito quando si tenterà di eseguire la funzione Rileva problemi e ripristina oppure di reinstallare Microsoft Office 2003.

Informazioni

Per ulteriori informazioni su come risolvere i problemi relativi ai messaggi di errore "Errore 1919" in Office 2003, cercare nella Microsoft Knowledge Base Errore 1919. Per effettuare una ricerca nella Microsoft Knowledge Base, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;IT;KBHOWTO

Proprietà

Identificativo articolo: 818954 - Ultima modifica: giovedì 13 maggio 2010 - Revisione: 5.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Office Access 2003
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office InfoPath 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Word 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office Edizione Professional 2003
  • Microsoft Office Edizione Standard 2003
  • Microsoft Office Edizione Studenti e Docenti 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Edizione Basic 2003
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Word 2007
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Standard 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2007 with Business Contact Manager
  • Microsoft Office OneNote 2007
  • Microsoft Office Excel 2007
Chiavi: 
kbupdate kbregistry kbwindowsinstaller kbsetup kberrmsg KB818954
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com