'Fout 1919. Fout bij het configureren van ODBC-gegevensbron' wanneer u Office Setup uitvoert

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 818954 - Bekijk de producten waarop dit artikel van toepassing is.
Belangrijk Dit artikel bevat informatie over het bewerken van het register. Maak eerst een back-up van het register voordat u dit gaat bewerken. Ga eerst na of u weet hoe u het register kunt herstellen als er een probleem optreedt. Als u meer informatie wilt over het maken van een back-up van het register en het herstellen of wijzigen van het register, klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
256986Beschrijving van het Microsoft Windows-register
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Wanneer u het Setup-programma uitvoert voor een van de programma's die worden vermeld in de sectie 'Van toepassing op', wordt het volgende foutbericht weergegeven:
Fout 1919. Fout bij het configureren van ODBC-gegevensbron: MS Access-database. ODBC-fout 6: Onderdeel is niet gevonden in het register. Controleer of het bestand MS Access-database bestaat en of u toegang hebt tot dit bestand.
Als u op Negeren klikt, wordt het volgende foutbericht weergegeven:
Fout 1919. Fout bij het configureren van ODBC-gegevensbron: Excel-bestanden. ODBC-fout 0: Controleer of het bestand Excel-bestanden bestaat en of u toegang hebt tot dit bestand.
Mogelijk wordt ook een van de volgende foutberichten weergegeven:
Fout 1919. Fout bij het configureren van ODBC-gegevensbron: MS Access-database. ODBC-fout 0: Controleer of het bestand MS Access-database bestaat en of u toegang hebt tot dit bestand.
Fout 1919. Fout bij het configureren van ODBC-gegevensbron: Visual FoxPro-database. ODBC-fout 0: Controleer of het bestand Visual FoxPro-database bestaat en of u toegang hebt tot dit bestand.
Fout 1919. Fout bij het configureren van ODBC-gegevensbron: Visual FoxPro-tabellen. ODBC-fout 0: Controleer of het bestand Visual FoxPro-tabellen bestaat en of u toegang hebt tot dit bestand.
Fout 1919. Fout bij het configureren van ODBC-gegevensbron: dBASE-bestanden. ODBC-fout 6: Controleer of het bestand dBASE-bestanden bestaat en of u toegang hebt tot dit bestand.

Oorzaak

Deze problemen treden op wanneer er registersleutels ontbreken in het Windows-register.

Oplossing

Zet de ontbrekende registersleutels terug om dit probleem op te lossen. U kunt dit op een van de volgende manieren doen.

Methode 1: MDAC 2.8 installeren

Ga naar de volgende MSDN-website om MDAC 2.8 installeren:
http://msdn2.microsoft.com/en-us/data/aa937712.aspx

Ga voor meer informatie over MDAC 2.8, inclusief instructies voor het installeren en verwijderen, naar de volgende MSDN-website:
http://msdn2.microsoft.com/en-us/library/ms810805.aspx
Nadat u MDAC 2.8 hebt geïnstalleerd, moet u de computer opnieuw opstarten en u aanmelden met beheerdersreferenties.

Opmerking MDAC 2.8 wordt ook geïnstalleerd wanneer u Microsoft Windows XP Service Pack 2 (SP2) installeert. Als u Windows XP als besturingssysteem gebruikt, kunt u in plaats van de vorige stappen uit te voeren Windows XP SP2 installeren. Ga naar de volgende Microsoft-website om Windows XP SP2 te installeren:
http://support.microsoft.com/xpsp2getinstall

Ga naar de volgende Microsoft-website voor meer informatie over Windows XP SP2:
http://www.microsoft.com/netherlands/windowsxp/sp2/default.aspx

Methode 2: De registersleutels opnieuw instellen met behulp van het bestand Mdac.inf

Bij deze methode gebruikt u het bestand Mdac.inf om de registersleutels opnieuw in te stellen.

Opmerking In dit programma wordt u mogelijk gevraagd om de Windows-cd met de ontbrekende bestanden te plaatsen.

Kies de methode voor uw besturingssysteem en zorg dat u beschikt over de Windows-cd.

Ga als volgt te werk voor de handelsversies van Microsoft Windows 2000, Microsoft Windows XP en Microsoft Windows Server 2003:

  1. Klik op Start, klik op Uitvoeren, typ pad\inf in het vak Openen en klik op OK.

    In dit voorbeeld is pad het pad naar de Windows-map. Typ bijvoorbeeld C:\Windows\Inf of C:\Winnt\Inf. Standaard is C:\Windows de map waarin Windows is geïnstalleerd. Windows 2000 is standaard geïnstalleerd in de map C:\Winnt. Ditzelfde geldt voor Windows XP als u een upgrade hebt uitgevoerd van Windows 2000 naar Windows XP.
  2. Klik op Mapopties in het menu Extra.
  3. Open het tabblad Beeld, klik in het vak Geavanceerde instellingen op Verborgen bestanden en mappen weergeven en klik op OK.
  4. Klik met de rechtermuisknop op Mdac.inf en klik op Installeren.
  5. Plaats de Windows-cd desgevraagd in het cd-rom- of dvd-station.
  6. Klik op de map I386 op de vaste schijf (normaal is dit C:\I386) en klik op OK.

    Opmerking Als de map I386 een submap is van de Windows-map, kan deze op sommige computers niet worden geselecteerd. Typ in dat geval het volledige pad in het vak Bestanden kopiëren van (typ bijvoorbeeld C:\Windows\I386 of C:\Winnt\I386) en klik op OK.
  7. Start de computer opnieuw op.

Ga als volgt te werk voor OEM-versies (Original Equipment Manufacturer) van Windows 2000 of Windows XP:

Waarschuwing Er kunnen zich ernstige problemen voordoen als u het register met de Register-editor of met een andere methode foutief wijzigt. Wellicht moet u door deze problemen het besturingssysteem opnieuw installeren. Microsoft kan niet garanderen dat deze problemen opgelost kunnen worden. Het wijzigen van het register is dan ook voor uw eigen risico.

Stap 1: De registersleutels wijzigen

  1. Zoek de map I386 op de vaste schijf en maak een notitie met het pad naar deze map.
  2. Klik op Start en klik op Uitvoeren.
  3. Typ regedit in het vak Openen en klik op OK.
  4. Klik in de Register-editor op de volgende sleutel:
    HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Setup
  5. Klik met de rechtermuisknop op de vermelding Installation Sources en klik op Wijzigen.
  6. Wijzig de waarde in het vak Waardegegevens in het pad van de map I386 op de vaste schijf en klik op OK.
  7. Herhaal stap 5 en 6 voor de volgende vermeldingen:
    • SourcePath
    • ServicePackSourcePath
  8. Sluit de Register-editor af.

Stap 2: Mdac.inf installeren

  1. Klik op Start, klik op Uitvoeren, typ C:\Winnt\Inf in het vak Openen en klik op OK.
  2. Klik op Mapopties in het menu Extra.
  3. Open het tabblad Beeld, klik in het vak Geavanceerde instellingen op Verborgen bestanden en mappen weergeven en klik op OK.
  4. Klik met de rechtermuisknop op Mdac.inf en klik op Installeren.
  5. Plaats de Windows-cd desgevraagd in het cd-rom- of dvd-station.
  6. Klik op de map I386 op de vaste schijf (normaal is dit C:\I386) en klik op OK.

    Opmerkingen
    • Als u niet beschikt over de cd voor de huidige Windows-installatie, klikt u op Bladeren en zoekt en selecteert u de map I386.
    • Als de map I386 een submap is van de Windows-map, kan deze op sommige computers niet worden geselecteerd.

      Typ in dat geval het volledige pad in het vak Bestanden kopiëren van (typ bijvoorbeeld C:\Windows\I386 of C:\Winnt\I386) en klik op OK.
  7. Start de computer opnieuw op.

Methode 3: De registersleutels importeren uit een andere computer in het netwerk

Opmerking Wanneer u de registersleutels uit een andere computer importeert, moet u controleren of op de bron- en doelcomputer hetzelfde besturingssysteem wordt uitgevoerd. Als u deze methode bijvoorbeeld gebruikt voor een computer waarop Windows XP wordt uitgevoerd, zoekt u een andere Windows XP-computer van waaruit u de registersleutels kunt exporteren.

Waarschuwing Er kunnen zich ernstige problemen voordoen als u het register met de Register-editor of met een andere methode foutief wijzigt. Wellicht moet u door deze problemen het besturingssysteem opnieuw installeren. Microsoft kan niet garanderen dat deze problemen opgelost kunnen worden. Het wijzigen van het register is dan ook voor uw eigen risico.

Deel 1: De sleutels exporteren uit het register op de broncomputer

  1. Klik op een computer waarop de sleutels niet ontbreken (de broncomputer) op Start, klik op Uitvoeren, typ regedit in het vak Openen en klik op OK.
  2. Klik op de volgende registersleutel:
    HKEY_CURRENT_USER\Software\ODBC
  3. Klik op Exporteren in het menu Bestand.
  4. Geef in het vak Opslaan in een locatie op waar u het registratiebestand (.REG) tijdelijk wilt opslaan.

    Typ een bestandsnaam in het vak Bestandsnaam en klik op Opslaan:
  5. Zoek de volgende sleutel en klik erop:
    HKEY_LOCAL_MACHINE\Software\ODBC
  6. Herhaal stap 4 en 5 om deze sleutel te exporteren.

Deel 2: De sleutels importeren in het register van de doelcomputer

  1. Kopieer de geëxporteerde REG-bestanden van de broncomputer naar een tijdelijke locatie op de computer met de ontbrekende sleutels (de doelcomputer).
  2. Klik op Start, klik op Uitvoeren, typ regedit in het vak Openen en klik op OK.
  3. Klik in het menu Register op Registerbestand importeren.
  4. Zoek en klik op een van de REG-bestanden die u heb gekopieerd in stap 1 en klik op Openen.
  5. Herhaal stap 4 en 5 voor de overige REG-bestanden.

Workaround

Mogelijk kunt u het probleem omzeilen door verschillende keren op Nogmaals te klikken wanneer deze foutberichten worden weergegeven. Deze methode werkt mogelijk niet op de lange termijn. U ondervindt later mogelijk problemen als u Analyse en herstel uitvoert of Microsoft Office 2003 opnieuw installeert.

Meer informatie

Zoek in de Microsoft Knowledge Base naar Fout 1919 voor meer informatie over het oplossen van problemen met Fout 1919 in Office 2003. Hiertoe gaat u naar de volgende website van Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;nl;KBHOWTO

Eigenschappen

Artikel ID: 818954 - Laatste beoordeling: donderdag 13 mei 2010 - Wijziging: 5.0
De informatie in dit artikel is van toepassing op:
  • Microsoft Office Access 2003
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office InfoPath 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Word 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Student and Teachers Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Word 2007
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Standard 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2007 with Business Contact Manager
  • Microsoft Office OneNote 2007
  • Microsoft Office Excel 2007
Trefwoorden: 
kbupdate kbregistry kbwindowsinstaller kbsetup kberrmsg KB818954

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com