Mensagem de erro "Erro 1919. Erro ao configurar a origem de dados ODBC" exibida ao executar o programa Instalação do Office

Traduções deste artigo Traduções deste artigo
ID do artigo: 818954 - Exibir os produtos aos quais esse artigo se aplica.
Importante Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça um backup e certifique-se de que saiba como restaurá-lo caso ocorra algum problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
256986 Descrição do Registro do Microsoft Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Ao executar o programa de Instalação de um dos programas listados na seção "Aplica-se a", a seguinte mensagem de erro é exibida:
Erro 1919. Erro ao configurar fonte de dados de ODBC: Banco de dados do MS Access. Erro ODBC 6: Não foi possível encontrar o componente no Registro. Verifique se o arquivo de banco de dados do MS Access existe e se é possível acessá-lo.
Se você clicar em Ignorar, a seguinte mensagem de erro pode ser exibida:
Erro 1919. Erro ao configurar fonte de dados de ODBC: Arquivos do Excel. Erro ODBC 0: Verifique se o arquivo denominado Arquivos do Excel existe e se é possível acessá-lo.
Uma das seguintes mensagens de erro também pode ser exibida:
Erro 1919. Erro ao configurar fonte de dados de ODBC: Banco de dados do MS Access. Erro ODBC 0: Verifique se o arquivo de banco de dados do MS Access existe e se é possível acessá-lo.
Erro 1919. Erro ao configurar fonte de dados de ODBC: Banco de dados do Visual FoxPro. Erro ODBC 0: Verifique se o arquivo de banco de dados do Visual FoxPro existe e se é possível acessá-lo.
Erro 1919. Erro ao configurar fonte de dados de ODBC: Tabelas do Visual FoxPro. Erro ODBC 0: Verifique se o arquivo de tabelas do Visual FoxPro existe e se é possível acessá-lo.
Erro 1919. Erro ao configurar fonte de dados de ODBC: Arquivos do dBASE. Erro ODBC 6: Verifique se o arquivo denominado Arquivos do dBASE existe e se é possível acessá-lo.

Causa

Esses problemas podem ocorrer se não houver o Registro do Windows em algumas chaves do Registro.

Resolução

Para resolver esse problema, substitua as chaves do Registro não encontradas. Para fazer isso, use um dos seguintes métodos.

Método 1: instalar o MDAC 2.8

Para instalar o MDAC 2.8, visite o seguinte site da MSDN (em inglês):
http://msdn2.microsoft.com/en-us/data/aa937712.aspx

Para obter mais informações sobre o MDAC 2.8, incluindo as instruções de instalação e remoção, visite o seguinte site da MSDN (em inglês):
http://msdn2.microsoft.com/en-us/library/ms810805.aspx
Após instalar o MDAC 2.8, será necessário reiniciar o computador e efetuar logon com credenciais administrativas.

Observação O MDAC 2.8 também é instalado após a instalação do Microsoft Windows XP Service Pack 2 (SP2). Se o sistema operacional for o Windows XP, você poderá optar por instalar o Windows XP SP2 em vez de executar as etapas anteriores. Para instalar o Windows XP SP2, visite o seguinte site da Microsoft:
http://support.microsoft.com/xpsp2getinstall

Para obter mais informações sobre o Windows XP SP2, visite o seguinte site da Microsoft:
http://www.microsoft.com/windowsxp/sp2/default.mspx

Método 2: redefinir as chaves do Registro usando o Mdac.inf

Use o arquivo Mdac.inf para redefinir as chaves do Registro.

Observação Esse programa poderá solicitar seu CD do Windows para obter novos arquivos.

Execute uma das seguintes etapas de acordo com o sistema operacional e se você tiver o CD do Windows.

Para obter edições comerciais do Windows 2000, do Windows XP e do Microsoft Windows Server 2003

  1. Clique em Iniciar e em Executar, digite caminho\inf na caixa Abrir e clique em OK.

    Neste exemplo, path é o caminho para a pasta do Windows. Por exemplo, digite C:\Windows\Inf ou C:\Winnt\Inf. Por padrão, C:\Windows é a pasta na qual o Windows XP está instalado. Por padrão, C:\Winnt é a pasta em que o Windows 2000 está instalado e a pasta em que o Windows XP também está instalado se você atualizou o Windows 2000 para o Windows XP.
  2. No menu Ferramentas, clique em Opções de pasta.
  3. Na guia Exibir, na caixa Configurações avançadas, clique em Mostrar pastas e arquivos ocultos, e clique em OK.
  4. Clique com o botão direito do mouse em Mdac.inf e clique em Instalar.
  5. Se o CD do Windows for solicitado, insira-o na unidade de CD-ROM ou DVD-ROM.
  6. Clique na pasta I386 do disco rígido (normalmente, C:\I386), e clique em OK.

    Observação Se a pasta I386 for uma subpasta da pasta Windows, em alguns computadores, não será possível selecioná-la. Nesse caso, digite o caminho completo na caixa Copiar arquivos de (por exemplo, digite C:\Windows\I386 ou C:\Winnt\I386), e clique em OK.
  7. Reinicie o computador.

Para as Edições OEM (Fabricante original do equipamento) do Windows 2000 ou do Windows XP

Aviso O uso incorreto do Editor do Registro, ou outro método, pode causar sérios problemas, que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. A modificação do Registro é de sua responsabilidade.

Etapa 1: modificar as chaves do Registro

  1. Localize a pasta I386 no disco rígido e anote o seu caminho.
  2. Clique em Iniciar e em Executar.
  3. Na caixa Abrir, digite regedit e clique em OK.
  4. No Editor do Registro, localize e clique na seguinte chave:
    HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Setup
  5. Clique com o botão direito do mouse na entrada Origens da instalação e clique em Modificar.
  6. Na caixa Dados do Valor, altere o valor para o caminho da pasta I386 no disco rígido, e clique em OK.
  7. Repita as etapas 5 e 6 para cada uma das seguintes entradas:
    • SourcePath
    • ServicePackSourcePath
  8. Encerre o Editor do Registro.

Etapa 2: instalar Mdac.inf

  1. Clique em Iniciar, em Executar, digite C:\Winnt\Inf na caixa Abrir e clique em OK.
  2. No menu Ferramentas, clique em Opções de pasta.
  3. Na guia Exibir, na caixa Configurações avançadas, clique em Mostrar pastas e arquivos ocultos e em OK.
  4. Clique com o botão direito do mouse em Mdac.inf e clique em Instalar.
  5. Se o CD do Windows for solicitado, insira-o na unidade de CD-ROM ou DVD-ROM.
  6. Clique na pasta I386 do disco rígido (normalmente, C:\I386), e clique em OK.

    Observações
    • Se você não tiver o CD para a instalação atual do Windows, clique em Procurar, localize e selecione a pasta I386.
    • Se a pasta I386 for uma subpasta da pasta Windows, em alguns computadores, você não conseguirá selecioná-la.

      Nesse caso, digite o caminho completo na caixa Copiar arquivos de (por exemplo, digite C:\Windows\I386 ou C:\Winnt\I386), e clique em OK.
  7. Reinicie o computador.

Método 3: importar as chaves do Registro de outro computador na rede

Observação Ao importar as chaves do Registro de outro computador, certifique-se de que o computador fonte e o computador de destino estejam executando o mesmo sistema operacional. Por exemplo, se você estiver usando esse método em um computador que esteja executando o Windows XP, localize um computador que também o execute para que seja possível exportar as chaves do Registro.

Aviso O uso incorreto do Editor do Registro, ou outro método, pode causar sérios problemas, que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. A modificação do Registro é de sua responsabilidade.

Parte 1: exportar as chaves do Registro no computador de "origem"

  1. Em um computador em que as chaves foram encontradas (o computador de "origem"), clique em Iniciar, em Executar, digite regedit na caixa Abrir e clique em OK.
  2. Localize e clique na seguinte chave do Registro:
    HKEY_CURRENT_USER\Software\ODBC
  3. No menu Arquivo, clique em Exportar.
  4. Na caixa Salvar em, especifique um local para salvar temporariamente o arquivo de registro (.reg file).

    Na caixa Nome do arquivo, digite um nome de arquivo e clique em Salvar.
  5. Localize e clique na seguinte chave:
    HKEY_LOCAL_MACHINE\Software\ODBC
  6. Repita as etapas 4 e 5 para exportar essa chave.

Parte 2: importar as chaves para o Registro do computador de "destino"

  1. Copie os arquivos .reg exportados do computador de origem para um local temporário no computador em que não há chaves (o computador de "destino").
  2. Clique em Iniciar, em Executar, digite regedit na caixa Abrir e clique em OK.
  3. No menu Registro, clique em Importar arquivo do Registro.
  4. Localize e clique em um dos arquivos .reg copiados na etapa 1 e clique em Abrir.
  5. Repita as etapas 4 e 5 para o outro arquivo .reg.

Como Contornar

Como solução alternativa para esse problema, é possível clicar em Tentar novamente várias vezes ao receber essas mensagens de erro. No entanto, esta solução alternativa pode não funcionar a longo prazo; você poderá ter problemas mais tarde se tentar executar Detectar e Reparar ou uma reinstalação do Microsoft Office 2003.

Mais Informações

Para obter informações adicionais sobre como solucionar problemas de mensagens de erro Erro 1919 do Office 2003, procure na Base de Dados de Conhecimento Microsoft Erro 1919. Para fazer isso, visite o seguinte site da Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;PT-BR;KBHOWTO

Propriedades

ID do artigo: 818954 - Última revisão: quinta-feira, 13 de maio de 2010 - Revisão: 5.0
A informação contida neste artigo aplica-se a:
  • Microsoft Office Access 2003
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office InfoPath 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Word 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Student and Teachers Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Word 2007
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Standard 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2007 with Business Contact Manager
  • Microsoft Office OneNote 2007
  • Microsoft Office Excel 2007
Palavras-chave: 
kbupdate kbregistry kbwindowsinstaller kbsetup kberrmsg KB818954

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com