Article ID: 819019 - Last Review: October 26, 2006 - Revision: 3.4

IIS Admin Service Repeatedly Stops on an Exchange 2000 Server

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SYMPTOMS

On a Windows 2000-based server where Exchange 2000 is installed or where the Simple Mail Transport Protocol (SMTP) service is configured, the IIS Admin Service repeatedly stops (crashes). You can restart the service successfully, but it stops again after a short period of time (about 5 minutes).

CAUSE

This problem occurs because of an access violation in the Mailmsg object (part of the SMTP service). The Mailmsg object stops responding (crashes) because of a stack overflow that is caused by a corrupted message that cannot be processed.

When messages are received by the SMTP service, they are stored in the NTFS file system. During message processing, the message properties (for example, the From, To, Subject, IP Address, and Number of Recipients properties) are submitted as a set of Mailmsg properties that are then exposed to subsequent SMTP event sinks. The problem that is described in this article occurs when corruption is introduced in the message stream that causes the Mailmsg object internal structure size to be incorrect. This causes a stack overflow. Depending on the extent of the corruption, the stack may be overwritten, and then it stops responding (crash).

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Microsoft Windows 2000 Service Pack 2 (SP2) or later must be installed on your computer before you install this hotfix. For additional information about how to obtain the latest Windows 2000 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
260910  (http://support.microsoft.com/kb/260910/EN-US/ ) How to Obtain the Latest Windows 2000 Service Pack

Restart Requirement

This hotfix automatically restarts the IIS Admin Service.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
----------------------------------------------------------
11-Jun-2003  19:30  5.0.2195.6654     322,320  Aqueue.dll
11-Jun-2003  19:30  5.0.2195.6739      67,856  Mailmsg.dll
11-Jun-2003  19:30  5.0.2195.6662      38,672  Ntfsdrv.dll
11-Jun-2003  19:30  5.0.2195.6747     444,688  Smtpsvc.dll

WORKAROUND

To work around this problem, remove the corrupted message from the NTFS or from the Exchange Messaging Database (MDB). For information about how to locate and remove the corrupted message from the NTFS or the MDB, contact Microsoft Product Support Services (PSS). For information about how to contact Microsoft PSS, visit the following Microsoft Web site:
http://support.microsoft.com (http://support.microsoft.com/)

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

When the messages are received by the SMTP service, they are stored in the NTFS. However, if the message is received from the Exchange Information Store service (Store.exe), the physical message may reside in the Messaging Database (MDB). The problem described in this article occurs because of NTFS file corruption or MDB file corruption. For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915  (http://support.microsoft.com/kb/816915/EN-US/ ) New Naming Schema for Microsoft Windows Hotfix Packages

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB819019
 

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