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Article ID: 819249 - Last Review: October 26, 2006 - Revision: 2.5

You Receive an "Event ID 1311" Message Every 15 Minutes in the Directory Services Event Log

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SYMPTOMS

You may receive an "Event ID 1311" message similar to the following in the Directory Services event log every 15 minutes:

Event Type: Error
Event Source: NTDS KCC
Event Category: Knowledge Consistency Checker
Event ID: 1311
Date: MM/DD/YYYY
Time: HH:MM:SS AM|PM
User: N/A
Computer: domain_controller_name

Description: The Knowledge Consistency Checker (KCC) has detected problems with the following directory partition.

CAUSE

In Windows 2000, the Knowledge Consistency Checker (KCC) uses the Intersite Messaging service to help it build the spanning tree topology for Microsoft Active Directory directory service replication. In a very small percentage of cases, Intersite Messaging may not complete building the hash table that it passes to the KCC. When the KCC uses this hash table in its calculations, this may generate the KCC logging event ID 1311 in the Directory Services event log.

This problem typically occurs in environments with large numbers of sites, domain controllers, and domains.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size    File name
   ------------------------------------------------------
   29-Apr-2003  10:53  5.0.2195.6742   34,576  Ismip.dll
   29-Apr-2003  10:53  5.0.2195.6742   56,080  Ismsmtp.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

REFERENCES

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915  (http://support.microsoft.com/kb/816915/EN-US/ ) New Naming Schema for Microsoft Windows Hotfix Packages

APPLIES TO
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kberrmsg kbbug kbfix kbwin2000presp5fix kbqfe KB819249

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