Artikel-ID: 819536 - Geändert am: Donnerstag, 14. September 2006 - Version: 4.4

Wenn ein Benutzer sich von einem Microsoft Windows 2000- oder Microsoft Windows XP-Computer abmeldet, werden servergespeicherte Profile nicht gespeichert

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Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
819536  (http://support.microsoft.com/kb/819536/EN-US/ ) Roaming profiles are not saved when a user logs off a Microsoft Windows 2000-based computer or a Microsoft Windows XP-based computer
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

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Problembeschreibung

Wenn ein Benutzer sich von einem Microsoft Windows 2000-Computer oder einem Microsoft Windows XP-Computer abmeldet, werden servergespeicherte Profile nicht gespeichert. Im Ereignisprotokoll der Anwendung wird die folgende Fehlermeldung protokolliert:

Quelle: Userenv
Typ: Fehler
Kategorie: Keine
Ereigniskennung: 1000

Beschreibung: Die Registrierungsdatei konnte nicht entfernt werden. Ihre Einstellungen werden nicht repliziert, falls Sie ein servergespeichertes Profil haben. Wenden Sie sich an Ihren Administrator. DETAIL - Zugriff verweigert. Buildnummer ((2195)).

Die folgende Fehlermeldung wird möglicherweise im Ordner "Userenv.log" protokolliert:
USERENV(854.794) 16:20:10:312 MyRegUnLoadKey: Hive unload for S-1-5-21-2121617444-1749639941-654838779-1469 failed due to open registry key. Windows will try unloading the registry hive once a second for the next 60 seconds (max). USERENV(854.794) 16:21:10:500 MyRegUnLoadKey: Windows was not able to unload the registry hive. USERENV(854.794) 16:21:10:500 MyRegUnLoadKey: Failed to unmount hive 5 USERENV(854.794) 16:21:10:500 MyRegUnloadKey: Mutex released. Returning 0. USERENV(854.794) 16:21:10:500 UnloadUserProfile: Didn't unload user profile <err = 5> USERENV(854.794) 16:21:10:500 DumpOpenRegistryHandle: 2 user registry Handles leaked from \Registry\User\S-1-5-21-2121617444-1749639941-654838779-1469 USERENV(854.794) 16:21:10:500 LoadUserProfile: Releasing mutex. USERENV(854.794) 16:21:10:500 UnloadUserProfile: Leaving with a return value of 0

Ursache

Dieses Problem kann auftreten, wenn das Skript für die Benutzeranmeldung Windows Management Instrumentation (WMI) verwendet, um einen Registrierungsschlüssel aufzulisten. Dieses Problem kann zum Beispiel auftreten, wenn der Benutzer ein Microsoft Visual Basic-Anmeldeskript verwendet, das die Funktionen EnumKey und EnumValues aufruft, um Werte in der Registrierung zu lesen. Der Prozess "Winmgmt.exe" gibt möglicherweise einen Handle für einen Registrierungsschlüssel nicht frei. Wenn der Benutzer sich abmeldet, kann Windows die Registrierungsstruktur nicht entfernen.

Lösung

Service Pack-Informationen

Installieren Sie das neueste Service Pack für Windows XP, um das Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/DE/ ) Wie Sie das neueste Service Pack für Windows XP erhalten

Hotfix-Informationen

Ein Hotfix zur Behebung dieses Problems ist inzwischen von Microsoft erhältlich; dieser Hotfix wurde jedoch ausschließlich zur Behebung des in diesem Artikel beschriebenen Problems entwickelt. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Dieser Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf das nächste Service Pack für Microsoft Windows XP zu warten, das diesen Hotfix enthalten wird.

Wenn Sie das Problem sofort beheben möchten, wenden Sie sich an Microsoft Support Services, um den Hotfix zu erhalten. Die Telefonnummern des Technischen Supports lauten:

Deutschland: 0180 567 2255
Österreich: 0150 222 2255
Schweiz: 0848 858 868

Alternativ erhalten Sie auch eine vollständige Liste mit Telefonnummern der Microsoft Support Services unter der folgenden Adresse im World Wide Web:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Voraussetzungen

Keine

Neustart

Sie müssen den Computer nicht neu starten, nachdem Sie diesen Hotfix angewendet haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die lokale Zeit konvertiert. Die Abweichung zwischen UTC-Zeit und lokaler Zeit können Sie im Systemsteuerungsprogramm Datum/Uhrzeit mithilfe der Registerkarte Zeitzone ermitteln.
Windows 2000
   Datum        Zeit   Version            Größe   Dateiname
   ---------------------------------------------------------- 
   24-Apr-2003  15:18  1.50.1085.105     180.312  Stdprov.dll 
Windows XP Professional, 64-Bit Edition (Itanium)
   Datum        Zeit   Version            Größe   Dateiname     Plattform
   ---------------------------------------------------------------------- 
   13-Jun-2003  15:09  5.1.2600.1234     295.424  Stdprov.dll   IA-64
Windows XP, 32-Bit-Versionen (x86)
   Datum        Zeit   Version            Größe   Dateiname
   ---------------------------------------------------------- 
   13-Jun-2003  15:09  5.1.2600.1234      81.408  Stdprov.dll 

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt. Dieses Problem wurde erstmals in Microsoft Windows XP Service Pack 2 behoben.

Informationsquellen

Weitere Informationen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
836051  (http://support.microsoft.com/kb/836051/DE/ ) Ein Visual Basic-Skript erstellt Registrierungsunterschlüssel und sehr langsam Werte in der Teilstruktur HKEY_CURRENT_USER auf einem Windows XP-Computer
824684  (http://support.microsoft.com/kb/824684/DE/ ) Erläuterung von Standardbegriffen bei Microsoft Software Updates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Tablet PC Edition
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