사용자가 Microsoft Windows 2000 기반 컴퓨터를 설정하거나 Windows XP 기반 컴퓨터에 로그온하면 로밍 프로필이 저장되지 않습니다.

기술 자료 번역 기술 자료 번역
기술 자료: 819536 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

사용자가 Microsoft Windows 2000 기반 컴퓨터를 설정하거나 Windows XP 기반 컴퓨터에 로그온하면 로밍 프로필이 저장되지 않습니다. 다음과 같은 오류 메시지가 응용 프로그램 이벤트 로그에 기록됩니다.

원본: Userenv
형식: 오류
범주: 없음
이벤트: 1000

설명: Windows 레지스트리 파일을 언로드할 수 없습니다. 로밍 프로필이 있는 경우 사용자 설정은 복제되지 않습니다. 관리자에게 문의하십시오. 자세한 내용 - 액세스가 거부되었습니다. 빌드 번호 ((2195)).

Userenv.log 폴더에서 다음과 같은 메시지가 기록될 수 있습니다.
USERENV(854.794) 16:20:10:312 MyRegUnLoadKey: S-1-5-21-2121617444-1749639941-654838779-1469 하이브 언로드 레지스트리 키 열 인해 실패했습니다. Windows는 레지스트리 하이브 언로드 초 (최대) 다음 60 초 동안 한 번 시도합니다. USERENV(854.794) 16:21:10:500 MyRegUnLoadKey: Windows에서 레지스트리 하이브를 언로드할 수 없습니다. USERENV(854.794) 16:21:10:500 MyRegUnLoadKey: 하이브를 5 USERENV(854.794) 16:21:10:500 MyRegUnloadKey 분리할 수 없습니다: Mutex 릴리스되었습니다. 0 반환. USERENV(854.794) 16:21:10:500 UnloadUserProfile: 사용자 프로필이 언로드되지 않는 < err = 5 > USERENV(854.794) 16:21:10:500 DumpOpenRegistryHandle: 2 사용자 레지스트리 \Registry\User\S-1-5-21-2121617444-1749639941-654838779-1469 USERENV(854.794) 16:21:10:500 LoadUserProfile에서 핸들 누수가: 뮤텍스 해제. USERENV(854.794) 16:21:10:500 UnloadUserProfile: 반환 값이 0 인 탈퇴하기

원인

레지스트리 키를 열거하는 데 Windows WMI) 사용자 로그온 스크립트를 사용하는 경우 이 문제가 발생할 수 있습니다. 예를 들어, 사용자가 EnumKey 함수를 호출하고 레지스트리에서 값을 읽는 데 EnumValues 함수는 Visual Basic 로그온 스크립트를 사용하는 경우 이 문제가 발생할 수 있습니다. Winmgmt.exe가 프로세스가 레지스트리 키에 대한 핸들을 해제하지 못할 수 있습니다. 사용자가 로그오프할 때 Windows 레지스트리 하이브를 언로드할 수 없습니다.

해결 방법

서비스 팩 정보

이 문제를 해결하려면 Windows XP용 최신 서비스 팩을 구하십시오. 추가 정보는 다음 문서 번호를 클릭하여 Microsoft 기술 자료에서 확인하십시오:
322389최신 Windows XP 서비스 팩을 구하는 방법

핫픽스 정보

Microsoft에서 제공하는 핫픽스를 사용할 수 있습니다. 그러나 이 핫픽스는 이 문서에서 설명된 문제만 해결할 수 있습니다. 이 문서에 설명된 특정 문제가 발생한 시스템에만 이 핫픽스를 적용하십시오.

다운로드할 핫픽스가 있는 경우, 이 기술 자료 문서의 맨 위에 "사용 가능한 핫픽스 다운로드" 링크가 있습니다. 이 섹션이 표시되지 않으면 핫픽스를 구하려면 Microsoft 고객 서비스 및 지원 요청을 제출하십시오.

참고 추가적인 문제가 발생할 경우 또는 모든 문제 해결에 필요한 경우 별도의 서비스 요청을 만들어야 할 수도 있습니다. 핫픽스에 적용되지 않는 추가 지원 질문과 문제에는 일반 지원 비용이 적용됩니다. Microsoft 고객 서비스 지원 전화 번호 전체 목록 또는 별도의 서비스 요청을 만들려면 다음 Microsoft 웹 사이트로 이동하십시오:
http://support.microsoft.com/contactus/?ws=support
참고 "핫픽스 다운로드 가능" 형식에는 핫픽스를 사용할 수 있는 언어가 표시됩니다. 사용자 언어가 표시되지 않으면 해당 언어의 핫픽스를 사용할 수 없습니다 때문입니다.

전제 조건

전제 필요합니다.

재시작 요구 사항

이 핫픽스를 적용한 후에는 컴퓨터를 다시 시작할 필요가 없습니다.

핫픽스 대체 정보

이 핫픽스는 다른 핫픽스를 대체하지 않습니다.

파일 정보

이 핫픽스의 영어 버전은 다음 표에 나열된 파일 특성(또는 그 이후의 파일 특성)이 있습니다. 이러한 파일의 시간과 날짜는 UTC (협정 세계시) 로 나열됩니다. 파일 정보에서는 현지 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 알려면 제어판의 날짜 및 시간 도구에서 표준 시간대 탭을 사용하십시오.
Windows 2000
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Apr-2003  15:18  1.50.1085.105     180,312  Stdprov.dll 
Windows XP Professional 64비트 Edition (Itanium)
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Jun-2003  15:09  5.1.2600.1234     295,424  Stdprov.dll      IA-64
Windows XP 32비트 x 86 기반 버전
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Jun-2003  15:09  5.1.2600.1234      81,408  Stdprov.dll 

현재 상태

Microsoft는 "본 문서의 정보는 다음의 제품에 적용됩니다." 절에 나열된 Microsoft 제품에서 이 문제를 확인했습니다. 이 문제는 Microsoft Windows XP 서비스 팩 2에서 처음 수정되었습니다.

참조

자세한 내용은 Microsoft 기술 자료에 있는 문서를 보려면 다음 문서 번호를 클릭하시기 바랍니다:
836051Visual Basic 스크립트를 Windows XP 기반 컴퓨터에 레지스트리 하위 키와 값은 HKEY_CURRENT_USER 하위 트리 매우 느리게 에서 만듭니다.
824684Microsoft 소프트웨어 업데이트를 설명하는 데 사용되는 표준 용어에 대한 설명

속성

기술 자료: 819536 - 마지막 검토: 2006년 10월 25일 수요일 - 수정: 4.7
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
키워드:?
kbmt kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbscript kbprofiles kbwbem kbclientserver kbclient kbwin2000sp5fix kbwinxppresp2fix kbwin2000presp5fix kbpolicy kblogin kbevent kbuser kbqfe kbfix kbbug KB819536 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com