Windows desconecta la alimentación eléctrica después de apagar el equipo si un programa llama a la función ExitWindowsEx o InitiateSystemShutdownEx

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Síntomas

Si un programa llama a la función ExitWindowsEx y también utiliza el indicador EWX_SHUTDOWN , Windows puede apagar la alimentación en lugar de mostrar el mensaje "It ahora es seguro apagar el equipo" como se esperaba. Este comportamiento se produce también si se utiliza la función InitiateSystemShutdownEx para apagar el equipo.

Nota La función InitiateSystemShutdownEx puede utilizarse sólo si el sistema admite la característica de apagado.

Causa

Windows Server 2003 trata el indicador EWX_SHUTDOWN igual que el indicador EWX_POWEROFF . En otras palabras, Windows desconecta la alimentación después apaga el equipo si el sistema admite la característica de apagado.

Solución

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Microsoft Windows Server 2003. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100Cómo obtener la versión más reciente del Service Pack para Windows Server 2003

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Versiones de 32 bits de Windows Server 2003
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Mar-2005  18:47  5.2.3790.287      380,928  Licdll.dll       
   13-Mar-2005  06:50  5.2.3790.287    2,407,936  Ntkrnlmp.exe
   13-Mar-2005  02:28  5.2.3790.287    2,064,896  Ntkrnlpa.exe     
   13-Mar-2005  03:27  5.2.3790.287    2,109,952  Ntkrpamp.exe
   13-Mar-2005  06:34  5.2.3790.287    2,208,768  Ntoskrnl.exe     
   26-Dec-2004  21:17                  1,513,002  System.adm
   13-Mar-2005  07:59  5.2.3790.287      540,672  Winlogon.exe     
   24-Feb-2005  20:24  6.1.22.4          371,936  Updspapi.dll
Versiones de Server 2003 64 bits de Windows
   Date         Time   Version         Size       File name     Platform
   ---------------------------------------------------------------------
   13-Mar-2005  06:17  5.2.3790.287    5,606,912  Ntkrnlmp.exe  IA-64
   26-Dec-2004  20:17                  1,513,002  System.adm
   13-Mar-2005  02:20  5.2.3790.287      639,488  Winlogon.exe  IA-64
   25-Feb-2005  02:52  6.1.22.4          639,712  Updspapi.dll  IA-64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".
Este problema se corrigió por primera vez en Windows Server 2003 Service Pack 1.

Más información

Windows Server 2003

Para resolver este problema en Windows Server 2003, siga estos pasos después de instalar el hotfix que se describe en "Solución" sección:
  1. Haga clic en Inicio , haga clic en Ejecutar y, a continuación, escriba gpedit.msc .
  2. En Directiva de equipo local , expanda Configuración del equipo , expanda Plantillas administrativas y, a continuación, expanda sistema .
  3. Haga doble clic en No apague sistema después de que se haya cerrado el sistema Windows .
  4. Haga clic en la ficha configuración , haga clic en habilitada y, a continuación, haga clic en Aceptar .

Windows Small Business Server 2003

Para resolver este problema en Small Business Server 2003, siga estos pasos después de instalar la revisión descrita en la sección "Solución":
  1. Haga clic en Inicio , haga clic en Ejecutar y, a continuación, escriba gpmc.msc .
  2. Expanda directivas de dominio y bosque y, a continuación, busque el Equipo cliente de Small Business Server directiva.
  3. Haga clic con el botón secundario del mouse en el Small Business Server Client equipo directiva y seleccione Modificar .
  4. Expanda Configuración del equipo , expanda Plantillas administrativas y, a continuación, expanda sistema .
  5. Haga doble clic en No apague sistema después de que se haya cerrado el sistema Windows .
  6. Haga clic en la ficha configuración , haga clic en habilitada y, a continuación, haga clic en Aceptar .
Como alternativa, en Windows Small Business Server 2003, quizás desee aplicar la configuración sólo al servidor. Para ello, siga estos pasos.

importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Realice una para agregar protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
  1. Instale la revisión.
  2. Inicie el Editor del registro en el servidor y, a continuación, busque la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows NT\DontPowerOffAfterShutdown
  3. Escriba 1 como el REG_DWORD valor.
También puede agregar el valor del registro escribiendo lo siguiente en un símbolo en el servidor de Windows Small Business 2003:
reg add HKLM\Software\Policies\Microsoft\Windows NT /v DontPowerOffAfterShutdown /t REG_DWORD /d 1 /f

Propiedades

Id. de artículo: 819760 - Última revisión: lunes, 03 de diciembre de 2007 - Versión: 8.11
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwinserv2003presp1fix KB819760 KbMtes
Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 819760

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