"Unable to read file" error message when you open Excel file that contains a PivotTable report

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Article ID: 819853 - View products that this article applies to.
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SYMPTOMS

When you open an Excel workbook that contains a PivotTable report, you may receive the following error message:
Unable to read file.
When you click OK, you receive the following error message:
Errors were detected in 'filename.xls', but Microsoft Excel was able to open the file by making the repairs listed below. Save the file to make these repairs permanent.

PivotTable report 'report_name' on '[filename.xls]worksheet_name' was discarded due to integrity problems.
After you click Close to close the error message, the PivotTable drop-down fields do not appear. Additionally, if you try to open the file again, Excel quits.

CAUSE

This problem occurs if the following conditions are true :
  • AutoRecovery is enabled.
  • You open an unprotected workbook that contains a PivotTable report.
  • You turn worksheet protection on, and then you turn worksheet protection off.
Note This problem may also be caused by any form of mail operation and some forms of shared editing.

RESOLUTION

Service pack information

This problem is corrected in Office XP Service Pack 3. To resolve this problem, obtain the latest service pack for Microsoft Office XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 How to obtain the latest Office XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size        File name
   -------------------------------------------
   09-May-2003  22:43   4,808,732  Excelop.msp  (Client update)
   09-May-2003  23:52  16,554,576  Excelff.msp  (Full file update)

				
After the hotfix is installed, the global version of this fix will have the file attributes (or later) that are listed in the following table.
   Date         Time   Version      Size       File name
   -----------------------------------------------------
   08-May-2003  21:08  10.0.5306.0  9,181,768  Excel.exe        

				
This hotfix is a post-Office XP Service Pack 2 (SP-2) hotfix. To install the hotfix, you must have Office XP SP-2 installed. For more information about Office XP SP-2, click the following article number to see the article in the Microsoft Knowledge Base:
325671 Description of the Office XP Service Pack 2 (SP2)
Additionally, you may have to install Windows Installer 2.0 to install this hotfix. For more information about the Windows Installer requirement for post-Office XP SP-2 hotfixes, click the following article number to see the article in the Microsoft Knowledge Base:
330537 Office XP updates and patches released after September 2002 may require Windows Installer 2.0

WORKAROUND

To work around this problem, turn off AutoRecovery when you work with any workbooks that perform actions similar to those listed in the "Cause" section of this article. To do this, follow these steps:
  1. Start Excel.
  2. On the Tools menu, click Options.
  3. On the Save tab, click to clear the Save AutoRecover info every check box.
  4. Click OK to close the Options dialog box.

MORE INFORMATION

When you open an unprotected workbook with AutoRecovery enabled, and then you turn on Worksheet protection, portions of the file are flagged as encrypted when AutoRecovery runs. When you turn off worksheet protection, the encrypted source stream is decrypted with the password that is used during AutoRecovery. That stream is flagged as unencrypted, and then that stream is saved when the file is saved. When you then try to open the corrupted file, Excel quits. For more information about a similar problem, click the following article number to view the article in the Microsoft Knowledge Base:
322238 Pivot table fields do not function after Excel repairs and recovers file

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Office XP Service Pack 3.

Properties

Article ID: 819853 - Last Review: October 9, 2011 - Revision: 5.0
APPLIES TO
  • Microsoft Excel 2002 Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbopenfile kberrmsg kbbug kbfix kbofficexppresp3fix KB819853

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