Messaggio di errore "Impossibile leggere il file" quando si apre file di Excel che contiene un rapporto di tabella pivot

Traduzione articoli Traduzione articoli
Identificativo articolo: 819853 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si apre una cartella di lavoro Excel contenente una tabella pivot report, Ŕ possibile che venga visualizzato il seguente messaggio di errore:
Impossibile leggere il file.
Quando si fa clic su OK , viene visualizzato il seguente messaggio di errore:
Sono stati rilevati errori in filename xls", ma Ŕ stato in grado di aprire il file effettuando le correzioni elencate di seguito. Salvare il file per rendere permanenti le operazioni effettuate.

Tabella pivot report ' report_name ' su '[filename xls] worksheet_name' Ŕ stata scartata per problemi di integritÓ.
Dopo aver scelto l'opzione Chiudi per chiudere il messaggio di errore, non vengono visualizzati i campi di tabella pivot a discesa. Inoltre, se si tenta di aprire nuovamente il file, Excel viene chiuso.

Cause

Questo problema si verifica se le seguenti condizioni sono vere:
  • Salvataggio automatico Ŕ attivato.
  • Si apre una cartella di lavoro non protetto contiene una tabella pivot report.
  • Attivare protezione del foglio di lavoro e quindi si disattiva protezione del foglio di lavoro.
Nota Questo problema potrebbe essere causato anche da qualsiasi tipo di operazione di posta elettronica e alcune forme di modifica condivisa.

Risoluzione

Informazioni sul Service pack

Questo problema Ŕ stato corretto in Office XP Service Pack 3.Per risolvere il problema, procurarsi l'ultimo service pack per Microsoft Office XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
307841Come ottenere il service pack pi¨ recente per Office XP

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.La versione globale di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
   Date         Time   Size        File name
   -------------------------------------------
   09-May-2003  22:43   4,808,732  Excelop.msp  (Client update)
   09-May-2003  23:52  16,554,576  Excelff.msp  (Full file update)

				
Dopo avere installato la correzione, la versione globale di questa soluzione avrÓ gli attributi di file elencati nella tabella seguente (o successivi).
   Date         Time   Version      Size       File name
   -----------------------------------------------------
   08-May-2003  21:08  10.0.5306.0  9,181,768  Excel.exe        

				
Questo aggiornamento rapido (hotfix) Ŕ successivi a Office XP Service Pack 2 (SP-2). Per installare l'hotfix, Ŕ necessario che Office XP SP-2 installato. Per ulteriori informazioni su Office XP SP-2, fare clic il seguente numero articolo vedere l'articolo della Microsoft Knowledge Base riportato di seguito:
325671Descrizione di Office XP Service Pack 2 (SP2)
Inoltre, Ŕ necessario installare Windows Installer 2.0 per installare questo hotfix. Per ulteriori informazioni sui requisiti di Windows Installer per successivi a Office XP SP-2 hotfix, fare clic il seguente numero articolo vedere l'articolo della Microsoft Knowledge Base riportato di seguito:
330537Gli aggiornamenti e Office XP patch rilasciate dopo il mese di settembre 2002 possono richiedere Windows Installer 2.0

Workaround

Per risolvere questo problema, disattivare automaticamente quando si lavora con le cartelle di lavoro che eseguono azioni simili a quelli elencati nella sezione "Cause" di questo articolo. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Avviare Excel.
  2. Scegliere Opzioni dal menu Strumenti .
  3. Nella scheda Salva , fare clic per deselezionare il Salva automaticamente ogni casella di controllo.
  4. Fare clic su OK per chiudere la finestra di dialogo Opzioni .

Informazioni

Quando si apre una cartella di lavoro non protetto con salvataggio automatico attivato e quindi attivare la protezione del foglio di lavoro, parti del file vengono contrassegnati come crittografati quando viene eseguito automaticamente. Quando disattiva la protezione del foglio di lavoro, il flusso di origine crittografati decrittografia con la password utilizzata durante il salvataggio automatico. Tale flusso Ŕ contrassegnato come non crittografati e quindi tale flusso viene salvato quando viene salvato il file. Quando si tenta di aprire il file danneggiato, Excel viene chiuso. Per ulteriori informazioni su un problema simile, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322238Campi di tabella pivot non funzionano dopo Excel Ripristina e ripristino file

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a". Questo problema Ŕ stato innanzitutto corretto nel Service Pack 3 per Office XP.

ProprietÓ

Identificativo articolo: 819853 - Ultima modifica: lunedý 5 febbraio 2007 - Revisione: 4.3
Le informazioni in questo articolo si applicano a:
  • Microsoft Excel 2002 Standard Edition
Chiavi:á
kbmt kbautohotfix kbqfe kbhotfixserver kbopenfile kberrmsg kbbug kbfix kbofficexppresp3fix KB819853 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 819853
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com