A Program Stops Performing a Task or Explorer.exe Uses 100 Percent of the CPU When You Right-Click an Item in Windows Explorer

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Article ID: 819946 - View products that this article applies to.
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SYMPTOMS

When you right-click an item (such as a file, a folder, or a network connection) in Windows Explorer or in My Computer, other programs may temporarily stop performing a task. For example, a video that is being played in Microsoft Windows Media Player may temporarily stop being played.

If you start Windows Task Manager, you may notice on the Processes tab that the Explorer.exe process is using a lot (or 100 percent) of the CPU resources. To start Windows Task Manager, right-click an empty area on the taskbar, and then click Task Manager.

CAUSE

This problem occurs if the following settings are turned on, and you right-click an item to select that item:
  • Show common tasks in folders
  • Fade or slide menus into view
By default, both of these settings are turned on in Windows XP.

If these settings are turned on, information about the selected item is shown in the Tasks pane in Windows Explorer by using an animation. If you open a shortcut menu (the menu that appears when you right-click an item) while this animation is occurring, the animation may not be able to finish (and may use a lot of the CPU resources) until you close the shortcut menu.

WORKAROUND

To work around this problem, select the item before you right-click it. To select an item, either click the item or rest the mouse pointer on the item.

You can avoid this problem by turning off either of the settings that are listed in the "Cause" section of this article. To do this, use one of the following methods:

Method 1: Turn Off the "Fade or Slide Menus into View" Visual Effect

  1. Click Start, and then click Control Panel.
  2. Click Performance and Maintenance, and then click System (or double-click the System icon).
  3. On the Advanced tab, click Settings under Performance.
  4. On the Visual Effects tab, click to clear the Fade or slide menus into view check box.
  5. Click OK.

Method 2: Use Classic Windows Folders

  1. Click Start, and then click Control Panel.
  2. Click Appearance and Themes, and then click Folder Options (or double-click the Folder Options icon).
  3. On the General tab, click Use Windows classic folders.
  4. Click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For help with system performance issues in Windows Vista, visit the following Microsoft web page:
Problems with overall system speed and system performance

Properties

Article ID: 819946 - Last Review: February 5, 2007 - Revision: 2.5
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP 64-Bit Edition Version 2003
Keywords: 
kbprb KB819946

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