エクスプローラで項目を右クリックすると、プログラムの実行が停止するか、Explorer.exe が CPU を 100 パーセント使用する

文書翻訳 文書翻訳
文書番号: 819946 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

エクスプローラまたは [マイ コンピュータ] で項目 (ファイル、フォルダ、またはネットワーク接続など) を右クリックすると、他のプログラムが一時的にタスクの実行を停止することがあります。たとえば、Microsoft Windows Media Player で再生中のビデオの再生が一時的に停止することがあります。

Windows タスク マネージャを起動すると、[プロセス] タブに、Explorer.exe プロセスが大量 (100 パーセント) の CPU リソースを使用中であることが表示される場合があります。Windows タスク マネージャを起動するには、タスクバーの空の領域を右クリックして、[タスク マネージャ] をクリックします。

原因

この問題は、次の設定がオンになっていて、項目を右クリックして選択した場合に発生します。
  • フォルダに共通の作業を表示する
  • メニューをフェードまたはスライドして表示する
Windows XP ではデフォルトで、これらの両方の設定がオンになっています。

これらの設定がオンになっている場合、エクスプローラのタスク ウィンドウに、選択した項目の情報がアニメーションで表示されます。このアニメーションの実行中に、ショートカット メニュー (項目を右クリックすると表示されるメニュー) を開くと、ショートカット メニューを閉じるまで、アニメーションが終了しないことがあります (また、大量の CPU リソースを使用することがあります)。

回避策

この問題を回避するには、項目を右クリックする前に、項目を選択しておきます。項目を選択するには、項目をクリックするか、項目の上にマウス ポインタを置きます。

この資料の「原因」に挙げた設定のいずれかをオフにすることによって、この問題を回避することができます。 この操作を実行するには、次のいずれかの方法を使用します。

方法 1 : [メニューをフェードまたはスライドして表示する] 視覚効果をオフにする

  1. [スタート] ボタンをクリックし、[コントロール パネル] をクリックします。
  2. [パフォーマンスとメンテナンス] をクリックし、[システム] をクリックします (または [システム] アイコンをダブルクリックします)。
  3. [詳細設定] タブで、[パフォーマンス] の下の [設定] をクリックします。
  4. [視覚効果] タブの [メニューをフェードまたはスライドして表示する] をクリックしてオフにします。
  5. [OK] をクリックします。

方法 2 : 従来の Windows フォルダを使用する

  1. [スタート] ボタンをクリックし、[コントロール パネル] をクリックします。
  2. [デスクトップの表示とテーマ] をクリックし、[フォルダ オプション] をクリックします (または [フォルダ オプション] アイコンをダブルクリックします)。
  3. [全般] タブで、[従来の Windows フォルダを使う] をクリックします。
  4. [OK] をクリックします。

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 819946 (最終更新日 2003-05-11) を基に作成したものです。

プロパティ

文書番号: 819946 - 最終更新日: 2003年5月23日 - リビジョン: 2.2
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP 64-Bit Edition Version 2003
キーワード:?
kbprb KB819946
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com