Komputer przestaje odpowiadać lub pojawia się komunikat o błędzie „Ehshell.exe - Common Language Runtime Debugging Services” podczas wykonywania powtarzalnych zadań w aplikacji Media Center

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 820121 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Podczas wykonywania powtarzalnych zadań w programie Media Center na komputerze z systemem Windows XP Media Center Edition komputer może przestać odpowiadać (zawiesić się) lub może się pojawić następujący komunikat o błędzie:
ehshell.exe - Common Language Runtime Debugging Services

Application has generated an exception that could not be handled. (ehshell.exe — Aparat plików wykonywalnych języka wspólnego usług debugowania. Aplikacja wygenerowała wyjątek, który nie może być obsługiwany).

Process id=0xa18 (2584), Thread id=0xa24 (2596).

Przyczyna

Ten problem może się pojawić w przypadku wykonania jednego lub kilku powtarzalnych zadań w programie Media Center:
  • Zostały zaplanowane programy telewizyjne do nagrania.
  • W powtarzalny sposób zmieniasz rozmiar okna programu Media Center, minimalizujesz lub zmieniasz jego rozmiar.
  • W powtarzalny sposób zmieniasz kanał w czasie, gdy w oknie otwarty jest program Media Center.

Rozwiązanie

Informacje o dodatku Service Pack

W celu rozwiązania tego problemu należy uzyskać najnowszy dodatek Service Pack dla systemu Microsoft Windows XP. Aby uzyskać dodatkowe informacje, kliknij numer artykułu poniżej w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322389 Jak uzyskać najnowszy dodatek Service Pack dla systemu Windows XP

Informacje o poprawce

Firma Microsoft udostępniła już poprawkę dla systemów z procesorami o częstotliwości równej lub większej niż 2,4 GHz oraz określonymi funkcjami, ale jest ona przeznaczona wyłącznie do rozwiązywania problemu opisanego w tym artykule. Powinna być stosowana tylko w systemach, w których ten problem występuje. Poprawka może być wciąż w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następny dodatek Service Pack dla systemu Windows XP zawierający tę poprawkę.

Aby natychmiast rozwiązać ten problem, skontaktuj się z Pomocą techniczną firmy Microsoft w celu otrzymania poprawki. Aby uzyskać pełną listę numerów telefonów Pomocy technicznej firmy Microsoft, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/gp/cok
UWAGA:

Wersja anglojęzyczna tej poprawki ma atrybuty pliku pokazane w poniższej tabeli (lub nowsze). Daty i godziny ostatniej modyfikacji plików podano zgodnie z czasem UTC (Coordinated Universal Time). Są one zamieniane na czas lokalny po wyświetleniu informacji o pliku. Aby zobaczyć różnicę między czasem UTC i czasem lokalnym, należy skorzystać z karty Strefa czasowa narzędzia Data i godzina w Panelu sterowania.
   Data         Godzina Wersja           Rozmiar  Nazwa pliku
   -----------------------------------------------------------
   01-maj-2003  13:34   5.1.2600.1198  1 821 696  Acgenral.dll
   01-maj-2003  10:31                  1 087 770  Sysmain.sdb				

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Informacje zawarte w tym artykule dotyczą”. Ten problem został rozwiązany po raz pierwszy w dodatku Service Pack 2 dla systemu Microsoft Windows XP.

Właściwości

Numer ID artykułu: 820121 - Ostatnia weryfikacja: 13 marca 2007 - Weryfikacja: 2.2
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows XP Media Center Edition
Słowa kluczowe: 
kberrmsg kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver KB820121

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com