O computador deixa de responder ou o utilizador recebe uma mensagem de erro "Ehshell.exe - Common Language Runtime Debugging Services" quando efectua tarefas repetitivas no Media Center

Artigo: 820121 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando efectua tarefas repetitivas no Media Center ou num computador baseado no Windows XP Media Center Edition, o computador poderá deixar de responder (não reagir), ou o utilizador poderá receber a seguinte mensagem de erro:
ehshell.exe - Common Language Runtime Debugging Services

Application has generated an exception that could not be handled.

Process id=0xa18 (2584), Thread id=0xa24 (2596).

Causa

Este problema poderá ocorrer se efectuar uma ou mais vezes as seguintes tarefas repetitivas no Media Center:
  • Agendar a gravação de programas de TV.
  • Redimensionar, minimizar ou restaurar repetidamente a janela do Media Center.
  • Mudar repetidamente de canal enquanto o Media Center está no modo de janela.

Resolução

Informações sobre Service Packs

Para resolver este problema, obtenha o Service Pack mais recente do Microsoft Windows XP. Para obter informações adicionais, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
322389 Como obter o Service Pack mais recente do Windows XP

Informações sobre a correcção

A Microsoft tem já disponível uma correcção suportada para os sistemas com processadores a 2,4GHz, ou superiores, e determinadas funcionalidades específicas, mas destina-se apenas a corrigir o problema descrito neste artigo. Aplique-a apenas em computadores que tenham este problema específico. Esta correcção poderá ser submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, a Microsoft recomenda que aguarde pelo próximo Service Pack do Windows XP que contenha esta correcção.

Para resolver este problema imediatamente, contacte o suporte técnico da Microsoft para obter a correcção. Para obter uma lista completa dos números de telefone do suporte técnico da Microsoft, bem como informações sobre os custos de suporte, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;PT;CNTACTMS
NOTA: em casos especiais, os custos normalmente inerentes às chamadas de suporte poderão ser anulados, se um técnico de suporte da Microsoft determinar que uma actualização específica resolverá o problema. Os custos normais do suporte serão aplicados a problemas e questões de suporte adicionais, não incluídos na actualização específica em questão.

A versão inglesa desta correcção tem os atributos de ficheiro listados na seguinte tabela (ou posteriores). As datas e horas destes ficheiros são indicadas no formato de hora universal coordenada (UTC, Coordinated Universal Time). Ao visualizar as informações dos ficheiros, estas serão convertidas na hora local. Para determinar a diferença entre a hora UTC e a hora local, utilize o separador Time Zone da ferramenta Date and Time do Control Panel.
   Data         Hora   Versão         Tamanho    Ficheiro
   ----------------------------------------------------------
   01-May-2003  13:34  5.1.2600.1198  1,821,696  Acgenral.dll
   01-May-2003  10:31                 1,087,770  Sysmain.sdb				

Ponto Da Situação

A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a". Este problema foi corrigido pela primeira vez no Microsoft Windows XP Service Pack 2.

Propriedades

Artigo: 820121 - Última revisão: terça-feira, 7 de Novembro de 2006 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Media Center Edition
Palavras-chave: 
kberrmsg kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver KB820121

Submeter comentários