提交打印作业时后台打印程序服务崩溃并且系统日志中记录了事件 ID 7031 消息

文章翻译 文章翻译
文章编号: 820550 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

症状

当您向网络打印机发送一个打印任务时,服务器上主管此打印机的后台打印程序服务可能会突然关闭。当您在打印作业中选择了打印多个副本以及使用了 RAW 数据类型时,这种情况就可能发生。

原因

如果后台打印程序服务中发生了访问冲突,就可能发生此问题。如果打印缓冲区空间不足,则必须重新分配。但是,在对缓冲区重新分配的调用中,GetPrinterInfo 函数分配一个 0 字节缓冲区,于是就发生了访问冲突。

解决方案

修补程序信息

Microsoft 提供了一个受支持的修补程序。但此修补程序只用于解决本文中提到的问题。请仅对出现这一特定问题的系统应用此修补程序。

如果可以下载此修补程序,此知识库文章顶部将存在“提供修补程序下载”部分。如果此部分不存在,请向 Microsoft 客户支持服务部门提交请求以获取该修补程序。

注意:如果发生其他问题或需要进行任何疑难解答,您可能需要另行创建服务请求。对于此特定修补程序无法解决的其他支持问题和事项,将照常收取支持费用。有关 Microsoft 客户支持服务部门的电话号码的完整列表,或者另行创建服务请求,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support
注意:“提供修补程序下载”窗体显示了修补程序提供的语言。如果找不到需要的语言,则说明修补程序没有那种语言的版本。

先决条件

安装此修补程序必须先安装 Windows 2000 Service Pack 3 (SP3)。

修补程序替代信息

此修补程序不替代任何其他修补程序。

文件信息

此修补程序的英语版具有下表中列出的文件属性(或更新的属性)。这些文件的日期和时间以协调世界时 (UTC) 格式列出。当您查看文件信息时,该时间将转换为本地时间。要了解 UTC 与本地时间之间的时差,请使用“控制面板”中的“日期和时间”工具中的“时区”选项卡。
   日期         时间   版本        大小     文件名
   --------------------------------------------------------
2003-06-11  15:50  5.0.2195.6749  252,176  Localspl.dll
2003-06-11  15:50  5.0.2195.6741   80,656  Spoolss.dll
2003-06-11  15:50  5.0.2195.6681   97,040  Win32spl.dll
目前有两种版本的修补程序可供下载使用。一个被标记为“Free I386”,另一个被标记为“Free x86”。Free x86 修补程序包含此修补程序中列出的最新版本的文件。不要下载 free I386 版本,否则此修补程序无法正确安装,并且您可能会收到 Microsoft 知识库文章 822384 中提到的错误消息。如果遇到此问题,则表示您具有不正确的版本,并且必须获取 free x86 版本。

状态

Microsoft 已经确认这是在本文的“适用于”部分中列出的 Microsoft 产品中存在的问题。

更多信息

有关如何命名修补程序包的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
816915 Microsoft Windows 软件更新包的新文件命名方案

属性

文章编号: 820550 - 最后修改: 2008年9月11日 - 修订: 5.5
这篇文章中的信息适用于:
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Service Pack 3
关键字:?
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB820550
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com