Problemi durante l'esecuzione di un programma che accede a un'unitÓ DVD-ROM o CD-RW USB 2.0

Traduzione articoli Traduzione articoli
Identificativo articolo: 820759 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si esegue un programma che accede a un'unitÓ DVD-ROM o CD-RW USB (Universal Serial Bus) 2.0, si possono verificare problemi simili a quelli descritti nei seguenti scenari:
  • Se si esegue Intervideo WinDVD con un'unitÓ DVD-ROM USB 2.0, l'audio o il video pu˛ risultare distorto e potrebbe essere problematico visualizzare un particolare menu o scena del disco. Questi problemi si verificano quando si riproduce un DVD per un determinato periodo di tempo, ad esempio da 30 a 60 minuti, si chiude e si riavvia WinDVD e si tenta di nuovo di riprodurre il DVD.
  • Se si esegue Easy CD Creator di Roxio, ad esempio la versione 5, con un'unitÓ CD-RW USB 2.0 e si utilizza la funzionalitÓ di copia del disco, quando tale funzionalitÓ tenta di trovare l'unitÓ CD-RW potrebbe essere visualizzato un messaggio di errore analogo al seguente:
    Impossibile trovare un lettore di CD di supporto.
    In un computer basato su Windows 2000 pu˛ anche essere visualizzato un messaggio di rimozione non sicura di una periferica che si riferisce all'unitÓ CD-RW, oppure pu˛ essere visualizzato il messaggio "Windows 2000 ha terminato l'installazione delle nuove periferiche" e viene richiesto di riavviare il computer perchÚ le modifiche abbiano effetto.
  • Se si esegue Easy CD Creator di Roxio, ad esempio la versione 5, con un'unitÓ CD-RW USB 2.0, potrebbe non essere possibile cancellare un disco CD-RW esistente.

Cause

Questi problemi possono verificarsi se il controller host genera un comando di reimpostazione del bus USB dopo avere ricevuto numerosi pacchetti USB STALL dalla periferica DVD-ROM o CD-RW. Questi pacchetti STALL sono solitamente generati dalla periferica in risposta a un comando che il controller host non Ŕ in grado di eseguire.

Quando si verifica questa situazione mentre nel bus Ŕ presente un'ulteriore quantitÓ di traffico significativa, il driver del controller host USB 2.0 (Usbehci.sys) pu˛ non riuscire a restituire lo stato dei risultati corretto per un trasferimento USB che Ŕ stato interrotto a causa della condizione STALL. Questa condizione pu˛ fare in modo che i driver USB di livello superiore non interpretino correttamente lo stato della periferica e del bus USB. I driver generano quindi una reimpostazione del bus per risolvere le condizioni di errore e reinizializzare la periferica USB nel bus.

Le operazioni critiche comprendono il rilevamento dell'unitÓ CD-RW o l'autenticazione di un titolo DVD. Se la reimpostazione del bus USB si verifica durante l'esecuzione di un'operazione critica, tale operazione pu˛ non andare a buon fine e potrebbe non essere possibile correggere l'errore da parte dell'applicazione, vale a dire da un lettore di DVD o da un masterizzatore. Questa condizione causa i sintomi descritti nella sezione "Sintomi" del presente articolo.

Nota Tra le periferiche USB che generano ulteriore traffico USB sufficiente a causare i problemi descritti nella sezione "Sintomi" sono comprese:
  • Schede Bluetooth, comprese quelle incorporate nei computer portatili
  • Periferiche Pocket PC che eseguono un'operazione ActiveSync mediante una connessione USB

Risoluzione

Informazioni sul service pack per Windows XP

Per risolvere il problema, procurarsi il service pack pi¨ recente per Microsoft Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322389 Come ottenere il service pack pi¨ recente per Windows XP

Informazioni sull'aggiornamento rapido

Windows Server 2003

╚ disponibile una correzione supportata da Microsoft, che Ŕ tuttavia destinata esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. ╚ possibile che la correzione venga sottoposta ad altre verifiche allo scopo di migliorare ulteriormente la qualitÓ del prodotto. Se dunque questo problema non causa gravi difficoltÓ, si consiglia di attendere la versione successiva del service pack di Windows Server 2003 contenente tale correzione.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere la correzione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo:
http://support.microsoft.com/default.aspx?scid=fh;IT;CNTACTMS
Nota In casi particolari le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverÓ il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.
Informazioni sui file
La versione in lingua inglese di questa correzione presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data        Ora    Versione     Dimensione  Nome file    Piattaforma
   --------------------------------------------------------------------
   13/05/2003  00.40  5.2.3790.25      19.968  Usbehci.sys  i386
   13/05/2003  00.40  5.2.3790.25      61.312  Usbehci.sys  ia64

Windows XP

╚ disponibile una correzione supportata da Microsoft, che Ŕ tuttavia destinata esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarla solo nei computer in cui si verifica questo problema specifico. ╚ possibile che su questa correzione vengano eseguite ulteriori verifiche. Se pertanto questo problema non causa gravi difficoltÓ, si consiglia di attendere la versione successiva del service pack di Windows XP contenente tale correzione.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere la correzione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo:
http://support.microsoft.com/default.aspx?scid=fh;IT;CNTACTMS
NOTA: in casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverÓ il problema. I normali costi dell'assistenza verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questa correzione presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data        Ora    Versione       Dimensione   Nome file    Piattaforma
   -----------------------------------------------------------------------
   13/05/2003  01.14  5.1.2600.1222      19.456   Usbehci.sys  i386
   12/05/2003  04.22  5.1.2600.1221     137.600   Usbport.sys  i386
   13/05/2003  01.14  5.1.2600.1222      64.768   Usbehci.sys  ia64
   10/05/2003  13.10  5.1.2600.1221     482.816   Usbport.sys  ia64
				

Windows 2000

╚ disponibile un aggiornamento rapido supportato da Microsoft, destinato esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico.

Per risolvere il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'aggiornamento rapido. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Nota In casi particolari le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverÓ il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questa correzione presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data            Ora    Versione Dimensione  Nome file
   --------------------------------------------------------
   15/01/2003  19.45  5.0.2195.6655   24.752  Hidclass.sys
   08/05/2003  17.22  5.0.2195.6743   24.912  Openhci.sys
   23/04/2003  17.52  5.0.2195.6739   32.944  Uhcd.sys
   23/04/2003  17.52  5.0.2195.6739   20.752  Usbd.sys
   13/05/2003  19.47  5.0.2195.6745   19.728  Usbehci.sys
   15/01/2003  19.46  5.0.2195.6655   49.776  Usbhub20.sys
   28/04/2003  17.41  5.0.2195.6741  138.768  Usbport.sys
				

Workaround

Per risolvere questi problemi, riavviare il computer. In questo modo il problema potrebbe anche essere risolto.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine di questo articolo. Questo problema Ŕ stato corretto per la prima volta nel Service Pack 2 per Microsoft Windows XP.

Informazioni

I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilitÓ di tali prodotti.

ProprietÓ

Identificativo articolo: 820759 - Ultima modifica: lunedý 3 dicembre 2007 - Revisione: 6.3
Le informazioni in questo articolo si applicano a
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Chiavi:á
kbbug kbfix kbqfe kbsound kbdriver kbwinxpsp2fix kbdisplay kbwinxppresp2fix kbwin2000presp5fix kbwinserv2003presp1fix kbhotfixserver KB820759
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com