Проблемы при запуске программы, обращающейся к дисководам DVD или CD-RW с интерфейсом USB 2.0

Переводы статьи Переводы статьи
Код статьи: 820759 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

При запуске программы, обращающейся к дисководам DVD-ROM или CD-RW с интерфейсом USB (Universal Serial Bus) 2.0, могут возникать следующие проблемы.
  • При обращении программы Intervideo WinDVD к дисководу DVD-ROM с интерфейсом USB 2.0 могут наблюдаться искажения при воспроизведении изображения или звука, а также могут возникать проблемы при обращении к некоторым меню или сценам на диске. Это происходит, если через некоторое время после начала воспроизведения диска (например, через 30-60 минут) закрыть программу WinDVD, перезапустить ее и начать воспроизведение этого диска заново.
  • Если в системе установлен дисковод CD-RW с интерфейсом USB 2.0, то при запуске программы Roxio Easy CD Creator (например, версии 5) в режиме копирования диска при распознавании дисковода CD-RW может появляться следующее сообщение об ошибке.
    Disc Copier could not find a supported CD-ROM reader
    На компьютерах под управлением Windows 2000 также может появляться сообщение о небезопасном извлечении устройства. Указанное сообщение относится к дисководу CD-RW. Кроме того, может появляться сообщение о том, что установка новых устройств закончена, после чего операционная система предлагает перезагрузить компьютер.
  • Если в системе установлен дисковод CD-RW с интерфейсом USB 2.0, то при запуске программы Roxio Easy CD Creator (например, версии 5) может не удаваться стирание диска CD-RW.

Причина

Описанная проблема возникает, если после получения от устройства DVD или CD-RW нескольких пакетов USB STALL хост-контроллер выполняет сброс шины USB. Как правило, устройство отправляет пакеты STALL, если оно не может выполнить команду.

Если в момент появления пакетов STALL на шине присутствует значительный дополнительный трафик, то драйвер хост-контроллера USB 2.0 (Usbehci.sys) может неправильно возвращать состояние процесса передачи данных по шине USB, остановленного из-за появления пакетов STALL. Это может приводить к тому, что драйверы USB верхнего уровня неправильно определяют состояние устройства и шины USB и выполняют сброс шины для устранения ошибочного состояния и инициализации устройств USB на шине.

Если при выполнении операций обнаружения дисковода CD-RW или проверки подлинности заголовка диска DVD выполняется сброс шины, то указанные операции могут завершаться с ошибкой, которую программы (например, программа воспроизведения диска DVD или программа записи компакт-диска) не могут исправить. Это приводит к появлению сообщений об ошибках, описанных в разделе «Проблема» этой статьи.

Примечание. К числу устройств USB, создающих дополнительный трафик на шине USB, который может приводить к появлению проблем, описанных в разделе «Проблема» этой статьи, относятся следующие устройства.
  • Адаптеры Bluetooth (включая встроенные адаптеры портативных компьютеров).
  • Устройства Pocket PC, работающие с программой ActiveSync с использованием подключения USB.

Решение

Сведения о пакете обновления для Windows XP

Чтобы решить эту проблему, установите последний пакет обновления для Windows XP. Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
322389 Как получить последний пакет обновления для Windows XP

Сведения об исправлении

Windows Server 2003

Корпорация Майкрософт выпустила исправление, однако оно предназначено исключительно для устранения проблемы, описанной в этой статье. Это исправление необходимо применять только в тех системах, в которых наблюдается данная проблема. Исправление может проходить дополнительное тестирование. По этой причине корпорация Майкрософт рекомендует во всех случаях, когда проблема не представляет особой важности, отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, в верхней части статьи базы знаний отображается раздел «Исправление доступно для загрузки». Если этот раздел не отображается, обратитесь в службу поддержки пользователей Майкрософт, чтобы получить данное исправление.

Примечание. Если возникли другие проблемы или необходимо устранить неполадки, возможно, потребуется создать отдельный запрос. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются на стандартных условиях. Чтобы получить полный список телефонных номеров службы поддержки пользователей корпорации Майкрософт или создать отдельный запрос, посетите веб-узел корпорации Майкрософт по следующему адресу:
http://support.microsoft.com/contactus/?ws=support
Примечание. В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если нужный язык не отображается, это означает, что исправление для данного языка отсутствует.
Сведения о файлах
Английская версия исправления содержит атрибуты файлов, приведенные в следующей таблице, или более поздние. Дата и время указаны в формате UTC. При просмотре сведений о файле в системе происходит перевод соответствующих значений в местное время. Чтобы узнать разницу между временем в формате UTC и местным временем, откройте вкладку Часовой пояс элемента «Дата и время» на панели управления.
   Дата         Время Версия     Размер Имя файла Платформа
   --------------------------------------------------------------
   13-май-2003  00:40  5.2.3790.25  19 968  Usbehci.sys  i386
   13-май-2003  00:40  5.2.3790.25  61 312  Usbehci.sys  ia64

Windows XP

Корпорация Майкрософт выпустила исправление, однако оно предназначено исключительно для устранения проблемы, описанной в этой статье. Это исправление необходимо применять только в тех системах, в которых наблюдается данная проблема. Исправление может проходить дополнительное тестирование. По этой причине корпорация Майкрософт рекомендует во всех случаях, когда проблема не представляет особой важности, отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, вверху статьи базы знаний отображается раздел "Исправление доступно для загрузки". Если этот раздел не отображается, обратитесь в службу поддержки пользователей Майкрософт, чтобы получить данное исправление.

Примечание. Если возникли другие проблемы или необходимо устранить неполадки, возможно, потребуется создать отдельный запрос. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются на стандартных условиях. Чтобы получить полный список телефонных номеров службы поддержки пользователей корпорации Майкрософт или создать отдельный запрос, посетите веб-узел корпорации Майкрософт по следующему адресу:
http://support.microsoft.com/contactus/?ws=support
Примечание. В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если нужный язык не отображается, это означает, что исправление для данного языка отсутствует. Английская версия исправления содержит атрибуты файлов, приведенные в следующей таблице, или более поздние. Дата и время указаны в формате UTC. При просмотре сведений о файле в системе происходит перевод соответствующих значений в местное время. Чтобы узнать разницу между временем в формате UTC и местным временем, откройте вкладку Часовой пояс элемента «Дата и время» на панели управления.
   Дата         Время Версия     Размер Имя файла Платформа
   -----------------------------------------------------------------
   13-май-2003  01:14  5.1.2600.1222   19 456  Usbehci.sys  i386
   12-май-2003  04:22  5.1.2600.1221  137 600  Usbport.sys  i386
   13-май-2003  01:14  5.1.2600.1222   64 768  Usbehci.sys  ia64
   10-май-2003  13:10  5.1.2600.1221  482 816  Usbport.sys  ia64
				

Windows 2000

Корпорация Майкрософт выпустила исправление, однако оно предназначено исключительно для устранения проблемы, описанной в этой статье. Это исправление необходимо применять только в тех системах, в которых наблюдается данная проблема.

Если исправление доступно для загрузки, вверху статьи базы знаний отображается раздел "Исправление доступно для загрузки". Если этот раздел не отображается, отправьте запрос на получение исправления в службу поддержки пользователей Майкрософт через Интернет.

Примечание. Если возникли другие проблемы или необходимо устранить неполадки, возможно, потребуется создать отдельный запрос. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются на стандартных условиях. Чтобы получить полный список телефонных номеров службы поддержки пользователей корпорации Майкрософт или создать отдельный запрос, посетите веб-узел корпорации Майкрософт по следующему адресу:
http://support.microsoft.com/contactus/?ws=support
Примечание. В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если нужный язык не отображается, это означает, что исправление для данного языка отсутствует.

Английская версия исправления содержит атрибуты файлов, приведенные в следующей таблице, или более поздние. Дата и время указаны в формате UTC. При просмотре сведений о файле в системе происходит перевод соответствующих значений в местное время. Чтобы узнать разницу между временем в формате UTC и местным временем, откройте вкладку Часовой пояс элемента «Дата и время» на панели управления.
   Дата         Время Версия      Размер  Имя файла
   --------------------------------------------------------
   15-янв-2003  19:45  5.0.2195.6655   24 752  Hidclass.sys
   08-май-2003  17:22  5.0.2195.6743   24 912  Openhci.sys
   23-апр-2003  17:52  5.0.2195.6739   32 944  Uhcd.sys
   23-апр-2003  17:52  5.0.2195.6739   20 752  Usbd.sys
   13-май-2003  19:47  5.0.2195.6745   19 728  Usbehci.sys
   15-янв-2003  19:46  5.0.2195.6655   49 776  Usbhub20.sys
   28-апр-2003  17:41  5.0.2195.6741  138 768  Usbport.sys
				

Временное решение

В качестве временного решения проблемы перезагрузите компьютер. Однако в ряде случаев перезагрузка не устраняет указанную проблему.

Статус

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в начале данной статьи. Первое исправление этой проблемы появилось в пакете обновления 2 (SP2) для Windows XP.

Дополнительная информация

В данной статье упомянуты программные продукты независимых производителей. Корпорация Майкрософт не дает никаких гарантий и обязательств по корректной работе или надежности этих продуктов.

Свойства

Код статьи: 820759 - Последний отзыв: 11 сентября 2008 г. - Revision: 7.3
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Advanced Server
  • операционная система Microsoft Windows 2000 Server
  • Операционная система Microsoft Windows 2000 Professional
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Ключевые слова: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbdriver kbdisplay kbsound kbwinxppresp2fix kbwin2000presp5fix kbbug kbfix kbqfe kbwinserv2003presp1fix KB820759

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com