Computer intermittently stops responding, and a "Stop error code 0x000000C2 (BAD_POOL_CALLER)" error occurs

Article translations Article translations
Article ID: 820765 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

If you are using a computer that is running Microsoft Windows 2000, the computer may intermittently stop responding (crash) and the following Stop error may occur:
*** STOP 0x000000C2 BAD_POOL_CALLER

CAUSE

This problem may occur when you have NetBIOS transport enabled. In a bug that exists in Netbt.sys, a Unicode string is initialized to a static string and then freed inside the NbtReadSingleParameter function. The BAD_POOL_CALLER (C2) error indicates that the current thread is making a bad pool request. Typically, this request occurs at an incorrect interrupt request (IRQ) level, or it is caused by the freeing of a memory allocation that has already been freed.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This patch requires Windows 2000 Service Pack 2 (SP2), Windows 2000 Service Pack 3 (SP3) or Windows 2000 Service Pack 4 (SP4).

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size     File name 
   -------------------------------------------------------- 
   21-May-2003  18:48  5.0.2195.6747   163,568  Netbt.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages

Properties

Article ID: 820765 - Last Review: January 30, 2012 - Revision: 5.0
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbHotfixServer kbqfe kbbug kbfix kbwin2000presp5fix KB820765

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com