Komputer sporadycznie przestaje odpowiadać i występuje błąd "Stop: kod błędu 0x000000C2 (BAD_POOL_CALLER)"

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 820765 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Jeśli używasz komputera z systemem Microsoft Windows 2000, komputer sporadycznie może przestać odpowiadać (zawiesić) i może wystąpić następujący błąd zatrzymania:
*** STOP 0X000000C2 BAD_POOL_CALLER

Przyczyna

Ten problem może wystąpić, gdy transport NetBIOS włączone. W przypadku błędu, który istnieje w Netbt.sys ciąg Unicode można zainicjować static string i następnie jest zwalniany wewnątrz NbtReadSingleParameter Funkcja. Błąd BAD_POOL_CALLER (C2) wskazuje, że bieżący wątek jest wnioskiem bad puli. Zazwyczaj wniosek ten występuje na żądanie przerwania niepoprawny poziom (przerwania IRQ) lub jest spowodowana przez zwalnianie alokacji pamięci, która już została zwolniona.

Rozwiązanie

Informacje o poprawce

Obsługiwana poprawka jest dostępna w firmie Microsoft. Jednak ta poprawka jest przeznaczona do usunięcia tylko problemu opisanego w tym artykule. Tylko w systemach, w których występuje ten problem, należy zastosować tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, istnieje sekcja "Poprawka dostępna do pobrania" na początku tego artykułu z bazy wiedzy Knowledge Base. Jeśli nie ma w tej sekcji, należy przedłożyć wniosek z działem pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga Wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu, należy utworzyć osobne zlecenie usługi. Koszty obsługi zwykłych zastosuje się do dodatkowych pytań i problemów, które nie kwalifikują się do tej poprawki. Aby uzyskać pełną listę numerów telefonów z działem pomocy technicznej firmy Microsoft lub utworzyć osobne zlecenie usługi odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/?ws=support
Uwaga "Poprawka dostępna do pobrania" zawiera listę języków, dla których poprawka jest dostępna. Jeśli język nie jest widoczny, jest to, ponieważ poprawka nie jest dostępna dla danego języka.

Wymagania wstępne

Ta poprawka wymaga dodatku Service Pack 2 (SP2) dla systemu Windows 2000, Windows 2000 Service Pack 3 (SP3) lub dla systemu Windows 2000 z dodatkiem Service Pack 4 (SP4).

Wymaganie dotyczące ponownego uruchomienia

Po zastosowaniu tej poprawki należy ponownie uruchomić komputer.

Informacje dotyczące zastępowania poprawek

Ta poprawka nie zastępuje dowolny inne poprawki.

Informacje o pliku

Wersja angielskojęzyczna tej poprawki ma atrybuty pliku (lub nowsze) wymienione w poniższej tabeli. Daty i godziny odpowiadające tym plikom są wymienione w skoordynowanego czasu uniwersalnego (UTC). Podczas przeglądania informacji o pliku jest konwertowane na czas lokalny. Do ró?nic? mi?dzy czasem UTC i czasem lokalnym, należy użyć Czas Strefy Karta narzędzia Data i godzina w Panelu sterowania.
   Date         Time   Version         Size     File name 
   -------------------------------------------------------- 
   21-May-2003  18:48  5.0.2195.6747   163,568  Netbt.sys

Stan

Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft, które są wymienione na początku tego artykułu.

Więcej informacji

Aby uzyskać dodatkowe informacje dotyczących nazewnictwa pakietów poprawek kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
816915 Nowy schemat nazewnictwa plików dla pakietów aktualizacji oprogramowania Microsoft Windows

Właściwości

Numer ID artykułu: 820765 - Ostatnia weryfikacja: 30 stycznia 2012 - Weryfikacja: 1.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Słowa kluczowe: 
kbautohotfix kbHotfixServer kbqfe kbbug kbfix kbwin2000presp5fix kbmt KB820765 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to:820765

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com