Numéro d'article: 820865 - Dernière mise à jour: lundi 23 avril 2007 - Version: 4.0

Affichage du message d'erreur « Un programme récemment installé empêche Microsoft Office ou un autre programme ayant une messagerie électronique de fonctionner correctement » au démarrage de Microsoft Outlook

Sommaire

Agrandir tout | Réduire tout

Symptômes

Au démarrage de Microsoft Outlook, le message d'erreur suivant peut s'afficher :
Un programme récemment installé empêche Microsoft Office ou un autre programme ayant une messagerie électronique de fonctionner correctement. Outlook peut résoudre ce problème sans affecter le programme qui est la cause du problème. Souhaitez-vous résoudre le problème ?

Cause

Ce problème se produit en cas de conflit de fichiers avec les fichiers MAPI de base de votre ordinateur. Le fichier en conflit est le fichier Mapi32.dll. Le fichier Mapi32.dll se trouve à l'emplacement suivant sous Microsoft Windows XP, Microsoft Windows Server 2003 et Microsoft Windows 2000 :
C:\Windows\System32

Résolution

Pour résoudre ce problème, cliquez sur Oui ou sur Non dans le message d'erreur mentionné dans la section « Problèmes » de cet article.

Scénario 1

Si vous cliquez sur Oui dans le message d'erreur, l'utilitaire Fixmapi.exe démarre et essaye de réparer le conflit de fichier avec les fichiers MAPI de base en installant la version correcte.

Si un programme en cours d'exécution utilise le fichier Mapi32.dll, l'utilitaire Fixmapi.exe ne peut pas régler le conflit de fichiers. Dans ce cas, le message d'erreur suivant s'affiche :
Outlook n'a pas pu résoudre le conflit entre un programme installé récemment et Microsoft Office ou d'autres programmes ayant une messagerie électronique. Outlook doit modifier un composant système en cours d'utilisation par un autre programme. Pour résoudre le problème, redémarrer Windows.
Si vous cliquez sur OK dans ce message d'erreur, Microsoft Windows ne redémarre pas. Toutefois, une entrée pour l'utilitaire Fixmapi.exe est placée dans la clé de Registre RunOnce. La prochaine fois que vous démarrerez Windows, l'utilitaire Fixmapi.exe essaiera de résoudre le conflit avec le fichier Mapi32.dll.

Scénario 2

Si vous cliquez sur Non dans le message d'erreur mentionné dans la section « Symptômes » de cet article, les fichiers MAPI de base ne sont pas modifiés. Comme Outlook utilise le fichier Mapi32.dll dans le dossier C:\Program Files\Common Files\SYSTEM\MSMapi\1033, le fait de cliquer sur Non n'affecte pas le fonctionnement du programme.

Contournement

Si l'utilitaire Fixmapi.exe ne fonctionne pas, procédez comme suit :
  1. Quittez tous les programmes.
  2. Renommez le fichier Mapi32.dll du dossier C:\Windows\System32 en « Mapi32.old » (sans les guillemets).
  3. Cherchez le fichier Fixmapi.exe dans le dossier C:\Windows\System32 , puis double-cliquez sur Fixmapi.exe pour exécuter le programme.
  4. Redémarrez votre ordinateur.

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.

Plus d'informations

Microsoft Windows Messaging Subsystem (WMS) installe les fichiers MAPI de base dans le dossier C:\Windows\System32. Les versions de Microsoft Outlook antérieures à Microsoft Office Outlook 2003 accèdent aux fichiers MAPI de base à partir de cet emplacement. Dans Outlook 2003 et les versions ultérieures de Microsoft Outlook, les principaux fichiers MAPI de base sont stockés à un emplacement commun.

Les programmes MAPI simples, tels que Microsoft Outlook Express, Qualcomm, Eudora, Netscape et d'autres programmes tiers, installent le fichier Mapi32.dll et y accèdent à partir de l'emplacement suivant :
C:\Windows\System32
Vous pouvez cliquer sur Envoyer vers dans le menu Fichier pour envoyer des documents dans les programmes qui prennent en charge les programmes MAPI simples.

Remarque Ce problème peut affecter le Gestionnaire système Microsoft Exchange, même s'il ne se trouve pas sur le même ordinateur que le serveur Microsoft Exchange. Le Gestionnaire système Exchange ne fonctionne pas si vous choisissez de remplacer les fichiers MAPI de base par les fichiers MAPI Outlook après avoir exécuté l'utilitaire Fixmapi.exe. En outre, si vous choisissez de ne pas remplacer les fichiers MAPI de base par les fichiers MAPI Outlook, Outlook peut ne pas fonctionner normalement. Vous recevrez le message d'erreur mentionné dans la section « Symptômes » de cet article à chaque démarrage de Microsoft Outlook jusqu'à ce que vous remplaciez les fichiers MAPI de base par les fichiers MAPI Outlook.

Nous vous recommandons de ne pas placer Microsoft Outlook 2002, ou une version antérieure de Microsoft Outlook, sur le même ordinateur que le Gestionnaire système Exchange ou le serveur Exchange. Si vous utilisez Outlook 2002 ou une version antérieure de Microsoft Outlook, vous pouvez éviter ce problème en utilisant Microsoft Outlook Web Access ou une session Terminal Server pour accéder aux messages électroniques.

Résolution

Les produits tiers mentionnés dans le présent article proviennent de sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2007 with Business Contact Manager
  • Microsoft Office Outlook 2003
  • Microsoft Office Outlook 2003 with avec Gestionnaire de contacts professionnels
Mots-clés : 
kbprb kbstartprogram kberrmsg kbsetup KB820865
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
 

Traductions disponibles

 

Related Support Centers