Word 2003:n tai Word 2002:n käynnistyksen tai käyttämisen aikana ilmenevien ongelmien vianmääritys

Artikkeleiden käännökset Artikkeleiden käännökset
Artikkelin tunnus: 820919 - Näytä tuotteet, joita tämä artikkeli koskee.
Laajenna kaikki | Kutista kaikki

Tällä sivulla

Yhteenveto

Tässä artikkelissa on lisätietoja Troubleshoot Utility -apuohjelmasta, jonka saa Microsoftin tuotetuesta. Tämän apuohjelman avulla voit tehdä Microsoft Word -ongelmien vianmäärityksen automaattisesti. Apuohjelma poistaa tietyt perusosat, jotka saattavat olla vioittuneet tai jotka saattavat aiheuttaa ristiriidan Microsoft Wordin kanssa.

Tässä artikkelissa kerrotaan, miten seuraavat osat poistetaan käytöstä Troubleshoot Utility -apuohjelman avulla. Nämä osat ladataan yleensä Wordin käynnistyksen yhteydessä:
  • Wordin Data-rekisteriavain
  • Wordin Options-rekisteriavain
  • yleinen Normal.dot-malli
  • apuohjelmat ja mallit
  • COM-apuohjelmat
  • Options-rekisteriavain.
Tämän artikkelin avulla voit selvittää ongelman syyn, kun sitä ei voi tunnistaa muilla tavoilla Microsoft Wordissa. Löydät mahdollisesti kohtaamiasi tiettyjä ongelmia käsitteleviä artikkeleita etsimällä Microsoft Knowledge Base -tietokannasta. Voit tehdä tämän seuraavassa Microsoftin Web-sivustossa:
http://support.microsoft.com/default.aspx?ln=fi

Support Template -mallin asentaminen

Support Template -mallin avulla voit tehdä Wordin käynnistysongelmien vianmäärityksen. Support Template -malli asennetaan, kun suoritat täydellisen asennuksen. Jos asennat Microsoft Wordin päivityksenä tai normaalina asennuksena, Support Template -mallia ei asenneta.

Voit asentaa Support Template -mallin tekemällä seuraavat Word-versiosi mukaiset toimet:

Microsoft Office Word 2003

  1. Napsauta Käynnistä-painiketta ja valitse Ohjauspaneeli.
  2. Valitse Lisää tai poista sovellus.
  3. Valitse Muuta tai poista sovellus.
  4. Valitse Nykyiset asennetut ohjelmat -luettelossa Microsoft Office 2003 (valitse esimerkiksi Microsoft Office Professional Edition 2003) ja valitse sitten Muuta.
  5. Valitse Lisää tai poista ominaisuuksia ja valitse sitten Seuraava.
  6. Valitse Mukautetussa asennuksessaValitse sovellusten lisämukauttaminen -valintaruutu ja valitse sitten Seuraava.
  7. Toimi Valitse sovellusten ja työkalujen päivitysasetukset -luettelossa seuraavasti:
    1. Laajenna Microsoft Office Word.
    2. Laajenna Ohjattuja toimintoja ja malleja.
    3. Napsauta Lisää malleja ja makroja -kuvaketta ja valitse sitten Suorita kaikki paikallisena.
  8. Asenna Support Template -malli valitsemalla Päivitä.

Microsoft Word 2002


Support Template -malli (Support.dot) asennetaan täydellisessä asennuksessa. Sitä ei asenneta normaalissa asennuksessa tai päivitysasennuksessa. Jos Support Template -malli ei ole asennettuna, toimi seuraavasti:
  1. Sulje Microsoft Word ja kaikki muut Microsoft Office -ohjelmat.
  2. Napsauta Käynnistä-painiketta, valitse Asetukset ja valitse sitten Ohjauspaneeli.
  3. Kaksoisnapsauta OhjauspaneelinLisää tai poista sovellus -kuvaketta.
  4. Tee tietokoneen käyttöjärjestelmän mukaiset toimet.
    • Jos käyttöjärjestelmä on Microsoft Windows 98 tai Microsoft Windows Millennium Edition (Me), valitse Asenna tai poista -välilehdessä Microsoft Office XP (Microsoft Word 2002) ja valitse sitten Lisää tai poista.
    • Jos käyttöjärjestelmä on Microsoft Windows 2000 tai Microsoft Windows XP, valitse Muuta tai poista sovellus. Valitse Nykyiset asennetut ohjelmat -luettelossa Microsoft Office XP (Microsoft Word 2002) ja valitse sitten Muuta.
  5. Valitse Microsoft Office XP:n asennusohjelmassa (Microsoft Word 2002:n asennusohjelmassa) Lisää tai poista ominaisuuksia ja valitse sitten Seuraava.
  6. Toimi Asennettavat ominaisuudet -luettelossa seuraavasti:

    Huomautus Laajenna ominaisuus sen vasemmalla puolella olevan plusmerkin (+) avulla.
    1. Laajenna Microsoft Word for Windows.
    2. Laajenna Ohjattuja toimintoja ja malleja.
    3. Napsauta Lisää malleja ja makroja -kuvaketta ja valitse sitten Suorita kaikki paikallisena.
  7. Asenna Support Template -malli valitsemalla Päivitä.
Word 2002:n Support Template -malli on saatavana myös Microsoft Download Centeristä. Ohjeet ladattavan tiedoston lataamiseen ja asentamiseen ovat seuraavassa Microsoftin Web-sivustossa.
http://www.microsoft.com/downloads/details.aspx?FamilyID=efb7219f-aaf5-4858-8abe-0b08aeb69664
Lisätietoja Microsoft-tukitiedostojen lataamisesta saat napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
119591 Microsoft-tukitiedostojen hankkiminen online-palveluista

Pikakuvakkeen luominen Support Template -mallille

Voit luoda Support Template -mallille pikakuvakkeen seuraavasti:
  1. Napsauta mitä tahansa työpöydän kohtaa hiiren kakkospainikkeella, valitse Uusi ja valitse sitten Pikakuvake.
  2. Valitse Selaa.
  3. Napsauta Luo pikakuvake -valintaikkunan Kirjoita kohteen sijainti -ruudussa ja kirjoita seuraava Word-versiosi mukainen oletuspolkulauseke:

    Word 2003"C:\Program Files\Microsoft Office\Office11\Winword.exe" /a "C:\Program Files\Microsoft Office\Office11\Macros\Support.dot"

    Word 2002
    "C:\Program Files\Microsoft Office\Office10\Winword.exe" /a "C:\Program Files\Microsoft Office\Office10\Macros\Support.dot"

    Huomautus Jos olet asentanut Wordin eri sijaintiin, muuta oletustiedostopolku kyseisen sijainnin mukaiseksi.
  4. Jatka valitsemalla Seuraava.
  5. Kirjoita Kirjoita pikakuvakkeen nimi -ruutuun Support Template ja valitse sitten Valmis.
Kun kaksoisnapsautat pikakuvaketta, Word käynnistyy oletustilassa. Support Template -malli avautuu.

Troubleshoot Utility -apuohjelman käyttäminen

Troubleshoot Utility -apuohjelman avulla voit tunnistaa ja poistaa osan, joka aiheuttaa ongelman Wordissa. Poista seuraavat osat Troubleshoot Utility -apuohjelman avulla yksi kerrallaan ja mainitussa järjestyksessä. Kun olet tunnistanut ja poistanut osan, ongelma on korjattu Wordissa, eikä sinun tarvitse tehdä jäljellä olevia vaiheita.

Huomautus Tämän osan vaiheissa on esimerkkejä sanomista. Sanoman sijainti vaihtelee Wordin version mukaan. Seuraavat esimerkit ovat Word 2003:a varten.

Vaihe 1: Wordin Data-rekisteriavaimen poistaminen

Suurin osa usein käytetyistä asetuksista on tallennettu Wordin Data-rekisteriavaimeen. (Voit tarkastella näitä asetuksia valitsemalla Työkalut-valikosta Asetukset.) Yleinen vianmääritystoimi on poistaa Wordin Data-rekisteriavain. Kun käynnistät Wordin seuraavan kerran, Word luo Data-avaimen uudelleen käyttäen oletusasetuksia. Jos ongelma ei ratkea poistamalla Wordin Data-rekisteriavain, siirry vaiheeseen 2.

Huomautus Jos poistat Wordin Data-rekisteriavaimen, Word palauttaa joitakin asetuksia niiden oletusasetuksiin. Tällainen asetus on esimerkiksi Tiedosto-valikon viimeksi käytettyjen tiedostojen luettelo. Lisäksi Word palauttaa useita Asetukset-valintaikkunassa mukautettavia asetuksia.

Voit poistaa Wordin Data-rekisteriavaimen seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
  3. Valitse Support Template -mallissa Troubleshoot Utility.
  4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa Data Registry Key ja valitse sitten Delete.
  5. Valitse OK, kun näyttöön tulee seuraava sanoma:
    HKEY_CURRENT_USER\Software\Microsoft Office\11.0\Word\Data
    Backup file for this registry key is present at:
    C:\DOCUME~1\käyttäjänimi\LOCALS~1\Temp\wddata11.0

    Registry key has been deleted.
  6. Valitse Sulje.
  7. Sulje Word valitsemalla Tiedosto-valikosta Lopeta.
  8. Käynnistä Word normaalisti.

    Huomautus ÄLÄ käytä vaiheessa 8 työpöydälle luomaasi Support Template -pikakuvaketta.
Jos Word käynnistyy ja toimii oikein, ongelma on ratkaistu. Ongelma aiheutui vioittuneesta Wordin Data-rekisteriavaimesta. Jos haluat palauttaa haluamasi Wordin asetukset, saatat joutua muuttamaan joitakin asetuksia. Jos ongelma ei ratkennut, palauta vanha Wordin Data-rekisteriavain. Voit tehdä tämän seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
  3. Valitse Support Template -mallissa Troubleshoot Utility.
  4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa Data Registry Key ja valitse sitten Restore.
  5. Valitse Kyllä, kun näyttöön tulee seuraava sanoma:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data
    This key is present in the registry.
    Overwrite it?
  6. Valitse OK, kun näyttöön tulee seuraava sanoma:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data Registry key

    restoration successful.
  7. Sulje Microsoft Word Troubleshooting Utility -valintaikkuna valitsemalla Sulje ja sulje tämän jälkeen Word.
Palaa vaiheisiin

Vaihe 2: Wordin Options-rekisteriavaimen poistaminen

Options-rekisteriavaimeen on tallennettu Wordin asetukset, jotka määritetään joko valikkovaihtoehtojen tai RegOptions-makron avulla. Asetukset on jaettu oletusasetuksiin ja valinnaisiin asetuksiin. Oletusasetukset määritetään asennuksen aikana. Voit muuttaa oletusasetuksia muokkaamalla asetuksia Wordissa. Valinnaisia asetuksia ei luoda asennuksen aikana. Jos ongelma ei ratkea poistamalla Wordin Options-rekisteriavain, siirry vaiheeseen 3.

Voit poistaa Wordin Options-rekisteriavaimen seuraavasti.
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
  3. Valitse Support Template -mallissa Troubleshoot Utility.
  4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa Options Registry Key ja valitse sitten Delete.
  5. Valitse OK, kun näyttöön tulee seuraava sanoma:
    HKEY_CURRENT_USER\Software\Microsoft Office\11.0\Word\Options

    Backup file for this registry key is present at:

    C:\DOCUME~1\käyttäjänimi\LOCALS~1\Temp\wdoptn11.0

    Registry key has been deleted.
  6. Valitse Sulje.
  7. Sulje Word valitsemalla Tiedosto-valikosta Lopeta.
  8. Käynnistä Word normaalisti.

    Huomautus ÄLÄ käytä vaiheessa 8 työpöydälle luomaasi Support Template -pikakuvaketta.
Jos Word käynnistyy ja toimii oikein, ongelma on ratkaistu. Ongelma aiheutui vioittuneesta Wordin Options-rekisteriavaimesta. Jos haluat palauttaa haluamasi Wordin asetukset, saatat joutua muuttamaan joitakin asetuksia. Jos ongelma ei ratkennut, palauta vanha Wordin Options-rekisteriavain. Voit tehdä tämän seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
  3. Valitse Support Template -mallissa Troubleshoot Utility.
  4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa Options Registry Key ja valitse sitten Restore.
  5. Valitse Kyllä, kun näyttöön tulee seuraava sanoma:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options
    This key is present in the registry.

    Overwrite it?
  6. Valitse OK, kun näyttöön tulee seuraava sanoma:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options Registry key
    restoration successful.
  7. Sulje Microsoft Word Troubleshooting Utility -valintaikkuna valitsemalla Sulje ja sulje tämän jälkeen Word.
Palaa vaiheisiin

Vaihe 3: Yleisen Normal.dot-mallin nimeäminen uudelleen

Voit estää yleiseen malliin (Normal.dot) tallennettujen muotoilujen, automaattisen tekstin ja makrojen vaikutuksen Wordiin ja avattaviin asiakirjoihin nimeämällä yleisen mallin uudelleen. Kun käynnistät Wordin uudelleen normaalisti (ilman Support Template -mallia), Word luo uuden yleisen Normal.dot-mallin. Jos ongelma ei ratkennut, kun nimesit yleisen Normal.dot-mallin uudelleen, siirry vaiheeseen 4.

Huomautus Kun nimeät yleisen Normal.dot-mallin uudelleen, jotkin asetukset palautetaan niiden oletusasetuksiksi. Näitä palautettuja asetuksia ovat esimerkiksi mukautetut tyylit, mukautetut työkalurivit, makrot ja automaattiset tekstit. Tämän vuoksi Microsoft suosittelee, että ET poista yleistä Normal.dot-mallia.

Tietyissä tilanteissa voidaan luoda useita yleisiä Normal.dot-malleja. Tällaisia tilanteita ovat esimerkiksi seuraavat:
  • Samassa tietokoneessa on useita Word-versioita.
  • Samassa tietokoneessa on useita työasema-asennuksia.
Varmista näissä tilanteissa, että nimeät uudelleen yleisen Normal.dot-mallin oikean version.

Voit nimetä yleisen Normal.dot-mallin uudelleen seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
  3. Valitse Support Template -mallissa Troubleshoot Utility.
  4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa Normal.dot Global Template ja valitse sitten Rename.
  5. Valitse OK, kun näyttöön tulee seuraava sanoma:
    polku\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Templates\Normal.dot
    Copied To
    polku\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Templates\11Normal.dot
    HuomautusYleisen Normal.dot-mallisi sijainti saattaa olla erilainen. Kyseisen tiedoston nimi Word 2002:ssa on 10normal.dot.
  6. Valitse Sulje.
  7. Sulje Word valitsemalla Tiedosto-valikosta Lopeta.
  8. Käynnistä Word normaalisti.

    Huomautus ÄLÄ käytä vaiheessa 8 työpöydälle luomaasi Support Template -pikakuvaketta.
Jos Word käynnistyy oikein, ongelma on ratkennut. Tässä tapauksessa ongelma aiheutuu vioittuneesta yleisestä Normal.dot-mallista. Jos haluat palauttaa valitsemasi asetukset, saatat joutua muuttamaan joitakin asetuksia.

Jos uudelleennimeämässäsi yleisessä Normal.dot-mallissa on mukautuksia, kuten tyylejä, makroja tai automaattista tekstiä, joita ei ole helppo luoda uudelleen, saatat pystyä kopioimaan nämä mukautukset 11Normal.dot-tiedostosta (vanhasta yleisestä Normal.dot-mallista) uuteen Normal.dot-tiedostoon arkistoinnin avulla.

Saat lisätietoja makrojen nimeämisestä uudelleen arkistoinnin avulla valitsemalla Ohje-valikosta Microsoft Wordin ohje, kirjoittamalla etsimisruutuunmakrojen nimeäminen uudelleen ja tuomalla aiheen näyttöön valitsemalla sitten Etsi.

Jos ongelma ei ole ratkennut, palauta vanha yleinen Normal.dot-malli (Word 2003:ssa 11Normal.dot ja Word 2002:ssa 10.Normal.dot). Voit tehdä tämän seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
  3. Valitse Support Template -mallissa Troubleshoot Utility.
  4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa Normal.dot Global Template ja valitse sitten Restore.
  5. Valitse OK, kun näyttöön tulee seuraava sanoma:
    polku\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Templates\11Normal.dot

    Copied To

    polku\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Templates\Normal.dot
    Huomautus Yleisen Normal.dot-mallisi sijainti saattaa olla erilainen. Kyseisen tiedoston nimi Word 2002:ssa on 10normal.dot.
  6. Sulje Microsoft Word Troubleshooting Utility -valintaikkuna valitsemalla Sulje ja sulje tämän jälkeen Word.
Palaa vaiheisiin

Vaihe 4: Käynnistyskansion apuohjelmien poistaminen käytöstä

Kun käynnistät Wordin, Word lataa käynnistyskansioissa olevat mallit ja apuohjelmat automaattisesti. Wordin ongelmat saattavat aiheutua apuohjelmiin liittyvistä ongelmista ja ristiriidoista. Voit selvittää, aiheutuuko ongelma jostakin käynnistyskansiossa olevasta kohteesta, poistamalla näihin apuohjelmiin viittaavan rekisteriasetuksen käytöstä väliaikaisesti.

Kun käynnistät Wordin uudelleen normaalisti (käyttämättä Support Template -mallia), Word käynnistyy lataamatta käynnistyskansion apuohjelmia. Jos ongelma ei ole ratkennut, kun poistit käynnistyskansion apuohjelmat käytöstä, siirry vaiheeseen 5.

Voit poistaa käynnistyskansion apuohjelmat tilapäisesti käytöstä seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
  3. Valitse Support Template -mallissa Troubleshoot Utility.
  4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa Word Startup Folder Addins ja valitse sitten Rename.
  5. Valitse OK, kun näyttöön tulee jokin seuraavista sanomista:
    • No files found to rename/restore.

      Huomautus Jos tämä sanoma tulee näyttöön, Wordin käynnistämisen yhteydessä ei ladata mitään apuohjelmia. Sinun ei tarvitse tehdä loppuja toimia. Siirry sen sijaan vaiheeseen 5.
    • polku\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Word\Startup\tiedostonimi
      Copied To
      polku\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Word\Startup\tiedostonimi
      polku\Program Files\Microsoft Office\Office11\Startup\tiedostonimi
      Copied To
      polku\Program Files\Microsoft Office\Office11\Startup\tiedostonimi
      Tässä polku on tietokoneesi polku ja tiedostonimi on tietokoneesi nimi.
  6. Valitse Sulje.
  7. Sulje Word valitsemalla Tiedosto-valikosta Lopeta.
  8. Käynnistä Word normaalisti.

    Huomautus ÄLÄ käytä vaiheessa 8 työpöydälle luomaasi Support Template -pikakuvaketta.
  9. Tee jokin seuraavista:
    Jos et pysty enää toistamaan ongelmaa ja poistit apuohjelmat edellisissä vaiheissa, olet selvittänyt ongelman aiheutuvan jostakin apuohjelmasta. Voit selvittää ongelman aiheuttavan apuohjelman seuraavasti:
    1. Sulje kaikki Office-ohjelmat.
    2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
    3. Valitse Wordin Support Template -mallissa Troubleshoot Utility.
    4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa Word Startup Folder Addins ja valitse sitten Restore.
    5. Valitse OK, kun näyttöön tulee jokin seuraavista sanomista:
      • No files found to rename/restore.

        Huomautus Jos tämä sanoma tulee näyttöön, Wordin käynnistämisen yhteydessä ei ladata mitään apuohjelmia. Sinun ei tarvitse tehdä loppuja toimia. Siirry vaiheeseen 5.
      • polku\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Word\Startup\tiedostonimi

        Copied To

        polku\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Word\Startup\tiedostonimi

        polku\Program Files\Microsoft Office\Office11\Startup\tiedostonimi

        Copied To

        polku\Program Files\Microsoft Office\Office11\Startup\tiedostonimi
        Tässä polku on tietokoneesi polku ja tiedostonimi on tietokoneesi nimi.
    6. Valitse Sulje.
    7. Sulje Word valitsemalla Tiedosto-valikosta Lopeta.
    8. Napsauta Käynnistä-painiketta, valitse Oma tietokone ja avaa sitten jokin vaiheessa e määritetyistä kansioista, kuten:

      polku\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Word\Startup\

      TAI

      polku\Program Files\Microsoft Office\Office11\Startup\
    9. Napsauta jotakin kansiossa olevaa tiedostoa hiiren kakkospainikkeella ja valitse sitten Nimeä uudelleen.
    10. Kirjoita tiedostolle uusi nimi ja paina sitten ENTER-näppäintä.

      Tärkeää Kirjoita tiedoston alkuperäinen nimi muistiin, koska saatat joutua nimeämään tiedoston uudelleen sen alkuperäisellä tiedostonimellä.
    11. Käynnistä Word normaalisti.

      Huomautus ÄLÄ käytä vaiheessa k työpöydälle luomaasi Support Template -pikakuvaketta.

      Jos et pysty enää toistamaan ongelmaa, olet löytänyt ongelman aiheuttavan apuohjelman. Jos sinun on käytettävä kyseisen apuohjelman tarjoamia ominaisuuksia, ota yhteyttä apuohjelman valmistajaan ja kysy, onko apuohjelmalle olemassa päivitystä.

      Jos ongelma ei ole ratkennut, nimeä apuohjelma uudelleen sen alkuperäisellä nimellä ja toista sitten vaiheet h - j kullekin vaiheen e sanomien määrittämien kansioiden tiedostolle.
    Jos ongelma ei ole ratkennut, palauta apuohjelmat. Voit palauttaa apuohjelmat seuraavasti:
    1. Sulje kaikki Office-ohjelmat.
    2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
    3. Valitse Support Template -mallissa Troubleshoot Utility.
    4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa Word Startup Folder Addins ja valitse sitten Restore.
    5. Valitse OK, kun näyttöön tulee seuraava sanoma:

      polku\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Word\Startup\tiedostonimi

      Copied To

      polku\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Word\Startup\tiedostonimi

      polku\Program Files\Microsoft Office\Office11\Startup\tiedostonimi

      Copied To

      polku\Program Files\Microsoft Office\Office11\Startup\tiedostonimi
      Tässä polku on tietokoneesi polku ja tiedostonimi on tietokoneesi nimi.
Palaa vaiheisiin

Vaihe 5: COM-apuohjelmien rekisteriavaimen poistaminen

COM-apuohjelmat voidaan asentaa mihin tahansa sijaintiin. Wordin kanssa vuorovaikutuksessa olevat ohjelmat asentavat COM-apuohjelmia. Poista COM-apuohjelmien rekisteriavain ja käynnistä Word sitten uudelleen normaalisti.

COM-apuohjelmien poistaminen käytöstä

Voit poistaa COM-apuohjelmien rekisteriavaimen seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
  3. Valitse Support Template -mallissa Troubleshoot Utility.
  4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa COM-Addins Registry Key ja valitse sitten Delete.
  5. Kun näyttöön tulee sanoma siitä, että HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins-rekisteriavain on poistettu, valitse OK.
  6. Sulje Microsoft Word Troubleshooting Utility -valintaikkuna valitsemalla Sulje.
  7. Sulje Word valitsemalla Tiedosto-valikosta Lopeta.
  8. Käynnistä Word.
  9. Käytä jompaakumpaa seuraavista tavoista tilanteesi mukaan:
    • Jos ongelma on ratkennut, kun käynnistät Wordin, lue Tämän ongelman aiheuttavan COM-apuohjelman selvittäminen -osa.
    • Jos ongelma ei ole ratkennut, kun käynnistät Wordin, lue COM-apuohjelmien rekisteriavaimen palauttaminen -osa.
Palaa vaiheisiin

Tämän ongelman aiheuttavan COM-apuohjelman selvittäminen

Jos ongelma on ratkennut, olet selvittänyt ongelman aiheutuvan jostakin COM-apuohjelmasta. Voit selvittää ongelman aiheuttavan COM-apuohjelman seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
  3. Valitse Support Template -mallissa Troubleshoot Utility.
  4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa COM-Addins Registry Key ja valitse sitten Restore.
  5. Kun näyttöön tulee sanoma siitä, että HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins-rekisteriavain on palautettu onnistuneesti, valitse OK.
  6. Sulje Microsoft Word Troubleshooting Utility -valintaikkuna valitsemalla Sulje.
  7. Sulje Word valitsemalla Tiedosto-valikosta Lopeta.
  8. Käynnistä Word ja valitse sitten Työkalut-valikosta Mukauta.
  9. Valitse Mukauttaminen-valintaikkunassa Komennot.
  10. Valitse Luokat-luettelosta Työkalut.
  11. Valitse Komennot-luettelosta COM-apuohjelmat ja vedä komento sitten johonkin työkaluriviin. Sulje Mukauttaminen-valintaikkuna.
  12. Voit avata COM-apuohjelmat-valintaikkunan napsauttamalla työkaluriviin juuri lisäämääsi COM-apuohjelmat-painiketta.
    Huomautus Jos COM-apuohjelmat-valintaikkunassa näkyy vain yksi apuohjelma, poista sen valintaruudun valinta. Jos luettelossa on useita apuohjelmia, poista vain yhden apuohjelman valintaruudun valinta kerrallaan, jotta voit selvittää ongelman aiheuttavan apuohjelman.
  13. Sulje COM-apuohjelmat-valintaikkuna valitsemalla OK.
  14. Sulje Word valitsemalla Tiedosto-valikosta Lopeta.
  15. Käynnistä Word.
  16. Käytä jotakin seuraavista tavoista tilanteesi mukaan:
    • Jos ongelma on ratkennut, kun käynnistät Wordin, olet selvittänyt ongelman aiheuttavan COM-apuohjelman. Jos tarvitset apuohjelman tarjoamia ominaisuuksia, sinun on selvitettävä ominaisuuden sisältävä Word-apuohjelma, jotta voit kysyä päivitystä apuohjelman valmistajalta.
    • Jos ongelma ei ole ratkennut, kun käynnistät Wordin, napsauta työkaluriviin lisäämääsi COM-apuohjelmat-painiketta. Valitse se apuohjelman valintaruutu, jonka valinnan poistit vaiheessa 12. Poista eri apuohjelman valintaruudun valinta ja toista sitten vaiheet 13 - 15. Toista nämä toimet kullekin apuohjelmalle, kunnes olet selvittänyt ongelman aiheuttavan apuohjelman.

COM-apuohjelmien rekisteriavaimen palauttaminen

Jos ongelma ei ole ratkennut, kun käynnistät Wordin, palauta COM-apuohjelmien rekisteriavain. Voit tehdä tämän seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Support Template -pikakuvaketta.
  3. Valitse Support Template -mallissa Troubleshoot Utility.
  4. Valitse Microsoft Word Troubleshooting Utility -valintaikkunan Select an Item -luettelossa COM-Addins Registry Key ja valitse sitten Restore.
  5. Kun näyttöön tulee sanoma siitä, että HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins-rekisteriavain on palautettu onnistuneesti, valitse OK.
  6. Sulje Microsoft Word Troubleshooting Utility -valintaikkuna valitsemalla Sulje.
  7. Sulje Word valitsemalla Tiedosto-valikosta Lopeta.

Ominaisuudet

Artikkelin tunnus: 820919 - Viimeisin tarkistus: 29. lokakuuta 2007 - Versio: 6.2
Artikkelin tiedot koskevat seuraavia tuotteita:
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
Hakusanat: 
kbhowtomaster kbproductlink KB820919

Anna palautetta

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com