文章编号: 820919 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

概要

本文包含有关疑难解答信息由 Microsoft 产品支持服务提供的实用程序。此实用程序可以帮助您自动解决 Microsoft Word 中的问题。"实用程序中删除特定的关键组件,可能已经损坏,或者可能会造成Microsoft word 会发生冲突。

本文介绍如何使用疑难解答实用工具关闭下列组件。通常在 Word 启动期间加载这些组件:
  • Word Data 注册表项
  • Word 选项注册表项
  • Normal.dot 共用模板
  • 加载项和模板
  • COM 外接程序
  • 选项注册表项
这篇文章可以帮助您确定问题的原因时,您不能通过在 Microsoft Word 中的其他方法解决问题。若要查找有关您可能遇到的特定问题的文章,请查询 Microsoft 知识库。若要执行此操作,请访问下面的 Microsoft 网站:
http://support.microsoft.com/default.aspx

安装支持模板

使用支持模板,可以排除单词启动问题。执行完整的安装程序时,安装支持模板。如果您作为升级或典型安装,安装 Microsoft Word未安装支持模板。

若要安装支持模板,请按照下列步骤为您的 Word 版本:

Microsoft Office Word 2003

  1. 单击 开始然后单击控制面板.
  2. 单击 添加或删除程序.
  3. 单击 更改或删除程序.
  4. 在中 当前安装的程序 列表中,单击您的 Microsoft Office 2003年版本 (例如,单击Microsoft Office 专业版 2003),然后单击更改.
  5. 单击 添加或删除功能然后单击 下一步.
  6. 在中 自定义安装程序单击以选中选择应用程序的高级自定义 复选框,并然后单击 下一步.
  7. 在中 选择应用程序的更新选项和工具 列表中,请执行以下步骤:
    1. 展开 Microsoft OfficeWord.
    2. 展开 向导和模板.
    3. 单击的图标 其他模板和宏然后单击以选中 一切都是通过运行我计算机.
  8. 单击 更新 若要安装支持模板。

Microsoft Word 2002


支持模板 (Support.dot) 安装进行完整安装。未安装的典型安装或升级现在安装。如果未安装支持模板,请按照下列步骤:
  1. Microsoft Word 和所有其他 Microsoft Office 程序退出。
  2. 单击 开始指向 设置然后单击 控制面板 .
  3. 在中 控制面板双击 添加/删除程序.
  4. 为您的计算机的操作系统的步骤。
    • 在 Microsoft Windows 98 中,或在 Microsoft Windows 适当版 (Me) 单击安装/卸载选项卡上选择 Microsoft Office XP (Microsoft Word 2002 中),然后单击 添加/删除.
    • 在 Microsoft Windows 2000 或 Windows XP 中,单击以选中 更改或删除程序.在当前安装的程序列表中,单击 Microsoft Office XP (Microsoft Word 2002),然后单击 更改.
  5. 在 Microsoft Office XP 安装程序 (Microsoft Word 2002 安装),单击以选中 添加或删除功能然后单击 下一步.
  6. 在要安装列表的功能,请按照下列步骤。:

    注意向左功能的展开 (+)。
    1. 对于 Windows 展开 Microsoft Word。
    2. 展开 向导和模板.
    3. 单击的图标 其他模板和宏然后单击以选中 所有从我的计算机上运行.
  7. 单击 更新 若要安装支持模板。

创建支持模板的快捷方式

若要创建支持模板的快捷方式,请按照下列步骤操作:
  1. 用鼠标右键单击桌面上的任意位置指向然后单击 快捷方式.
  2. 单击 浏览.
  3. 在中 创建快捷方式 对话框中,单击中的任何位置 键入项目的位置 框,然后再键入您的 Word 版本的以下默认路径语句:

    Word 2003"C:\Program 能 Office\Office11\Winword.exe"/a"C:\Program 能 Office\Office11\Macros\Support.dot"

    Word 2002
    "C:\Program 能 Office\Office10\Winword.exe"/a"C:\Program 能 Office\Office10\Macros\Support.dot"

    注意如果将 Word 安装在不同位置,相应地更改默认文件路径。
  4. 单击 下一步 若要继续。
  5. 在中 为此快捷方式键入一个名称 框中,类型 支持模板然后单击完成.
当您双击该快捷方式时,Word 将启动默认情况下。支持模板打开。

使用疑难解答实用工具

疑难解答实用工具可帮助您隔离和删除在 Word 中导致问题的组件。使用疑难解答实用工具为删除每个下列组件,一次,然后按列出的顺序。之后您识别并删除该组件,如果中的问题解决Word 中,您不必执行其余步骤。

注意在此部分中的步骤,列出了消息的示例。在消息中的位置将会根据您的 Word 版本不同。下面的代码示例适用于 Word 2003。

步骤 1: 删除 Word Data 注册表项

大多数常用选项存储在 Word 数据注册表项。(若要查看这些选项,请单击 选项 在上 工具 菜单)。一个常见的故障排除步骤是删除 Word Data 注册表项。下次启动 Word 时,Word 重建此数据密钥使用默认设置。如果通过删除 Word Data 注册表项,没有解决问题请转到步骤 2。

注意如果您删除 Word Data 注册表项时,Word 会重新设置多个选项返回到其默认设置,例如,最近使用的文件列表上 文件 菜单。此外,Word 会重新设置您用自定义的许多设置 选项 对话框。

若要删除 Word Data 注册表项,请按照下列步骤操作:
  1. 退出所有 Office 程序。
  2. 双击 支持模板 桌面上的快捷方式。
  3. 在中 支持模板单击 诊断实用程序.
  4. 在 Microsoft Word 疑难解答工具的对话框中,单击 数据的注册表项 在中 选择的项列表然后单击 删除.
  5. 单击 确定 当您收到以下消息:
    HKEY_CURRENT_USER\Software\Microsoft Office\11.0\Word\Data
    备份此注册表项的文件位于:
    C:\DOCUME~1\username\LOCALS~1\Temp\wddata11.0

    注册表项已被删除。
  6. 单击 关闭.
  7. 在文件菜单上单击 退出 若要退出 Word。
  8. 以通常的方式启动 Word。

    注意不要使用第 8 步中您的桌面上的支持模板快捷方式。
如果 Word 启动该程序运行正常,问题已经解决。问题是已损坏的 Word 数据注册表项。您可能需要更改几项设置来还原 Word 中的首选项。如果问题未解决,还原您的旧词数据注册表项。若要执行此操作,请执行以下步骤:
  1. 退出所有 Office 程序。
  2. 双击 支持模板 桌面上的快捷方式。
  3. 在中 支持模板单击 诊断实用程序.
  4. 在中 Microsoft Word 故障诊断实用程序 对话框中,单击 数据的注册表项 在中 选择一个项目 列表,然后再单击 还原.
  5. 单击 当您收到以下消息:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data
    此项在注册表中存在。
    是否覆盖它?
  6. 单击 确定 当您收到以下消息:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data 注册表项

    还原操作成功。
  7. 单击 关闭 若要关闭 Microsoft Word 疑难解答工具对话框并退出 Word。
回步骤

步骤 2: 删除 Word 选项注册表项

该选项注册表项存储,您可以通过更改菜单选项,或者通过运行 RegOptions 宏从 Word 中设置这些选项。设置分为默认设置或可选设置。默认设置是在安装过程中建立的。您可以通过修改 Word 中的选项来更改默认设置。可选的设置不会在安装过程中创建。如果通过删除 Word 选项注册表项未解决此问题,请转到步骤 3。

若要删除 Word 选项注册表项,请按照下列步骤。
  1. 退出所有 Office 程序。
  2. 双击 支持模板 桌面上的快捷方式。
  3. 在中 支持模板单击 诊断实用程序.
  4. 在中 Microsoft Word 故障诊断实用程序 对话框中,单击 选项注册表项 在中 选择一个项目 列表,然后再单击 删除.
  5. 单击 确定 当您收到以下消息:
    HKEY_CURRENT_USER\Software\Microsoft Office\11.0\Word\Options

    备份此注册表项的文件位于:

    C:\DOCUME~1\username\LOCALS~1\Temp\wdoptn11.0

    注册表项已被删除。
  6. 单击 关闭.
  7. 在上 文件 菜单上,单击 退出 若要退出 Word。
  8. 以通常的方式启动 Word。

    注意不要使用第 8 步中您的桌面上的支持模板快捷方式。
如果 Word 启动该程序运行正常,问题已经解决。问题是已损坏的 Word 选项注册表项。您可能需要更改几项设置来还原 Word 中的首选项。如果问题未解决,恢复对旧的 Word 选项注册表项。若要执行此操作,请执行以下步骤:
  1. 退出所有 Office 程序。
  2. 双击桌面上的支持模板快捷方式。
  3. 在中 支持模板单击 诊断实用程序.
  4. 在中 Microsoft Word 故障诊断实用程序 对话框中,单击 选项注册表项 在中 选择一个项目 列表,然后再单击 还原.
  5. 单击 当您收到以下消息:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options
    此项在注册表中存在。

    是否覆盖它?
  6. 单击 确定 当您收到以下消息:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options 注册表项
    还原操作成功。
  7. 单击 关闭 若要关闭 Microsoft Word 疑难解答工具对话框并退出 Word。
回步骤

步骤 3: 重命名 Normal.dot 共用模板

若要防止格式、 自动图文集和宏是存储在共用模板 (Normal.dot) 影响 Word 及的行为文档打开时,重命名全局模板。重新启动 Word 以典型方式 (不使用支持模板),Word 会创建一个新 Normal.dot 共用模板。如果重命名 Normal.dot 共用模板后, 未解决问题请转到步骤 4。

注意如果您重命名 Normal.dot 共用模板,将几个选项重置为它们的默认设置。要重置的选项包括自定义样式、 自定义工具栏、 宏和自动图文集词条。因此,Microsoft 强烈建议您删除Normal.dot 共用模板。

某些类型的情况可能会造成几个 Normal.dot 共用模板。这些情况包括:
  • 在相同上运行 Word 的多个版本计算机。
  • 装有多个工作站上相同计算机。
在这些情况下,请确保您重命名的正确副本Normal.dot 共用模板。

要重命名 Normal.dot 共用模板,请执行以下步骤:
  1. 退出所有 Office 程序。
  2. 双击 支持模板 桌面上的快捷方式。
  3. 在中 支持模板单击 诊断实用程序.
  4. 在中 Microsoft Word 故障诊断实用程序 对话框中,单击 共用模板 Normal.dot 在中 选择一个项目 列表,然后再单击 重命名.
  5. 单击 确定 当您收到以下消息:
    路径 \Documents 和 Settings\ 用户名 \Application Data\Microsoft\Templates\Normal.dot
    复制到
    路径 \Documents 和 Settings\ 用户名 \Application Data\Microsoft\Templates\11Normal.dot
    注意Normal.dot 共用模板的路径可能不同。在 Word 2002 中的文件的名称为 10normal.dot。
  6. 单击 关闭.
  7. 在上 文件 菜单,然后单击 退出 若要退出 Word。
  8. 以通常的方式启动 Word。

    注意不要使用第 8 步中您的桌面上的支持模板快捷方式。
如果 Word 正确启动,您已经解决了问题。在这种情况下,问题在于损坏的 Normal.dot 共用模板。您可能需要更改几项设置来恢复您的首选项。

如果您重命名 Normal.dot 全局模板包含自定义设置,如样式、 宏或自动图文集词条,无法轻松地重新创建,您可能能够将这些自定义设置从 11Normal.dot 文件 (旧 Normal.dot 共用模板) 复制到新 Normal.dot 共用模板,通过使用管理器。

有关如何使用管理器来重命名宏的详细信息,请单击 Microsoft Word 帮助帮助菜单类型上 重命名宏 在中 搜索 框中,然后单击 搜索 若要查看的主题。

如果问题未解决,恢复旧共用 Normal.dot 模板 (对于 Word 2003,Word 2002 10.Normal.dot 11Normal.dot)。若要执行此操作,请执行以下步骤:
  1. 退出所有 Office 程序。
  2. 双击 支持模板 桌面上的快捷方式。
  3. 在中 支持模板单击 诊断实用程序.
  4. 在中 Microsoft Word 故障诊断实用程序 对话框中,单击 共用模板 Normal.dot 在中 选择一个项目 列表,然后再单击 还原.
  5. 单击 确定 当您收到以下消息:
    路径 \Documents 和 Settings\ 用户名 \Application Data\Microsoft\Templates\11Normal.dot

    复制到

    路径 \Documents 和 Settings\ 用户名 \Application Data\Microsoft\Templates\Normal.dot
    注意Normal.dot 共用模板的路径可能不同。在 Word 2002 中的文件的名称为 10normal.dot。
  6. 单击 关闭 若要关闭 Microsoft Word 疑难解答工具对话框并退出 Word。
回步骤

步骤 4: 关闭启动文件夹加载项

当您启动 Word 时,Word 将自动加载模板和的外接程序,它们位于启动文件夹中。在 Word 中的问题可能是冲突或问题造成的与外接程序。若要确定是否在某项启动文件夹导致此问题,请暂时关闭指向这些加载项的注册表设置。

在启动 Word 时再次以典型方式 (不使用支持模板),Word 会以不外接程序中启动文件夹。如果该问题得不到解决关闭启动文件夹加载项后,请转到步骤 5。

若要暂时关闭启动文件夹加载宏,请按照下列步骤操作:
  1. 退出所有 Office 程序。
  2. 双击 支持模板 桌面上的快捷方式。
  3. 在中 支持模板单击 诊断实用程序.
  4. 在中 Microsoft Word 故障诊断实用程序 对话框中,单击 Word 启动文件夹加载项 在中 选择一个项目 列表,然后再单击 重命名.
  5. 单击 确定 当您收到以下消息之一:
    • 没有找到文件来重命名/还原。

      注意如果您收到此消息,请在启动 Word 时不加载任何加载。您不必执行其余步骤。相反,请转到步骤 5。
    • 路径 \Documents 和 Settings\ 用户名 \Application Data\Microsoft\Word\Startup\ 文件名称
      复制到
      路径 \Documents 和 Settings\ 用户名 \Application Data\Microsoft\Word\Startup\ 文件名称
      路径 \Program Files\Microsoft Office\Office11\Startup\ 文件名称
      复制到
      路径 \Program Files\Microsoft Office\Office11\Startup\ 文件名称
      位置路径是在您的计算机和文件的名称的路径是在您的计算机上的文件名称。
  6. 单击 关闭.
  7. 在上 文件 菜单上,单击 退出 若要退出 Word。
  8. 以通常的方式启动 Word。

    注意不要使用第 8 步中您的桌面上的支持模板快捷方式。
  9. 使用以下过程之一:
    如果您不能重现该问题,并且如果您在前面的步骤中删除加载宏,您可以确定问题是由外接程序引起。若要确定问题由哪个加载项引起,请按照下列步骤操作:
    1. 退出所有 Office 程序。
    2. 双击 支持模板 桌面上的快捷方式。
    3. 在中 Word 支持模板单击 诊断实用程序.
    4. 在中 Microsoft Word 故障诊断实用程序 对话框中, 选择一个项目 列表中单击 Word 启动文件夹加载项然后单击 还原.
    5. 单击 确定 当您收到以下消息之一:
      • 没有找到文件来重命名/还原。

        注意如果您收到此消息,请在启动 Word 时不加载任何加载。您不必执行其余步骤。请转到步骤 5。
      • 路径 \Documents 和 Settings\ 用户名 \Application Data\Microsoft\Word\Startup\ 文件名称

        复制到

        路径 \Documents 和 Settings\ 用户名 \Application Data\Microsoft\Word\Startup\ 文件名称

        路径 \Program Files\Microsoft Office\Office11\Startup\ 文件名称

        复制到

        路径 \Program Files\Microsoft Office\Office11\Startup\ 文件名称
        位置路径是在您的计算机和文件的名称的路径是在您的计算机上的文件名称。
    6. 单击 关闭.
    7. 在上 文件 菜单上,单击 退出 若要退出 Word。
    8. 单击 开始单击 我的计算机然后打开在步骤e,如指定的文件夹之一:

      路径 \Documents 和 Settings\ 用户名 \Application Data\Microsoft\Word\Startup\

      -或者-

      路径 \Program Files\Microsoft Office\Office11\Startup\
    9. 用鼠标右键单击包含在文件夹中的文件之一,然后单击 重命名.
    10. 键入该文件的新名称,然后按 输入.

      重要记的原始文件的名称,因为您可能需要返回到其原始名称重命名该文件。
    11. 按照通常的方式启动 Word。

      注意不要使用在步骤k中您的桌面上的支持模板快捷方式。

      如果您不能重现该问题,您已经找到引起该问题的特定添加项。如果必须拥有该加载项提供的功能,将外接程序的供应商联系更新。

      如果问题未解决,在重命名为原来的名称,然后在步骤e中所示的消息中指定的文件夹中每个文件重复步骤hj
    如果问题未解决,还原您的外接程序。若要还原您的外接程序,请按照下列步骤操作:
    1. 退出所有 Office 程序。
    2. 双击 支持模板 桌面上的快捷方式。
    3. 在中 支持模板单击 诊断实用程序.
    4. 在中 Microsoft Word 故障诊断实用程序 对话框中, 选择一个项目 列表中单击 Word 启动文件夹加载项然后单击 还原.
    5. 单击 确定 当您收到以下消息:

      路径 \Documents 和 Settings\ 用户名 \Application Data\Microsoft\Word\Startup\ 文件名称

      复制到

      路径 \Documents 和 Settings\ 用户名 \Application Data\Microsoft\Word\Startup\ 文件名称

      路径 \Program Files\Microsoft Office\Office11\Startup\ 文件名称

      复制到

      路径 \Program Files\Microsoft Office\Office11\Startup\ 文件名称
      位置路径是在您的计算机和文件的名称的路径是在您的计算机上的文件名称。
回步骤

步骤 5: 删除 COM 外接程序的注册表项

COM 加载项可以安装在任何位置。Word 设置 COM 添加宏与交互的程序中删除 COM 外接程序的注册表项,并然后重新启动 Word 以典型方式。

请关闭 COM 加载项程序

若要删除 COM 外接程序的注册表项,请按照下列步骤操作:
  1. 退出所有 Office 程序。
  2. 双击 支持模板 桌面上的快捷方式。
  3. 在中 支持模板单击 诊断实用程序.
  4. 在中 Microsoft Word 故障诊断实用程序 对话框中,单击 COM 外接程序的注册表项 在中 选择一个项目 列表,然后再单击 删除.
  5. 当您收到一条消息,将 HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins 注册表项已被删除时,请单击 确定.
  6. 单击 关闭 若要关闭 Microsoft Word 疑难解答工具对话框。
  7. 在上 文件 菜单上,单击 退出 若要退出 Word。
  8. 开始 Word。
  9. 完成下列过程中,根据适用于您的情况之一:
    • 如果在启动 Word 时解决了问题,请参阅"确定 COM 外接程序导致此问题"一节。
    • 如果在启动 Word 时问题未解决,请参阅"恢复您 COM 加载项注册表项"一节。
回步骤

确定导致此问题的 COM 外接程序

如果问题得到解决,您可以确定 COM 外接程序导致该问题。要确定引起问题的 COM 外接程序,请执行以下步骤:
  1. 退出所有 Office 程序。
  2. 双击 支持模板 桌面上的快捷方式。
  3. 在中 支持模板单击 诊断实用程序.
  4. 在中 Microsoft Word 故障诊断实用程序 对话框中,单击 COM 外接程序的注册表项 在中 选择一个项目 列表,然后再单击 还原.
  5. 当您收到消息 HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins 注册表项已成功还原时,请单击 确定.
  6. 单击 关闭 若要关闭 Microsoft Word 疑难解答工具对话框。
  7. 在上 文件 菜单上,单击 退出 若要退出 Word。
  8. 开始 Word,然后单击 自定义 在上 工具 菜单。
  9. 在自定义对话框中,单击 命令.
  10. 在中 类别 列表中单击 工具.
  11. 在中 命令 列表中单击 COM 外接程序然后将命令拖至其中一个工具栏。关闭自定义对话框。
  12. 若要打开 COM 加载宏对话框,请单击 COM 外接程序 您只需添加到工具栏上的按钮。
    注意如果外接程序中列出 COM 外接程序 对话框中,单击以清除加载项复选框。如果列出多个外接程序,则单击以清除一次以确定引起问题的外接程序只能有一个加载项的复选框。
  13. 单击 确定 若要关闭 COM 加载宏对话框。
  14. 在上 文件 菜单上,单击 退出 若要退出 Word。
  15. 开始 Word。
  16. 使用适合于您的具体情况如下面的方法之一:
    • 如果在启动 Word 时解决了问题,您确定引起该问题的 COM 外接程序。如果您需要该外接程序提供的功能,您必须确定哪个 Word 加载项程序包含该特定功能,以便您可以与供应商联系以进行更新。
    • 如果在启动 Word 时问题未解决,请单击 COM 加载宏按钮添加到工具栏中的。单击以选中加载项复选框已清除,在步骤12中所述。单击以清除其他外接程序的复选框,然后重复步骤1315。重复此过程多次,根据需要,每个外接程序,直到您确定引起该问题的外接程序。

还原您的 COM 加载项注册表项

如果重新启动 Word 时问题未解决,请还原您的 COM 加载项注册表项。若要执行此操作,请执行以下步骤:
  1. 退出所有 Office 程序。
  2. 双击 支持模板 桌面上的快捷方式。
  3. 在中 支持模板单击 诊断实用程序.
  4. 在中 Microsoft Word 故障诊断实用程序 对话框中,单击 COM 外接程序的注册表项 在中 选择一个项目 列表,然后再单击 还原.
  5. 当您收到一条消息,单击"HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins"已成功还原注册表项 确定.
  6. 单击 关闭 若要关闭 Microsoft Word 疑难解答工具对话框。
  7. 在上 文件 菜单上,单击 退出 若要退出 Word。

属性

文章编号: 820919 - 最后修改: 2012年12月14日 - 修订: 1.0
这篇文章中的信息适用于:
  • Microsoft Word 2002 标准版
  • Microsoft Office Word 2003
关键字:?
kbproductlink kbhowtomaster kbmt KB820919 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 820919
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com