FIX: "Applicazione server non disponibile" messaggio di errore se una DLL viene caricata nel 0x33A20000 spazio degli indirizzi ed Ŕ richiesta una pagina ASP.NET

Traduzione articoli Traduzione articoli
Identificativo articolo: 821157 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

In un computer multiprocessore che dispone di una DLL caricata nel 0x33A20000 indirizzo spazio, se si effettua una qualsiasi richiesta nel browser Web che gestisce Microsoft ASP.NET, esegue lo Ŕ visualizzato il seguente messaggio di errore da ASP.NET nella finestra del browser:
Applicazione server non disponibile
Inoltre, Ŕ possibile che venga visualizzato messaggio di errore "Errore HTTP 500" nel browser o nel registro eventi di Microsoft Internet Information Services (IIS).

Cause

Questo comportamento si verifica se si utilizza l'opzione /base , quando si compila una DLL in Microsoft Visual Studio .NET e se si Ŕ impostata su 0x33A20000 la posizione di indirizzo. La DLL viene caricata in un processo prima di ASP.NET viene richiamato prima il file DLL associati vengono caricati i file e altri file.

PoichÚ il 0x33A20000 lo spazio di indirizzo quasi si Ŕ all'interno di spazio di indirizzi virtuali 2 gigabyte (GB), common language runtime Ŕ Impossibile trovare un spazio 1 GB contiguo parziale da utilizzare per gli heap di garbage collection.

Per modificare questo comportamento viene inoltre visualizzato l'ordine che le DLL vengono caricate. Se la DLL di spazio di indirizzi che utilizza il 0x33A20000 viene caricata in un processo dopo che Ŕ stato richiamato ASP.NET, ASP.NET si continuerÓ a funzionare correttamente. ╚ possibile rebase la DLL, questo non Ŕ una soluzione affidabile per questo comportamento.

Questo problema pu˛ verificarsi se si utilizza ASP.NET in combinazione con altri prodotti Microsoft attualmente disponibili. Ad esempio, se si utilizza siti di Microsoft Content Management Server 2002 (MCMS) in stesso pool di applicazioni ASP.NET, ma si visitano i siti MCMS prima, si verificherÓ sempre il comportamento descritto nella sezione "Sintomi".

Risoluzione

Per risolvere questo problema, Ŕ necessario installare questo aggiornamento rapido (hotfix) sul server Web.

Informazioni sull'hotfix

Questo aggiornamento rapido (hotfix) Ŕ solo per la versione di Microsoft .NET Framework 1.1.

importante Questo aggiornamento rapido (hotfix) contiene due tipi di pacchetti:
  • Un pacchetto di Microsoft Windows Installer
  • Un pacchetto di Gestione componenti facoltativi (OCM)
Se si utilizza Microsoft Windows Server 2003, Ŕ necessario specificare che Ŕ necessario installare l'aggiornamento di Windows Server 2003 (OCM). Se si utilizza un sistema operativo che Ŕ diverso da Windows Server 2003, Ŕ necessario utilizzare il pacchetto di Windows Installer. Per Windows Server 2003, protezione File Windows controlla i file di .NET Framework 1.1.

Un hotfix supportato Ŕ disponibile da Microsoft, tuttavia Ŕ destinato esclusivamente per risolvere il problema descritto in questo articolo. Utilizzarla solo nei sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Pertanto, se non si Ŕ notevolmente interessati da questo problema, si consiglia di attendere il rilascio del prossimo service pack di .NET Framework 1.1 che contiene questo aggiornamento rapido (hotfix).

Per risolvere immediatamente questo problema, contattare il servizio supporto tecnico clienti Microsoft per ottenere l'hotfix. Per un elenco completo di numeri di telefono del servizio supporto tecnico clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota in casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Supporto Tecnico Microsoft dovesse determinare che uno specifico aggiornamento risolverÓ il problema. I normali costi del Servizio Supporto Tecnico Clienti verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

Informazioni sul file di hotfix

La versione inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o successivi) elencati nella tabella riportata di seguito. Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
   Date         Time   Version       Size       File name
   --------------------------------------------------------------
   23-Jun-2003  23:17  1.1.4322.915     77,824  Corperfmonext.dll
   24-Jun-2003  14:13  1.1.4322.915  2,088,960  Mscorlib.dll
   23-Jun-2003  23:07                   10,728  Mscorlib.ldo
   23-Jun-2003  23:15  1.1.4322.915  2,494,464  Mscorsvr.dll
   23-Jun-2003  23:16  1.1.4322.915  2,486,272  Mscorwks.dll

Informazioni sull'installazione di hotfix

In un server a 32 processori, Ŕ necessario installare questo aggiornamento rapido (hotfix) prima di installare Microsoft SharePoint Portal Server 2003.

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

ProprietÓ

Identificativo articolo: 821157 - Ultima modifica: giovedý 22 febbraio 2007 - Revisione: 3.3
Le informazioni in questo articolo si applicano a:
  • Microsoft ASP.NET 1.1
  • Microsoft Visual Studio .NET 2003 Enterprise Architect
  • Microsoft Visual Studio .NET 2003 Enterprise Developer
  • Microsoft Visual Studio .NET 2003 Academic Edition
Chiavi:á
kbmt kbqfe kbhotfixserver kbnetframe110sp1fix kbfix kbbug kbnetframe110presp1fix kbvsnet2003presp1fix KB821157 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 821157
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com