Help and Support

You are prompted to convert your Access 97 database repeatedly when you open the file in Access 2002

Article ID:821185
Last Review:April 7, 2006
Revision:2.2
On This Page

SYMPTOMS

When you open a Microsoft Access 97 database file in Microsoft Access 2002, you receive the following message repeatedly even if you have selected Open Database:
You have selected a database created in a previous version of Microsoft Access. You can convert or open the database. Either action may take several minutes.

Back to the top

CAUSE

This problem occurs if all the following conditions are true:
You click Open Database to open the file in Access 2002, but still retain the original Access 97 file format so the file can still be used in Microsoft Access 97.
Your Access 97 database file contains a macro.
You open the Access 97 database file in Access 97 and make a change to the macro.
You reopen the Access 97 database file in Access 2002.

Back to the top

RESOLUTION

Service pack information

This problem is corrected in Office XP Service Pack 3. To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 (http://support.microsoft.com/kb/307841/) How to obtain the latest Office XP service pack
Note For information about updating Access 2002 Runtime applications, click the article number below to view the article in the Microsoft Knowledge Base:
839022 (http://support.microsoft.com/kb/839022/) How to obtain the latest Office XP service pack for Access 2002 Runtime

Back to the top

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Office XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The global version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size        File name     
   ----------------------------------------------
   09-May-2003  21:23   3,990,144  Msaccessop.msp  (Client Update)
   09-May-2003  22:02  11,440,660  Msaccessff.msp  (Full File Update)
				
After the hotfix is installed, the following files will have the listed attributes or later:
   Date         Time   Version      Size       File name     
   --------------------------------------------------------
   08-May-2003  21:08  10.0.5306.0  5,773,896  Msaccess.exe
				
This fix is a post-Office XP Service Pack 2 (SP-2) fix. To install the fix, you must have Office XP SP-2 installed. For additional information about Office XP SP-2, click the following article number to see the article in the Microsoft Knowledge Base:
325671 (http://support.microsoft.com/kb/325671/EN-US/) OFFXP: Overview of the Office XP Service Pack 2
Additionally, you may have to install Windows Installer 2.0 to install this fix. For additional information about the Windows Installer requirement for post-Office XP SP-2 fixes, click the following article number to see the article in the Microsoft Knowledge Base:
330537 (http://support.microsoft.com/kb/330537/EN-US/) OFFXP: Office XP Updates and Patches Released After September 2002 May Require Windows Installer 2.0


Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Office XP Service Pack 3 and Office XP Service Pack 3 (SP3) for Access 2002 Runtime.

Back to the top


APPLIES TO
Microsoft Access 2002 Standard Edition
Microsoft Access 97 Standard Edition

Back to the top

Keywords: 
kbqfe kbhotfixserver kbdatabase kbopenfile kbbug kbfix kbofficexppresp3fix KB821185

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.