Update: COM-Anwendungen ein Kernelmodus-Speicherleck verursacht

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Artikel-ID: 821457 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Problembeschreibung

Einige COM-Anwendungen können in den Kernelmodus-Speicher ein Speicherverlust verursachen. Wenn das Leck überprüft Systemmonitor, dass der Wert des Indikators Pool Nonpaged Bytes Lauf der Zeit steigt.

Ursache

Ein Fehler in der COM-Laufzeitumgebung möglicherweise Registrierungsbenachrichtigungen um bis zu erstellen.

Weitere Informationen

Dieser Fehler wirkt sich die Mehrheit der COM-Anwendungen nicht. Es betrifft nur Anwendungen, die wiederholt initialisieren und Deinitialisieren COM-Laufzeitumgebung. Dieser Fehler betrifft z. B. Anwendungen, die die Funktion CoInitialize und CoUninitialize -Funktion in einer Schleife aufrufen. Um zu ermitteln, ob eine Anwendung von diesem Fehler betroffen ist, führen Sie Regedit.exe, und beenden Sie dann Regedit.exe ohne Änderungen vorzunehmen. Wenn Sie ausführen und Sie dann Regedit.exe beenden ohne Änderungen vorzunehmen, werden alle Registrierungsbenachrichtigungen bereinigt.

Hinweis: Wenn Ihre Anwendung von diesem Fehler betroffen ist, stellen Sie eine Abnahme der nonpooled Seite Speicher.

Wie Sie das Update erhalten

Dieses Problem ist im Windows 2000 vor Service Pack 5 COM+ Hotfix-Paket behoben. Weitere Informationen finden Sie die folgende KB-Artikelnummer:
822618INFO: Verfügbarkeit des Windows 2000 Post-Service Pack 4 COM+ Hotfix Rollup Package 27

Lösung

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, senden Sie eine Anfrage an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Eigenschaften

Artikel-ID: 821457 - Geändert am: Donnerstag, 27. Februar 2014 - Version: 1.6
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 2000, wenn verwendet mit:
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
    • the operating system: Microsoft Windows 2000 SP4
Keywords: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbbug kbfix kbqfe KB821457 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 821457
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