Help and Support

[FP2003] [新しいドキュメント] をクリックすると "ドキュメントを作成できませんでした" というエラー メッセージが表示される

文書番号:821515
最終更新日:2004年6月16日
リビジョン:2.1

現象

Windows SharePoint Services リスト ビュー ページで [新しいドキュメント] をクリックすると、次のエラー メッセージが表示されます。
ドキュメントを作成できませんでした。
必要なアプリケーションが正しくインストールされていないか、またはこのドキュメント ライブラリのテンプレートを開けません。

次の操作を行ってみてください :
1. テンプレート名のこのドキュメント ライブラリの全般設定を確認し、テンプレートを開くために必要なアプリケーションをインストールしてください。アプリケーションを最初に使用したときにインストールする設定になっている場合、アプリケーションを実行してから、新しいドキュメントを作成してみてください。
2. このドキュメント ライブラリを変更する権限がある場合、ライブラリの全般的な設定に移動し、新しいテンプレートを構成してください。

先頭へ戻る

原因

この問題は、リスト ビュー ページの [新しいドキュメント] のテンプレート ファイルとして、Microsoft Office FrontPage 2003 で作成されたページが使用されている場合に発生します。

FrontPage 2003 で新しいページを作成する場合、デフォルトでは、Generator タグと ProgID タグがページに挿入されません。Windows SharePoint Services リスト ビュー ページの [新しいドキュメント] をクリックしたときに FrontPage でページを開くには、ページに Generator タグと ProgID タグが含まれている必要があります。

: FrontPage 2003 より前のバージョンの FrontPage では、デフォルトで新しいページに Generator タグと ProgID タグが挿入されます。

先頭へ戻る

解決方法

この問題を解決するには、FrontPage を使用してテンプレートを開き、リスト ビュー ページの [新しいドキュメント] のテンプレート ファイルとして使用されるページの <head> タグと </head> タグの間に、次の Generator タグと ProgID タグを挿入します。
 
<meta name="GENERATOR" content="Microsoft FrontPage 6.0">

<meta name="ProgId" content="FrontPage.Editor.Document">
挿入後の HTML コードの例を以下に示します。
<html>
<head>
<meta name="GENERATOR" content="Microsoft FrontPage 6.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<title>New Page 1</title>
</head>
<body>
</body>
</html>
Microsoft Office FrontPage 2003 のデフォルトの動作を変更して、新しいページに Generator タグと ProgID タグが自動的に挿入されるようにすることもできます。これを行うには、以下の手順を実行します。
1. FrontPage を起動し、[ツール] メニューの [ページのオプション] をクリックします。
2. [作成] タブをクリックし、[Generator および ProgID タグ] チェック ボックスをオンにし、[OK] をクリックします。

先頭へ戻る

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。

先頭へ戻る

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 821515 (http://support.microsoft.com/kb/821515/EN-US/) (最終更新日 2003-08-22) を基に作成したものです。

この資料に含まれているサンプル コード/プログラムは英語版を前提に書かれたものをありのままに記述しており、日本語環境での動作は確認されておりません。

先頭へ戻る


この資料は以下の製品について記述したものです。
?Microsoft Office FrontPage 2003
?Microsoft Windows SharePoint Services 2.0

先頭へ戻る

キーワード:?
kberrmsg kbbug kbfix KB821515

先頭へ戻る

"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.