NTBackup nespustí očekávaným způsobem při spuštění IT z příkazového řádku

Překlady článku Překlady článku
ID článku: 821730 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Spustit nástroj NTBackup při použití příkazového řádku nebo dávkového souboru a zahrnout parametry příkazového řádku pomocí příkazu ntbackup, NTBackup nespustí očekávaným způsobem.

Příčina

K tomuto problému dochází, pokud použijete znak lomítko a písmene v následující kombinace jako část parametru pro přepínač:
/j
/p
/g
/T
/n
/f
/d
/DS
/is
/a
/v
/r
/l
/m
/RS
hc
/UM
NTBackup přečte jednotlivých kombinací znaků, jako by byly jiného přepínač samotný (namísto pouze část parametru přepínače).

V následující syntaxi příkazu představuje parametr použit s přepínačem /d obsahuje například „ / r "kombinaci znaků. Tato kombinace znaků přečteny NTBackup jako /r přepnout namísto jako část parametr /d:
ntbackup backup "@ d:\backup.bks"/j "Úloha zálohování"/f"d:\záloha.bkf test" /d"zálohování nastavit popisek /r" /a/v: yes / /m kopie hc: off
Pokud tento příkaz byly zahrnout přepínač /r v syntaxi, by tento problém nenastane. V následující syntaxi příkazu představuje parametr /d stále obsahuje například „ / r "kombinaci znaků. Však protože přepínač /r také jasně uvedeno v syntaxi, problém se nevyskytuje:
ntbackup backup "@ d:\backup.bks"/d "test zálohovací úlohy"/f"d:\záloha.bkf" /j"zálohování nastavit popisek /r" /a/v: yes / r: no / /m kopie hc: off

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Neexistují žádné požadavky.

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy má následující atributy souborů (nebo novější). Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
  Date         Time        Version          Size   File name
  -------------------------------------------------------------
  17-Jul-2003  05:48    5.2.3790.69     1,168,384  Ntbackup.exe 

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku.

Vlastnosti

ID článku: 821730 - Poslední aktualizace: 24. července 2007 - Revize: 6.10
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwinserv2003presp1fix KB821730 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:821730

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com