Foutbericht 'De pagina kan niet worden weergegeven' wanneer u items plaatst op een site die verificatie vereist

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 821814 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Symptomen

Internet Explorer kan geen gegevens vanuit een POST-aanvraag posten en het foutbericht 'Pagina kan niet worden weergegeven' wordt weergegeven. Dit probleem kan optreden in de volgende gevallen:
  • U voert de POST-aanvraag uit op een nieuwe verbinding met een doelpagina die verificatie vereist.
  • De server beantwoordt de POST-aanvraag onmiddellijk met een '401 Toegang geweigerd'-bericht, waarna de verbinding wordt gesloten.

Oorzaak

De server sluit de verbinding zonder de hele aanvraag te lezen en de verbinding wordt hersteld wanneer de server frames ontvangt die de entiteittekst van de POST-aanvraag bevatten. Omdat de verbinding wordt hersteld, kan Internet Explorer (Wininet.dll) het bericht '401 Toegang geweigerd' niet lezen en verwerken.

Oplossing

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld als oplossing van het probleem dat in dit artikel wordt beschreven. Voer deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet mogelijk extra worden getest. Als u geen ernstige problemen ondervindt, raadt Microsoft u daarom aan te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix kan worden gedownload, is aan het begin van dit Knowledge Base-artikel een sectie 'Hotfix kan worden gedownload' opgenomen. Als een dergelijke sectie niet aanwezig is, kunt u de hotfix aanvragen bij de klantondersteuning van Microsoft.

Opmerking Als er nog andere problemen optreden of als er oplossingen vereist zijn, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking komen voor deze specifieke hotfix. Bezoek de volgende website van Microsoft voor een volledige lijst met telefoonnummers van de klantondersteuning van Microsoft of om een afzonderlijk serviceverzoek te maken:
http://support.microsoft.com/contactus/?ws=support
Opmerking Op het formulier 'Hotfix kan worden gedownload' zijn de talen vermeld waarvoor de hotfix beschikbaar is. Als uw taal daar niet bij staat, is de hotfix niet voor die taal beschikbaar. De Engelse versie van deze correctie heeft de bestandskenmerken die in de volgende tabel worden weergegeven (of recentere kenmerken). De datums en tijden voor deze bestanden worden weergegeven in UTC-notatie (Coordinated Universal Time). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Als u het verschil tussen UTC en lokale tijd wilt bepalen, gebruikt u het tabblad Tijdzone van de optie Datum en tijd in het Configuratiescherm.
   Datum       Tijd    Versie         Grootte    Bestandsnaam
   -------------------------------------------------------
   27-mei-2003  14:57  6.0.2800.1204  586.752  Wininet.dll

Workaround

U kunt dit probleem omzeilen door de POST-aanvraag alleen te gebruiken op een reeds verifieerde verbinding. U kunt dit bijvoorbeeld doen door een GET-aanvraag te verzenden voordat u de POST-aanvraag verzendt.

Status

Microsoft heeft bevestigd dat dit probleem zich kan voordoen in de Microsoft-producten die aan het begin van dit artikel worden vermeld.

Meer informatie

De hotfix die in dit artikel wordt beschreven, implementeert de volgende codewijziging in Wininet.dll:
  • Detecteer de RESET-voorwaarde voor een POST-aanvraag.
  • Sla de te posten gegevens op.
  • Voer de POST-aanvraag nogmaals uit en stel de content-lengte in op 0. U zorgt er zo voor dat er geen reset plaatsvindt, zodat het verificatieproces kan worden voltooid.
  • Voer de originele POST-aanvraag nogmaals uit.

Eigenschappen

Artikel ID: 821814 - Laatste beoordeling: woensdag 31 december 2008 - Wijziging: 1.10
De informatie in dit artikel is van toepassing op:
  • Microsoft Internet Explorer 6.0 SP1 op de volgende platformen
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 98 Tweede editie
    • Microsoft Windows Millennium Edition
    • Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows XP
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Trefwoorden: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kbie600presp2fix kbfix kbbug KB821814

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com