Kimlik Doğrulaması Gerektiren Bir Siteye Yönelik POST İşleminde "Sayfa Görüntülenemiyor" Hata İletisi Alıyorsunuz

Makale çevirileri Makale çevirileri
Makale numarası: 821814 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Belirtiler

Internet Explorer bir POST isteğinden veri gönderemeyebilir ve "Sayfa görüntülenemiyor" hata iletisini alabilirsiniz. Bu sorun, aşağıdaki koşullar doğruysa oluşabilir:
  • POST isteğini yeni bir bağlantıda, kimlik doğrulama gerektiren bir hedef sayfayla yapıyorsunuz.
  • Sunucu POST isteğini hemen "401 Erişim Reddedildi" hatasıyla yanıtlıyor ve bağlantıyı kapatıyor.

Neden

Sunucu, isteğin gövdesini tümüyle okumadan bağlantıyı kapatıyor ve POST isteğinin varlık gövdesini içeren çerçeveleri aldığında bağlantıyı sıfırlıyor. Bağlantı sıfırlandığı için, Internet Explorer (Wininet.dll) "401 Erişim Reddedildi" yanıtını okuyup işleyemez.

Çözüm

Desteklenen bir düzeltme Microsoft'tan edinilebilir. Ancak bu düzeltmenin, yalnızca bu makalede anlatılan sorunu gidermesi amaçlanmıştır. Bu düzeltmeyi yalnızca bu sorunla karşılaşan sistemlere uygulayın. Bu düzeltmeye ek sınama uygulanabilir. Bu nedenle, sorundan ciddi olarak etkilenmiyorsanız, bu düzeltmeyi içeren bir sonraki yazılım güncelleştirmesini beklemeniz önerilir.

Karşıdan yüklenebilecek bir düzeltme varsa, bu Bilgi Bankası makalesinin başında "Düzeltme karşıdan yüklenebilir" bölümü bulunur. Bu bölüm görünmüyorsa, düzeltmeyi edinmek üzere Microsoft Müşteri Hizmetleri ve Destek ekibine başvurun.

Not Ek sorunlar oluşursa veya sorun giderme işlemleri gerekirse, ayrı bir hizmet isteği oluşturmanız gerekebilir. Ek destek sorularına ve bu düzeltme için geçerli olmayan sorunlara normal destek ücretleri uygulanır. Microsoft Müşteri Hizmetleri ve Destek telefon numaralarının tam listesi veya ayrı bir hizmet isteği oluşturmak için, aşağıdaki Microsoft Web sitesini ziyaret edin:
http://support.microsoft.com/contactus/?ws=support
Not "Düzeltme karşıdan yüklenebilir" formunda, düzeltmenin kullanılabilir olduğu diller görüntülenir. Kendi dilinizi görmüyorsanız, bunun nedeni bu dil için kullanılabilir bir düzeltme bulunmamasıdır. Bu düzeltmenin İngilizce sürümü, aşağıdaki tabloda listelenen dosya özniteliklerine (veya daha yenisi) sahiptir. Bu dosyalarla ilgili tarihler ve saatler UTC (eşgüdümlü evrensel saat) kullanılarak listelenmiştir. Dosya bilgilerini görüntülediğinizde yerel saate dönüştürülür. UTC ve yerel saat arasındaki farkı bulmak için, Denetim Masası'ndaki Tarih ve Saat aracında Saat Dilimi sekmesini kullanın.
   Tarih        Saat   Sürüm          Boyut    Dosya adı
   -------------------------------------------------------
   27 May 2003  14:57  6.0.2800.1204  586.752  Wininet.dll

Pratik Çözüm

Bu soruna geçici bir çözüm olarak, POST isteğini kimlik doğrulaması yapılmış bir bağlantıda kullanmaya dikkat edin. Bunun için, örneğin, POST isteğini göndermeden önce GET isteği gönderebilirsiniz.

Durum

Microsoft, bu makalenin başında listelenen Microsoft ürünlerinde bir sorun olduğunu onaylamıştır.

Daha fazla bilgi

Bu makalede açıklanan düzeltme, Wininet.dll dosyasında bir kod değişikliği uygulayarak şunları gerçekleştirir:
  • Bir POST isteğindeki RESET koşulunu algılar.
  • Gönderilecek verileri kaydeder.
  • POST isteğini içerik uzunluğu 0'a ayarlanmış olarak yeniden dener. Böylece, sıfırlama oluşması engellenir ve kimlik doğrulama işleminin tamamlanması sağlanır.
  • Orijinal POST isteğini yeniden dener.

Özellikler

Makale numarası: 821814 - Last Review: 31 Aralık 2008 Çarşamba - Gözden geçirme: 1.10
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Internet Explorer 6.0 SP1, Ne zaman ne ile kullanilir:
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 98 İkinci Sürüm
    • Microsoft Windows Millennium Edition
    • Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows XP
    • Microsoft Windows Server 2003 Standard Edition
Anahtar Kelimeler: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kbie600presp2fix kbfix kbbug KB821814

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com