Article ID: 822116 - Last Review: November 15, 2007 - Revision: 1.6

You receive an error message when you export to XML in Commerce Server 2002 SP1

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
Expand all | Collapse all

SYMPTOMS

When you export to XML in Microsoft Commerce Server 2002 Service Pack 1 (SP1), you receive the following error message in the event log:
Failure on Catalog Export, Cannot sort a row of size 8276, which is greater than 8094

CAUSE

The Catalog export process submits a query to the computer that is running Microsoft SQL Server by using a plan. If the computer that is running SQL Server cannot complete the plan, the query is not successful. The Catalog export process does not include exception handling, and this may cause a failure.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   12-Jun-2003  00:48  4.5.3061.0        954,268  Catalog.dll


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

The hotfix implements error handling that runs failed queries with the ROBUST PLAN hint. This addition makes sure that the request is completed with some effect on performance.

APPLIES TO
  • Microsoft Commerce Server 2002 Service Pack 1
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kbfix kbbug KB822116
 

Article Translations

 

Related Support Centers